Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 20
So here's the deal.....Yesterday i was using Windows on my first hard drive, it crashed, so i restarted my computer and selected SuSE on the boot screen. It just went ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Newbie uninvisible's Avatar
    Join Date
    May 2005
    Location
    Canada
    Posts
    224

    SuSE restarts @ grub boot screen


    So here's the deal.....Yesterday i was using Windows on my first hard drive, it crashed, so i restarted my computer and selected SuSE on the boot screen. It just went blank and my computer restarted and went back to the boot screen. I booted up SuSE using failsafe and typing startkde and got this message:

    Code:
    xset: unable to open display ""
    xsetroot: unable to open display ``
    ksplash: cannot connect to xserver
    KDEinit: Aborting. $DISPLAY is not set
    Warning: connect () failed: No such file or directory
    KSMserver: cannot connect to x server
    ERROR: Couldn't attach to DCOP server!
    Startkde: Shutting down.....
    error:can't connect kdeinit!
    unix-connect: can't connect to server unix:/tmp/ksocket-jim-kim/linux-48d4-43cafb8b
    But i could boot in failsafe using startx. Can anybody shed some light on fixing this?
    Linux. Get Counted!! http://counter.li.org/

  2. #2
    Linux Guru AlexK's Avatar
    Join Date
    Feb 2005
    Location
    Earth
    Posts
    3,379
    ...
    KDEinit: Aborting. $DISPLAY is not set
    ...
    that shows it can't find a monitor. In failsafe, login as root and run sax2 and resetup the display and graphics.
    Life is complex, it has a real part and an imaginary part.

  3. #3
    Linux Newbie uninvisible's Avatar
    Join Date
    May 2005
    Location
    Canada
    Posts
    224
    Hi Alex, i don't know what to reset in Sax2, everything appears correct/as it should be. I don't know what else to check.
    Linux. Get Counted!! http://counter.li.org/

  4. #4
    Linux Newbie uninvisible's Avatar
    Join Date
    May 2005
    Location
    Canada
    Posts
    224
    I just found this post on another forum about the same problem as mine. Although i don't see the solution after reading it. Does it make sense to anyone?
    Linux. Get Counted!! http://counter.li.org/

  5. #5
    Linux Guru budman7's Avatar
    Join Date
    Oct 2004
    Location
    Knee deep in Grand Rapids, Michigan
    Posts
    3,242
    Quote Originally Posted by uninvisible
    I just found this post on another forum about the same problem as mine. Although i don't see the solution after reading it. Does it make sense to anyone?
    In the LQ thread you linked to, that guys problem was that he was trying to log in as root to X.
    Is that the problem you are having?
    Can you login is normal user?
    How to know if you are a geek.
    when you respond to "get a life!" with "what's the URL?"
    - Birger

    New users read The FAQ

  6. #6
    Linux Newbie uninvisible's Avatar
    Join Date
    May 2005
    Location
    Canada
    Posts
    224
    In the LQ thread you linked to, that guys problem was that he was trying to log in as root to X.
    Is that the problem you are having?
    Can you login is normal user?
    No i'm not trying to log in as root. The problem is when at the boot screen, where i have the option to select: SuSE, Windows, Floppy, or SuSE failsafe.
    When i pick SuSE as per usual, the computer restarts and brings me right back to the boot screen. When i login using SuSE failsafe, and enter startkde i get the error in my first post (same as the thread i linked to) So right now i'm just logging in failsafe and using startx which does work. So i'm trying to figure out if it's an xserver problem, kde not initializing, or something else i don't know about.
    Linux. Get Counted!! http://counter.li.org/

  7. #7
    Linux Guru budman7's Avatar
    Join Date
    Oct 2004
    Location
    Knee deep in Grand Rapids, Michigan
    Posts
    3,242
    I believe that you don't have an xdm installed correctly.
    To make sure that this is the problem, edit your inittab file so that you boot into runlevel 3.
    Code:
    vi /etc/inittab
    Then hiy " i " to bring you to INSERT mode.
    Now replace the initdefault=5 to initdefault=3
    Hit ESC to bring you back to COMMAND mode.
    Type "ZZ" to quit and save your work.
    Now reboot, login and try "startx" from there.
    How to know if you are a geek.
    when you respond to "get a life!" with "what's the URL?"
    - Birger

    New users read The FAQ

  8. #8
    Linux Newbie uninvisible's Avatar
    Join Date
    May 2005
    Location
    Canada
    Posts
    224
    This is what i have:

    Code:
    # The default runlevel is defined here
    id:5:initdefault:
    Do i just replace 5 with 3 or write initdefault=3 in place of what i have?
    Linux. Get Counted!! http://counter.li.org/

  9. #9
    Linux Guru AlexK's Avatar
    Join Date
    Feb 2005
    Location
    Earth
    Posts
    3,379
    replace the 5 with a 3. i.e. make the line read like id:3:initdefault:
    Life is complex, it has a real part and an imaginary part.

  10. #10
    Linux Guru budman7's Avatar
    Join Date
    Oct 2004
    Location
    Knee deep in Grand Rapids, Michigan
    Posts
    3,242
    Just replace the 5 with a 3.
    How to know if you are a geek.
    when you respond to "get a life!" with "what's the URL?"
    - Birger

    New users read The FAQ

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •