Find the answer to your Linux question:
Results 1 to 3 of 3
Heya, I see many people have had this problem. I found one fix on Google but it didn't work for me (SuSE 9.1 Pro). When I try and ./configure GTK ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined! sgt_pinky's Avatar
    Join Date
    Feb 2006
    Location
    Melbourne, Australia
    Posts
    2

    GTK 2.8.12 build problem (Can't find Pango)


    Heya,

    I see many people have had this problem. I found one fix on Google but it didn't work for me (SuSE 9.1 Pro).

    When I try and ./configure GTK 2.8.12 I get the following error at the end:

    checking Pango flags... -I/usr/local/include/pango-1.0 -I/usr/local/include/glib-2.0 -I/usr/local/lib/glib-2.0/include -I/usr/local/include/cairo -L/usr/local/lib -lpangocairo-1.0 -lpango-1.0 -lcairo -lgobject-2.0 -lgmodule-2.0 -ldl -lglib-2.0
    configure: error:
    *** Can't link to Pango. Pango is required to build
    *** GTK+. For more information see http://www.pango.org
    If I have a look at my pkg-config to see what's installed:

    gtk/gtk+-2.8.12> pkg-config --list-all
    gmodule-export-2.0 GModule - Dynamic module loader for GLib
    cairo cairo - Multi-platform 2D graphics library
    pangocairo Pango Cairo - Cairo rendering support for Pango
    freetype2 FreeType 2 - A free, high-quality, and portable font engine.
    gmodule-2.0 GModule - Dynamic module loader for GLib
    fontconfig Fontconfig - Font configuration and customization library
    pangoft2 Pango FT2 - Freetype 2.0 font support for Pango
    glib-2.0 GLib - C Utility Library
    gthread-2.0 GThread - Thread support for GLib
    gobject-2.0 GObject - GLib Type, Object, Parameter and Signal Library
    gmodule-no-export-2.0 GModule - Dynamic module loader for GLib
    pangox Pango X - X Window System font support for Pango
    pango Pango - Internationalized text handling
    atk Atk - Accessibility Toolkit
    gtk/gtk+-2.8.12>
    So Pango is most certainly there. I had a look in the ./configure script for GTK, and it definitely checks pkg-config to see if Pango is there as well, which makes me think that there must be more to the problem.

    I have checked /etc/ld.so.conf, and all the paths seem correct. I have opened new Konsole's and run ldconfig countless times to make sure that the library paths are updated - no help.

    TIA,

    Pinky

    **EDIT**
    Here is the error in config.log:

    configure:31615: gcc -o conftest -g -O2 -Wall -I/usr/local/include/pango-1.0 -I/usr/local/include/glib-2.0 -I/usr/local/lib/glib-2.0/include -I/usr/local/include/cairo -I/usr/local/include -I/usr/local/include/freetype2 -I/usr/X11R6/include conftest.c -L/usr/local/lib -lpangocairo-1.0 -lcairo -lpangoft2-1.0 -lpango-1.0 -lgobject-2.0 -lgmodule-2.0 -ldl -lglib-2.0 >&5
    /usr/lib64/gcc-lib/x86_64-suse-linux/3.3.3/../../../../x86_64-suse-linux/bin/ld: cannot find -lpangocairo-1.0
    **EDIT2**
    I rebuilt Pango, and it seems to include Cairo. This is the output when I ./configure Pango:
    checking for CAIRO... yes
    checking for cairo_scaled_font_get_ctm in -lcairo... no
    checking for cairo_scaled_font_text_extents in -lcairo... no
    checking for cairo_surface_write_to_png in -lcairo... no
    checking for cairo_xlib_surface_create in -lcairo... no
    checking for cairo_win32_scaled_font_select_font in -lcairo... no
    checking for cairo_ft_scaled_font_lock_face in -lcairo... no
    checking for cairo_atsui_font_face_create_for_atsu_font_id in -lcairo... no

    These are the libraries in my /usr/local/lib

    local/lib> ls libpango*
    libpango-1.0.la libpango-1.0.so.0.1105.0 libpangoft2-1.0.so.0 libpangox-1.0.so
    libpango-1.0.so libpangoft2-1.0.la libpangoft2-1.0.so.0.1105.0 libpangox-1.0.so.0
    libpango-1.0.so.0 libpangoft2-1.0.so libpangox-1.0.la libpangox-1.0.so.0.1105.0
    local/lib>

  2. #2
    Just Joined! Foolse's Avatar
    Join Date
    Feb 2006
    Location
    Mellbystrand, Sweden
    Posts
    28

    pkgconfig directory

    I have had almost the same problem while compiling GTK, only with another package. The trick was simply to download the tar for the missing package and recompile it. (I am sure there is another way, but I couldn't find one).

    After recompiling it I got a file in /usr/local/lib/pkgconfig/ named *packagename*.pc so for pango it is called pango.pc I also have a file called pangocairo.pc.

    My pango.pc file looks like this:

    prefix=/usr/local
    exec_prefix=${prefix}
    libdir=${exec_prefix}/lib
    includedir=${prefix}/include

    pango_module_version=1.4.0

    Name: Pango
    Description: Internationalized text handling
    Version: 1.10.3
    Requires: glib-2.0,gobject-2.0,gmodule-no-export-2.0
    Libs: -L${libdir} -lpango-1.0
    Cflags: -I${includedir}/pango-1.0


    The .pc file is used by pkgconfig for linking information as far as I understand...


    Hope this helps! It sure worked for me...

    Best,
    /Ove

    P.S. And if anyone knows of another way of creating the .pc files I would be VERY intereted to hear about it!

  3. #3
    Just Joined!
    Join Date
    Jul 2010
    Posts
    1
    make sure you have those lib -L/usr/local/lib -lpangocairo-1.0 -lpango-1.0 -lcairo -lgobject-2.0
    -lgmodule-2.0 -ldl -lglib-2.0

    In gtk+-2.21.1

    mark function:

    _gtk_marshal_OBJECT__VOID in gtk+-2.21.1/perl/marshalers.c

    modify configure:

    if ac_fn_c_try_link "$LINENO"; then :
    :
    else
    as_fn_error "
    *** Can't link to Pango. Pango is required to build
    *** GTK+. For more information see xxxxxxxxxxxx" "$LINENO" 5
    fi

    to

    if ac_fn_c_try_link "$LINENO"; then :
    :
    fi

    make clean

    export PREFIX=/usr/gtkdfb

    export LDFLAGS="-L$PREFIX/lib -Wl,-rpath,$PREFIX/lib"

    export CPPFLAGS="-I$PREFIX/include"

    export PKG_CONFIG_PATH=$PREFIX/lib/pkgconfig

    echo gio_can_sniff=yes>arm-linux.cache

    echo ac_cv_path_GTK_UPDATE_ICON_CACHE=/usr/bin/gtk-update-icon-cache>>arm-linux.cache

    echo ac_cv_path_GDK_PIXBUF_CSOURCE=/usr/bin/gdk-pixbuf-csource>>arm-linux.cache

    CC=arm-linux-gcc ./configure --host=arm-linux --prefix=$PREFIX --with-gdktarget=directfb --without-x --disable-modules --with-included-loaders=ani,bmp,gif,ico,png,pnm,ras,tga,wbmp,xbm,x pm --enable-static=yes --enable-shared=no --without-libtiff --without-libjpeg --disable-glibtest --cache-file=arm-linux.cache

    make

    make install

    refre to
    wretch.cc
    /
    blog
    /
    fatalfeel

  4. $spacer_open
    $spacer_close

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •