Find the answer to your Linux question:
Results 1 to 2 of 2
I removed my previous versions of amarok 1.3.8 and updated it with these files : amarok -xmms amarok -xine amarok -libvisual amarok -arts amarok -gstreamer amarok all those files were ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jan 2006
    Posts
    26

    amarok 1.4 installation


    I removed my previous versions of amarok 1.3.8 and updated it with these files :
    amarok -xmms
    amarok -xine
    amarok -libvisual
    amarok -arts
    amarok -gstreamer
    amarok

    all those files were version 1.4

    Dependancy check was ok i got all 5 components installed except the main component, amarok. It failed for some reason . here's what I get :

    ERROR(InstTarget:E_RpmDB_subprocess_failed)
    ---
    error: db4 error(-30978 )from db->close: DB_RUNRECOVERY: Fatal error, run database recovery
    rpmdb: PANIC: fatal region error detected; run recovery
    error: db4 erro (-30978 ) from db->close: DB_RUNRECOVERY: Fatal error, run database recovery
    rpmdb: PANIC: fatal region error detected; run recovery
    error: db4 error(-30978 ) from dbenv->close: DB_RUNRECOVERY: Fatal error, run database recovery

    My installation source is set to retrieve updates from Guru. Please help !!! thanks

  2. #2
    Linux Engineer oldcpu's Avatar
    Join Date
    Aug 2005
    Location
    Europe
    Posts
    1,142

    perhaps delete collection.db

    I read on another forum that you need to go to home/user/.kde/share/apps/amarok and delete the collection.db.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •