Find the answer to your Linux question:
Results 1 to 5 of 5
I've set up a linux box (Suse 9.3) to act as a fileserver for windows clients (2 xp and 1 2k). So far I can see the Samba shares on ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Feb 2006
    Posts
    3

    Linux Fileserver


    I've set up a linux box (Suse 9.3) to act as a fileserver for windows clients (2 xp and 1 2k). So far I can see the Samba shares on the linux box, however from WinXP, My Network Neighborhood, I can see the "users on Samba" however, when I click to open the folder, I get the message:

    \\Linux\users is not accessible. You might not have permissions to use this network resource. Contact the administrator (me of this server to find out if you have access permissions. The network path was not found.

    Any suggestions?
    Last edited by narnia; 02-23-2006 at 03:50 PM. Reason: typo

  2. #2
    Just Joined!
    Join Date
    Feb 2006
    Posts
    3
    BTW, I can ping the linux server from winxp. Maybe this will help:

    SMB.CONF

    # smb.conf is the main Samba configuration file. You find a full commented
    # version at /usr/share/doc/packages/samba/examples/smb.conf.SUSE if the
    # samba-doc package is installed.
    # Date: 2005-04-04
    [global]
    workgroup = INSIGHT
    printing = cups
    printcap name = cups
    printcap cache time = 750
    cups options = raw
    printer admin = @ntadmin, root, administrator
    username map = /etc/samba/smbusers
    map to guest = Bad User
    include = /etc/samba/dhcp.conf
    logon path = \\%L\profiles\.msprofile
    logon home = \\%L\%U\.9xprofile
    logon drive = P:
    add machine script = /usr/sbin/useradd -c Machine -d /var/lib/nobody -s /bin/false %m$
    domain logons = No
    domain master = No
    security = user
    idmap gid = 10000-20000
    idmap uid = 10000-20000

    [homes]
    comment = Home Directories
    valid users = %S
    browseable = No
    read only = No
    inherit acls = Yes

    [profiles]
    comment = Network Profiles Service
    path = %H
    read only = No
    store dos attributes = Yes
    create mask = 0600
    directory mask = 0700

    [users]
    comment = All users
    path = /home
    read only = No
    inherit acls = Yes
    veto files = /aquota.user/groups/shares/

    [groups]
    comment = All groups
    path = /home/groups
    read only = No
    inherit acls = Yes

    [printers]
    comment = All Printers
    path = /var/tmp
    printable = Yes
    create mask = 0600
    browseable = No

    [print$]
    comment = Printer Drivers
    path = /var/lib/samba/drivers
    write list = @ntadmin root
    force group = ntadmin
    create mask = 0664
    directory mask = 0775

    [clientfiles]
    comment = Directory for client files
    inherit acls = Yes
    path = /home/lbunnell/ClientFiles
    read only = No

  3. #3
    Linux Enthusiast
    Join Date
    Dec 2004
    Posts
    637
    You have to convert the UNIX user accounts to Samba accounts. Once you do this, set their Samba passwords to the same password used for Windows authentication. Once this is performed, you should be good-to-go. An easy tool to use to accomplish this is Webmin.

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Feb 2006
    Posts
    3
    I had previously added my unix users using

    # smbpasswd -a user_name

    Is that what you mean? If so, that didn't seem to help.

  6. #5
    Linux Guru AlexK's Avatar
    Join Date
    Feb 2005
    Location
    Earth
    Posts
    3,379
    For your users share, if you set read only to no, it could be causing the problem. Try setting browseable to yes as well and see if that helps. i.e.:

    [users]
    comment = All users
    path = /home
    read only = No
    browseable = Yes
    inherit acls = Yes
    veto files = /aquota.user/groups/shares/

    Also you may have to change the permission of the /home directory, i.e. chmod 755 /home as root.

    narnia, try not to double post on the same topic. Your other thread has been deleted.
    Last edited by AlexK; 02-23-2006 at 11:37 PM.
    Life is complex, it has a real part and an imaginary part.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •