Find the answer to your Linux question:
Results 1 to 2 of 2
ok so basically whats happened is... i went round installing random software and packages to try and get the new amarok working. after i installed one that was meant to ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Feb 2006
    Posts
    10

    Unhappy Help glibc.rpm... need to fix my computer!


    ok so basically whats happened is...

    i went round installing random software and packages to try and get the new amarok working. after i installed one that was meant to give me libc.so.6 the yast -i "rpm pacakage" stopped working and kept giving me this error: "warning: the ncurses frontend is installed but does not work
    You need to install yast2-ncurses to use the YaST2 text mode interface"
    i tryed opening yast and it doesnt work.
    i then tried to open JuK and it gave this error :
    "#14 0x413dcea0 in __libc_start_main () from /lib/tls/libc.so.6
    #15 0x0806da81 in ?? ()"

    I then came to the conclusion that there was a problem with thie libc.so.6 that i had tried to install. and so i went to find another package. i found one and tried to install using "rpm -ivh (rpm name)" and this gave me a long list after saying:
    "Preparing... ########################################### [100%]
    package glibc-2.3.5-40 (which is newer than glibc-2.3.4-23.4) is already installed"

    i would like to downgrade it to one that works but i do not have access to Yast and so is there a way of uninstalling using the rpm command or is there another option i can do?

    thx in advance

  2. #2
    Linux Engineer oldcpu's Avatar
    Join Date
    Aug 2005
    Location
    Europe
    Posts
    1,142

    on the wrong direction to fix your PC

    Quote Originally Posted by firecraker180
    i went round installing random software and packages to try and get the new amarok working.
    I assume you are using SuSE-9.3 or SuSE-10.0 (and not SuSE-10.1)? Please, I think you are going about this the wrong way. The easiest way to update your software is to use a Software Package Management package such as Smart (or the apt4rpm/synaptic combination). With Smart installed, you can easily select Guru (latest Amarok) and Packman (latest xine-lib, etc ...) packages to update your SuSE multimedia. Smart will examine the dependencies, making the repair/update of any dependency issues much easier and quicker. Upgrades that took hours (and maybe days) in the past, with Smart may take only minutes.

    Quote Originally Posted by firecraker180
    i tryed opening yast and it doesnt work.
    YaST doesn't work??? Please, I recommend you get your priorities straight. I recommend you sort out your YaST problems, BEFORE you try anything else. Did you try going to a konsole and type "yast" or "yast2" (using root permissions)? What error messages do you get?

    Apologies if my answer is not exactly focused the way you want, but I am concerned you are headed in the wrong direction to fix things, and you are making this much more difficult than it needs to be.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •