Find the answer to your Linux question:
Results 1 to 9 of 9
I can boot from GRUB to SUSE 10 then to the Nividia screen but then I gives me an X and stops...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Engineer cheetahman's Avatar
    Join Date
    Dec 2004
    Location
    New York
    Posts
    1,130

    SuSE Linux 10 Login Problem


    I can boot from GRUB to SUSE 10 then to the Nividia screen but then I gives me an X and stops
    \"TTFN Taa Taa For Now\" by Tigger in Winnie the Pooh
    http://www.distrowatch.com Linux Distros
    We Live in a Windows World but there is Linux to save the day

  2. #2
    Linux Guru techieMoe's Avatar
    Join Date
    Aug 2004
    Location
    Texas
    Posts
    9,496
    Can you boot to non-graphical mode, try startx and post the errors you get?
    Registered Linux user #270181
    TechieMoe's Tech Rants

  3. #3
    Linux Engineer cheetahman's Avatar
    Join Date
    Dec 2004
    Location
    New York
    Posts
    1,130
    I can boot into Failsafe from GRUB and I found this

    After installation lap top monitor does not display

    If after installation, on your lap top, you reboot and your lap top does not display anything follow these steps:

    * Reboot in Failsafe mode
    * Login as root
    * At the command prompt type: sax2 -m 0=vesa
    * Configure video settings and test them
    * Reboot in normal mode.

    and I haven't used the Rescue cd yet would that fix it
    \"TTFN Taa Taa For Now\" by Tigger in Winnie the Pooh
    http://www.distrowatch.com Linux Distros
    We Live in a Windows World but there is Linux to save the day

  4. #4
    Linux Guru techieMoe's Avatar
    Join Date
    Aug 2004
    Location
    Texas
    Posts
    9,496
    You should be able to type a 3 at the boot screen. I'm not entirely sure (since I haven't used SuSE 10 recently) but Failsafe might boot you into non-graphical as well.
    Registered Linux user #270181
    TechieMoe's Tech Rants

  5. #5
    Linux Engineer cheetahman's Avatar
    Join Date
    Dec 2004
    Location
    New York
    Posts
    1,130
    Quote Originally Posted by techieMoe
    You should be able to type a 3 at the boot screen. I'm not entirely sure (since I haven't used SuSE 10 recently) but Failsafe might boot you into non-graphical as well.
    While in Failsafe and if I boot into Failsafe shouln't I be able to use startx and would the Repair Cd fix it since I haven't tried them yet also the default is GNOME but I switched to KDE.
    \"TTFN Taa Taa For Now\" by Tigger in Winnie the Pooh
    http://www.distrowatch.com Linux Distros
    We Live in a Windows World but there is Linux to save the day

  6. #6
    Linux Guru techieMoe's Avatar
    Join Date
    Aug 2004
    Location
    Texas
    Posts
    9,496
    Quote Originally Posted by cheetahman
    While in Failsafe and if I boot into Failsafe shouln't I be able to use startx
    As I said, I haven't used SuSE in a while so I don't know. Give it a shot.

    and would the Repair Cd fix it since I haven't tried them yet
    It *might*, but I don't honestly know if there's a "recover X Windows" option.

    also the default is GNOME but I switched to KDE.
    What process did you use to switch to KDE? Perhaps X Windows is just confused as to which desktop you want.
    Registered Linux user #270181
    TechieMoe's Tech Rants

  7. #7
    Linux Engineer cheetahman's Avatar
    Join Date
    Dec 2004
    Location
    New York
    Posts
    1,130
    Set as default command before logging in and here are the results from startx

    Using configfile /etc/X11/xorg.conf

    Coud not init font path element /usr/X11R6/Lib/X11/fonts/local
    Coud not init font path element /usr/X11R6/Lib/X11/fonts/CFD

    Removing from list

    /opt/gnome/bin/gnome/gnome-session:symbol lookup error:
    /opt/gnome/lib/libgtk-x11-2.0.so.0:undefined symbol:
    g_object-compat_control

    Also the install cd repair didn't work
    \"TTFN Taa Taa For Now\" by Tigger in Winnie the Pooh
    http://www.distrowatch.com Linux Distros
    We Live in a Windows World but there is Linux to save the day

  8. #8
    Just Joined!
    Join Date
    Apr 2005
    Posts
    7
    try to look for the file .xinitrc at /root (or whatever your home directory is) and delete the file then do an init 6 and try logging in again.

  9. #9
    Linux Engineer cheetahman's Avatar
    Join Date
    Dec 2004
    Location
    New York
    Posts
    1,130
    I fixed it by going to failsafe loging in than rootlogging in command kdm and changed gdm to kdm but GNOME still doesn't work which I can probably fix when I upgrade it to the latest version.
    \"TTFN Taa Taa For Now\" by Tigger in Winnie the Pooh
    http://www.distrowatch.com Linux Distros
    We Live in a Windows World but there is Linux to save the day

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •