Problem 1.

The last time I updated the kernel (2 weeks, tops) I had to re-install SUSE to try and get it to boot. In other words, the update caused SUSE not to detect my Hard Drive. This problem is decribed in more detail http://www.linuxforums.org/forum/sus...n-respond.html.
-------------------------------------------
Problem 2. (SOLVED)

SUSE uses 50% CPU when idle. I have a 2.8ghz Hyperthreaded P4. This seems to be too much. Simply using the drag-selector causes CPU usage to go to 100% and the desktop to severely stutter. I tried installing the latest nVidia drivers, but it doesn't support my kernel.

EDIT: I think I found the problem. nvidia-installer is taking 28% of my CPU. It won't let me terminate. What should I do?

EDIT2: Did an su to root and killed it from console.
-------------------------------------------
Problem 3.

I cannot figure out for the life of me how to print to a Printer residing on a networked Windows machine. The printer is an HP DeskJet 722C. It is shared on all my windows PCs. It doesnt show up when browsing the network with smb://.
-------------------------------------------

Truly the only reason I am so attatched to windows now is printing and gaming. I would at least like to have SUSE print.