Find the answer to your Linux question:
Results 1 to 3 of 3
I have a full 120gig partition that was formated reiserfs with FC3. I can't mount a reiserfs drive with suse10. This drive is known good and worked fine under FC3. ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Mar 2006
    Posts
    1

    Unable to mount old reiserfs partition


    I have a full 120gig partition that was formated reiserfs with FC3. I can't mount a reiserfs drive with suse10. This drive is known good and worked fine under FC3. Is there anything I can try before trying to get ahold of a huge ass drive to change it to ext3?

    When I run "mount -t reiserfs /dev/hdg1 /mnt/store2" is outputs
    Code:
    wrong fs type, bad option, bad superblock on /dev/hdg1,
    missing codepage or other error
    In some cases useful info is found in syslog - try
    dmesg | tail or so
    "dmesg | tail" shows the error
    Code:
    ReiserFS: hdg1: warning: sh-2021: reiserfs_fill_super: can not find reiserfs on hdg1
    But it is definitly formatted reiserfs

  2. #2
    Linux Engineer
    Join Date
    Aug 2004
    Posts
    826
    The Fedora Core installer (still) does not have support for reiserfs. Even though you say it's reiserfs, are you sure it's not ext2/3? mount ( will guess the filesystem if -t is not specified. Try without the -t option and see if it works.
    Code:
    mount /dev/hdg1 /mnt/store2

  3. #3
    Linux Engineer
    Join Date
    Aug 2004
    Posts
    826
    Er, that smiley is supposed to be
    Code:
    mount (8)
    Damn smileys.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •