Find the answer to your Linux question:
Results 1 to 7 of 7
I'm on a DSL connection, and Bellsouth is my ISP. I'm currently running in Knoppix, and it was able to detect my network settings just fine, it seems. I cannot ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Mar 2006
    Posts
    3

    Unhappy Can't get internet to work in SuSE 9.1! Please assist! (DSL)


    I'm on a DSL connection, and Bellsouth is my ISP. I'm currently running in Knoppix, and it was able to detect my network settings just fine, it seems. I cannot get SuSE to allow me to get online. Help would be appreciated.

  2. #2
    Linux User
    Join Date
    Jan 2006
    Posts
    414
    More info if you please, how are you connected to the internet? What have you tried? If connected through LAN can you ping your router from the command line? Have you gone to Yast and configured the connection?

    help us help you.

  3. #3
    TBD
    TBD is offline
    Just Joined! TBD's Avatar
    Join Date
    Mar 2006
    Posts
    29
    Hi,

    It sounds like your not being assigned an IP# from your ISP's DHCP server.
    Open a terminal while using knoppix and type "ifconfig etho0" without quotes, this will display your IP#, MAC address, and your ISP's DNS server - Then run the same command under SUSE and see what's missing.

    Also ... check your "/etc/resolv.conf" file in Knoppix and take note of the settings ... and then check it in SUSE and edit in your DNS servers IP# if it's missing or different from the Knoppix configuration.

    Good Luck.

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Mar 2006
    Posts
    3
    I connect to the internet through ethernet to a Westell modem. It's a DSL connection and this is the only computer on this network. I tried configuring the connection and network card in YaST using the documentation that came with SuSE. Later, I will try running the commands that you suggested and trying to configure it once again. (I was frustrated with SuSE, so I tried installing another build of Linux. This computer seems to reject Linux somehow. I tried Ubuntu, and the X server wouldn't start. I tried SuSE, and I'm having this problem. I tried Slackware, and couldn't get it to install. It's quite frustrating, thank you for the help.)

  6. #5
    TBD
    TBD is offline
    Just Joined! TBD's Avatar
    Join Date
    Mar 2006
    Posts
    29
    If you like SUSE but Knoppix configures your hardware better ... i can show you how to copy the settings from Knoppix into SUSE.

    If your in a downloading mood ... grab SUSE 10.0.
    The hardware detection is alot better and it's a much nicer version all around.
    http://en.opensuse.org/Released_Version

  7. #6
    Just Joined!
    Join Date
    Mar 2006
    Posts
    3
    That would be most appreciated! But I don't really have the time for downloading and burning 5 blanks, so I'll go with the idea of copying the information from Knoppix to SuSE. Thank you very much.

  8. #7
    TBD
    TBD is offline
    Just Joined! TBD's Avatar
    Join Date
    Mar 2006
    Posts
    29
    It may be a case where the NIC has a conflict or is unsupported ... copying config files won't fix that. Plus the copying between machines is mainly for X settings, Kernel's, & modules.

    Most of the Network support or lack of (as well as config's) differ from distro to distro. Even between Debian and Knoppix (with Knoppix being a Debian spin-off).

    I didn't mean to raise false hope with the copying, but it would mean a kernel & Module replacement if it's an unsupported NIC in SUSE. It actually goes exceptionally smooth though.

    Let's copy some basic settings and see if we can't wake this NIC up.

    All commands surrounded by quote marks " " do not need the quotes when typed into your terminal.

    -----------------------------------------------------

    Run ifconfig in Knoppix (while online) and write all of the info down that you will need ... netmask, IP#, Bcast.

    ifconfig

    linux:/home/tim # ifconfig
    eth0 Link encap:Ethernet HWaddr 00:69:00:9A:15:F6
    inet addr:192.168.0.2 Bcast:192.168.0.255 Mask:255.255.255.0
    inet6 addr: fe80::269:ff:fe9a:15f6/64 Scope:Link
    UP BROADCAST NOTRAILERS RUNNING MULTICAST MTU:1500 Metric:1
    RX packets:2076 errors:0 dropped:0 overruns:0 frame:0
    TX packets:2621 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:1000
    RX bytes:1331692 (1.2 Mb) TX bytes:642348 (627.2 Kb)
    Interrupt:185 Base address:0xe000

    lo Link encap:Local Loopback
    inet addr:127.0.0.1 Mask:255.0.0.0
    inet6 addr: ::1/128 Scope:Host
    UP LOOPBACK RUNNING MTU:16436 Metric:1
    RX packets:52 errors:0 dropped:0 overruns:0 frame:0
    TX packets:52 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:0
    RX bytes:3360 (3.2 Kb) TX bytes:3360 (3.2 Kb)

    ------------------------------------------------------

    On very rare occasions you might find that your NIC card doesn't work because it shares both an interrupt and memory access address with some other device (IRQ).


    cat /proc/interrupts

    tim@linux:~> cat /proc/interrupts
    CPU0
    0: 600508 IO-APIC-edge timer
    1: 304 IO-APIC-edge i8042
    8: 0 IO-APIC-edge rtc
    9: 0 IO-APIC-level acpi
    12: 106431 IO-APIC-edge i8042
    15: 42603 IO-APIC-edge ide1
    169: 13223 IO-APIC-level libata
    177: 0 IO-APIC-level libata
    185: 4702 IO-APIC-level eth0
    193: 4912 IO-APIC-level uhci_hcd:usb1, uhci_hcd:usb2, uhci_hcd:usb3, uhci_hcd:usb4, ehci_hcd:usb5
    201: 4 IO-APIC-level bttv0
    209: 1378 IO-APIC-level EMU10K1
    217: 0 IO-APIC-level VIA8237
    NMI: 226
    LOC: 600432
    ERR: 0
    MIS: 0


    You can see in the example from my machine above that etho0 is on a line by itself and using 185 ... No conflicts.
    If your etho device is sharing the same number as another device then you have an IRQ (interrupt request) conflict.

    ---------------------------------------------------------

    Your DHCP server not only supplies the IP address your Linux box should use, but also the desired DNS servers. Make sure your /etc/resolv.conf file is pointing to your ISP's DNS server.

    Copy the namserver & Search (if applicable) address out of the Knoppix /etc/resolv.conf file.

    Add or replace that Info in the SUSE /etc/resolv.conf file with the Knoppix info.

    ### BEGIN INFO
    #
    # Modified_by: dhcpcd
    # Backup: /etc/resolv.conf.saved.by.dhcpcd.eth0
    # Process: dhcpcd
    # Process_id: 4691
    # Script: /sbin/modify_resolvconf
    # Saveto:
    # Info: This is a temporary resolv.conf created by service dhcpcd.
    # The previous file has been saved and will be restored later.
    #
    # If you don't like your resolv.conf to be changed, you
    # can set MODIFY_{RESOLV,NAMED}_CONF_DYNAMICALLY=no. This
    # variables are placed in /etc/sysconfig/network/config.
    #
    # You can also configure service dhcpcd not to modify it.
    #
    # If you don't like dhcpcd to change your nameserver
    # settings
    # then either set DHCLIENT_MODIFY_RESOLV_CONF=no
    # in /etc/sysconfig/network/dhcp, or
    # set MODIFY_RESOLV_CONF_DYNAMICALLY=no in
    # /etc/sysconfig/network/config or (manually) use dhcpcd
    # with -R. If you only want to keep your searchlist, set
    # DHCLIENT_KEEP_SEARCHLIST=yes in /etc/sysconfig/network/dhcp or
    # (manually) use the -K option.
    #
    ### END INFO
    search cityname.rr.com
    nameserver 66.23.9.2


    -------------------------------------------

    Now with the Knoppix info in hand... Give eth0 interface an IP address using the ifconfig command:

    linux:/home/tim # ifconfig eth0 192.168.0.1 netmask 255.255.255.0 up

    The "up" at the end of the command activates the interface. To make this permanent each time you boot up you'll have to add this command in your /etc/rc.local file which is run at the end of every reboot:

    ifconfig eth0 192.168.0.1 netmask 255.255.255.0 up

    ------------------------------------------------

    Im on cable ... so the settings and info may look different than your DSL.

    Summary:

    1.) Run "ifconfig" in Knoppix + write down your information.
    2.) Copy the very last 2 lines in the Knoppix /etc/resolv.conf file. All lines beginning with # are just comments and not info you need.

    --------------------------
    Back in SUSE

    3.) Run "ifconfig eth0 192.168.0.1 netmask 255.255.255.0 up" replace the info with that from Knoppix.
    4.) Open the /etc/resolv.conf file in SUSE and replace the last 2 lines with the info from Knoppix.

    See if you can blast off into cyberspace.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •