Find the answer to your Linux question:
Results 1 to 9 of 9
I have installed ndiswrapper, and I have configured YAST. My network card appears to be working. If I open up KWifi, I can see that i've got signal, and I ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Mar 2006
    Posts
    12

    Suse 10 Wireless Issue (Wireless NIC IS working)


    I have installed ndiswrapper, and I have configured YAST. My network card appears to be working. If I open up KWifi, I can see that i've got signal, and I can verify that I'm getting an IP address (192.168.0.100).

    If I open up firefox and I try to go to the net, I get nothing. It will NOT try to access the internet from my wireless connection.

    However, I am able to log into my router wirelessly through firefox by going to (192.168.0.1). Now, I know that my internet connection is working, as I'm not surfing the net on another computer, and I know my wireless setup works. I'm obviously connecting right or I would not get and IP address and I wouldnt be able to connect to the router setup page.

    Under YAST, I had to manually add my card. I see my wired card, and I see Ethernet Network Card (which is wlan0 ). I need to get suse to use my wireless as the internet connection, and I'd like to be able to connect to networks with KInternet. If I got to Kinternet right now, I get "smpppd is not running"

    Any help please?

    Thanks in advance,
    Shane

  2. #2
    Linux Guru AlexK's Avatar
    Join Date
    Feb 2005
    Location
    Earth
    Posts
    3,379
    can you post the results from the following commands:
    Code:
    iwconfig
    route
    ping -c 4 www.google.com
    ping -c 4 192.168.0.1
    Also tell yast to start wlan0 on boot and start eth0 on cable plugin.
    Life is complex, it has a real part and an imaginary part.

  3. #3
    Just Joined!
    Join Date
    Mar 2006
    Posts
    12
    Okay, I got it working.

    I had to take down my wired NIC, and reset my wireless nic with the following commands:

    ifdown eth0
    ifdown wlan0
    ifup wlan0

    I am now surfing the web wirelessly just fine

    I still cannot use KInternet to survey for wireless networks however. Is there a trick to configuring that?

    Shane

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Guru AlexK's Avatar
    Join Date
    Feb 2005
    Location
    Earth
    Posts
    3,379
    Quote Originally Posted by krazyshane
    I still cannot use KInternet to survey for wireless networks however. Is there a trick to configuring that?
    KInternet -> Wireless Connection -> Sacn for Wireless networks

    Glad to hear you got the wireless working fine.
    Life is complex, it has a real part and an imaginary part.

  6. #5
    Just Joined!
    Join Date
    Mar 2006
    Posts
    12
    Thanks, I appreciate that.

    KInternet does not present me with those options however. I had to find it first.. it's called "Dial-Up" in the internet menu of Suse 10. Anyways, when i first tried to open it, it gave me an error about smpppd not being active. I ran a search for that program and opened it up.

    Now, KInternet will work, but all my options are greyed out. KInternet has a little icon that looks like a power plug in the bottom tray. If I right click on it, the only option that is enabled to me is settings from there I have "various settings" and "Configure with Yast2"

    I cannot select interfaces or anything.

    Edit: I have tried reinstalling Kinternet now with no success. It's as if it's crippled to dialup internet access. Any help?

    Shane

  7. #6
    Just Joined!
    Join Date
    Mar 2006
    Posts
    12
    Well, I set up my modem even though I wont use it. That gave me some more options in KInternet. It sees my modem interface, but not my wireless interface. Hmm.

    Shane

  8. #7
    Linux Guru AlexK's Avatar
    Join Date
    Feb 2005
    Location
    Earth
    Posts
    3,379
    The reason why those boxes are blacked out is because you have told SUSE that only root can start and stop network interfaces via KInternet.

    All you have to do is tell SUSE to allow users to be able to start and stop network interfaces, this option is available in the config page for the network card under detailed settings. Here select user controlled, once that is done smpppd should start automaticially for a normal user and you'll be able to perform rudimentary network card configurations via KInternet.
    Life is complex, it has a real part and an imaginary part.

  9. #8
    Just Joined!
    Join Date
    Mar 2006
    Posts
    12
    Quote Originally Posted by AlexK
    The reason why those boxes are blacked out is because you have told SUSE that only root can start and stop network interfaces via KInternet.

    All you have to do is tell SUSE to allow users to be able to start and stop network interfaces, this option is available in the config page for the network card under detailed settings. Here select user controlled, once that is done smpppd should start automaticially for a normal user and you'll be able to perform rudimentary network card configurations via KInternet.
    Awesome! Thank you It's now just as easy as windows. I had totally overlooked that user controlled checkbox.

    Thanks a lot Alex

    Shane

  10. #9
    Linux Guru AlexK's Avatar
    Join Date
    Feb 2005
    Location
    Earth
    Posts
    3,379
    No problem, glad to hear you got it working.
    Life is complex, it has a real part and an imaginary part.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •