Find the answer to your Linux question:
Results 1 to 4 of 4
Hello, Perhaps some kind person could help me? I'm running SUSE 10.0 with KDE on a new Sony Vaio FE11S laptop and cannot get the sound system to work no ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Mar 2006
    Posts
    2

    No Sound on Sony Vaio FE11S running SUSE 10.0


    Hello,

    Perhaps some kind person could help me?

    I'm running SUSE 10.0 with KDE on a new Sony Vaio FE11S laptop and cannot get the sound system to work no matter what I do. I've tried installing the latest OpenSound system, then uninstalling it, then Googling, and can't find anything. I accept it's a new laptop, so might not be supported yet, but it's very irritating.

    According to Windows, I have a SigmaTel High Definition Audio Device.

    According to lspci, it's an "Intel Corporation 82801G (ICH7 Family) High Definition Audio Controller (rev 2)".

    SUSE's YaST config module has detected the card as an "82801G (ICH7 Family) High Definition Audio Controller".

    When I go into the YaST Sound window, the Audio Device is set to "autodetect", but when I select any of the options and hit "Apply", I get a small window with a status bar saying "Restarting Sound System". It takes about 20secs to reach 100% then starts back at 0% and keeps repeating indefinately. For any of the sound systems (ALSA, Jack, OSS).

    The solution here: http://www.desktoplinux.com/articles/AT9133949670.html is encouraging, but my KMix doesn't have a "Switches" tab - there's just one tab called "Output" with one slider marked "PCM".

    Please help - this is (silently) driving me mad.

    Cheers!

  2. #2
    Just Joined!
    Join Date
    Sep 2005
    Posts
    91
    Have you tried running the following command as root?

    alsamixer

    The sound maybe muted which is indicated by an "m" under the volume bars.

  3. #3
    Just Joined!
    Join Date
    Mar 2006
    Posts
    2
    Thanks, but I've already tried it and it's definately not muted.

    I've made some progress, though. It seems that my user was not added to the "audio" group, so I've now done this with KUser. This has caused the problem to change slightly.

    Before changing the group, when selecting an audio device in YaST (from Open Sound, Jack, ALSA, etc), a small status window would appear saying "Starting Sound System" which would run slowly from 0% to 100%, then loop back to 0% and carry out indefinately.

    Now, the status window appears, reaches 100% then disappears. Yet when I click "Test Sound" in YaST, it crashes and produces no sound. Also, a red "X" has appeared over the volume control in the system tray and KMix doesn't have anything in the "Current Mixer" box.

    Does anybody have any ideas what might be the problem...?

    Thanks.

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Sep 2005
    Posts
    91
    Now that you have been added to the 'audio' group, have you tried re-running alsaconf ?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •