Find the answer to your Linux question:
Page 2 of 2 FirstFirst 1 2
Results 11 to 12 of 12
Dear AlexK and seph The problem isn't really K3b, I think thats a symptom, its fstab. When I look at my fstab it does not contain "/dev/hdb and it says ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #11
    Just Joined!
    Join Date
    Dec 2005
    Location
    Versailles, France
    Posts
    30

    fstab


    Dear AlexK and seph

    The problem isn't really K3b, I think thats a symptom, its fstab.

    When I look at my fstab it does not contain "/dev/hdb and it says can't find /dev/sda1", so I'm at a loss here. I do not understand what you mean.

    I found on the PC a file called fstab.old and I have used this and get the following error when i try to mount a USB drive.
    "[mntent]: line 8 in /etc/fstab is bad
    [mntent]: warning: no final newline at the end of /etc/fstab
    mount: can't find /dev/sdb1 in /etc/fstab or /etc/mtab
    Please check that the device is plugged correctly."

    OK, its plugged in right.
    The fstab reads as follows, I noted the errors in capitals.

    /dev/hda3 / reiserfs acl,user_xattr 1 1
    /dev/hda1 /windows/C vfat users,gid=users,umask=0002,utf8=true 0 0
    /dev/hda2 swap swap defaults 0 0
    proc /proc proc defaults 0 0
    sysfs /sys sysfs noauto 0 0
    usbfs /proc/bus/usb usbfs noauto 0 0
    devpts /dev/pts devpts mode=0620,gid=5 0 0
    /dev/cdrom /media/cdrom subfs noauto,fs=cdfss,ro,procuid,nosuid,nodev,exec,iocha rset=utf8 (THIS IN BLUE) 0 0 (THE LAST ZERO IS UNDERLINED IN RED)
    /dev/fd0 /media/floppy subfs noauto,fs=floppyfss,procuid,nodev,nosuid,sync 0 0
    none /subdomain subdomainfs noauto 0 0

    Is there a nuclear option? If I delete fstab does linux recreate it at startup?

    Yours positively depressed

    Drew

  2. #12
    Banned CodeRoot's Avatar
    Join Date
    Sep 2005
    Posts
    567
    /dev/cdrom /media/cdrom subfs noauto,fs=cdfss,ro,procuid,nosuid,nodev,exec,iocha rset=utf8 (THIS IN BLUE) 0 0 (THE LAST ZERO IS UNDERLINED IN RED)
    "iocha rset=utf8" => "iocharset=utf8"

    (remove the space)

Page 2 of 2 FirstFirst 1 2

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •