Find the answer to your Linux question:
Results 1 to 4 of 4
I have got a SUSE 10 linux version installed in my machine and I have got problem with the istallation of the Intel fortran compiler l_fc_c_9.0.031. Here you are how ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Mar 2006
    Posts
    4

    Problem with the installation of the intel fortran compiler


    I have got a SUSE 10 linux version installed in my machine and I have got problem with the istallation of the Intel fortran compiler l_fc_c_9.0.031.

    Here you are how the problem appears:

    I installed the compiler using all the default settings and I am able to compile without getting any kind of warning, but when I try to lunch the compiled program I got the following:

    ./XMAIN.o: error while loading shared libraries: libimf.so: cannot open shared object file: No such file or directory

    the command used to compile should be the rigth one (ifort XEMAIN.f90 -o XEMIN.o) where , of course, XEMAIN.f90 is the source.

    It seems that the above library is a library of the compiler and it should have been installed during the compiler istallation. In spite of I can't find this library on my system (after the compiler istallation, I mean)

    To see the properties required by l_fc_c_9.0.031 have a look at the present webpage (Intel)
    http://www.intel.com/cd/software/pro...ers/219758.htm


    Do you think that the SUSE 10 is not suitable for this compiler?

    Someone knows what I can I do to solve this problem??

    Thank you

    Paolo

  2. #2
    Just Joined!
    Join Date
    Mar 2006
    Posts
    4

    Smile Problem solved

    I solved the problem in the following way:

    libimfo.so is a library of the Intel compiler, so, first of all I found where the library was. I used the following coomand:
    find ./opt -name "libimfo*"
    At this point I knew the path of the library
    Then I specified the path of the required library (libimfo.so) in the file etc/ld.so.conf
    finally I run the file sbin/ldconfig to update the configuration of the system
    Remember to do this last step!!!!!
    Now everythink work properly!

  3. #3
    Just Joined!
    Join Date
    Mar 2006
    Posts
    3

    Worked for me

    I have just upgraded to Suse 10.0 and installed l_fc_c_9.0 (for Intel)
    It worked for me I have an Intel Pentium 4.

    Download it and untar it, then run the .install.xx

    While installing it: It asks for the registration number, that you may have received by email, and of course the path to the directory to install it.

    Afterwards, you need to put in your .login:

    source $YOUR_F90_PATH/bin/ifortvars.csh
    source $YOUR_F90_PATH/bin/idbvars.csh

  4. #4
    Just Joined!
    Join Date
    Mar 2006
    Posts
    4

    Sorry, I can't find the .login file

    I can't find the .login file. Where is it?
    Anyway, you mean I have to add the two following commands line in the .login file?

    source $YOUR_F90_PATH/bin/ifortvars.csh
    source $YOUR_F90_PATH/bin/idbvars.csh

    Thank you
    Paolo

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •