Find the answer to your Linux question:
Results 1 to 5 of 5
I have a Dell D410 using a Linksys WPC11v1 wireless network card on SUSE 10. When I try to access the local network via IP it works, but if I ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Apr 2006
    Posts
    3

    Wireless Internet - HELP


    I have a Dell D410 using a Linksys WPC11v1 wireless network card on SUSE 10.
    When I try to access the local network via IP it works, but if I try to access the internet it fails. I cannot ping outside of the local network, but using Windows machines throught the same Linksys Router works fine it's only an issue with my new SUSE 10 machine. Using the SUSE 10 machine with the internal NIC connected with an RJ45 cable everything works fine - just the wireless is having this issue.

  2. #2
    Linux Guru sdousley's Avatar
    Join Date
    Feb 2004
    Posts
    1,790
    Does the Wireless router assign IP addresses thru DHCP?? If so, check the DHCP setuip on the router that it assigns DNS addresses ok, and also the Default gateway. These are about the only 2 things that would seem to make internet not work on one os when they do on the other.

    If you are using Static IP's on your wireless card, make sure these are setup ok too
    "I am not an alcoholic, alcoholics go to meetings"
    Registered Linux user = #372327

  3. #3
    Just Joined!
    Join Date
    Apr 2006
    Posts
    3

    Still not working

    The wireless router does assign IP addresses thru DHCP along with the DNS servers and default gateway. The Windows PC's pickup all settings correctly and the SUSE 10 PC's - (now tested on two devices) pickup IP's, but I'm not sure how to check for DNS and Gateway settings.

    ip addr
    1: lo: <LOOPBACK,UP> mtu 16436 qdisc noqueue
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
    inet6 ::1/128 scope host
    valid_lft forever preferred_lft forever
    2: sit0: <NOARP> mtu 1480 qdisc noop
    link/sit 0.0.0.0 brd 0.0.0.0
    3: eth0: <NO-CARRIER,BROADCAST,MULTICAST,NOTRAILERS,UP> mtu 1500 qdisc pfifo_fast qlen 1000
    link/ether 00:12:3f:21:1f:b0 brd ff:ff:ff:ff:ff:ff
    inet6 fe80::212:3fff:fe21:1fb0/64 scope link
    valid_lft forever preferred_lft forever
    4: eth1: <BROADCAST,MULTICAST,NOTRAILERS,UP> mtu 1500 qdisc pfifo_fast qlen 1000
    link/ether 00:03:2f:00:44:c6 brd ff:ff:ff:ff:ff:ff
    inet 192.168.1.102/24 brd 192.168.1.255 scope global eth1
    inet6 fe80::203:2fff:fe00:44c6/64 scope link
    valid_lft forever preferred_lft forever

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Apr 2006
    Posts
    3

    Success at last

    Well after playing around a bit I found that by manually adding DNS and Gatway settings instead of using the DHCP auto-configuration that it provided access. I don't understand why the auto-config failed on the machines, but I have at least found a work around. I am still allowing DHCP for machine IP address, but manually configured the DNS and Gateway servers.

  6. #5
    Linux User zba78's Avatar
    Join Date
    Feb 2004
    Location
    Birmingham, England
    Posts
    335
    Sadly I've had this same problems across a number of distros. Whereas DHCP works fine in WinXP it just won't play ball in (some) Linux distros.

    Not a big deal really as I don't connect to any other network with my laptop anyway
    Ubuntu Jaunty :: Arch Linux (current) :: Acer Aspire 1692WMLi

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •