Find the answer to your Linux question:
Results 1 to 2 of 2
This is my first time using Suse 10 In Redhat all i needed to do to start the vsftpd service was, service vsftpd start in Suse I tried and it ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Oct 2005
    Posts
    38

    can't start vsftpd service in Suse 10


    This is my first time using Suse 10
    In Redhat all i needed to do to start the vsftpd service was, service vsftpd start

    in Suse I tried and it didn't work. I am having trouble starting the service. I did a find for vsftpd and came back with
    /etc./xinet.d/vsftpd
    /etc/pam.d/vsftpd
    /usr/sbin/vsftpd

    when I run /usr/sbin/vsftpd start i get:500 OOPS: vsftpd: cannot open config file:start

    when I run /etc/pam.d/vsftpd start i get: bash: /etc/pam.d/vsftpd: Permission denied

    I get the same above error when I run /etc/xinet.d/vsftpd start

    What may be the problem?

  2. #2
    Linux Newbie
    Join Date
    Dec 2004
    Location
    Barrie, Ontario
    Posts
    219
    /usr/sbin/vsftpd is the actual vsftpd application

    /etc/pam.d/vsftpd is the authentication rules (PAM = Pluggable Authentication Modules) for ftp users

    /etc./xinet.d/vsftpd is the xinet.d (eXtended InterNET Daemon) configuration for running the ftp service.

    What you need to do is make sure the vsftpd service is enabled (edit /etc/xinet.d/vsftpd and set disable = no), then restart xinet.d -- probably using service xinet.d restart or /etc/init.d/xinetd restart
    Blog - KB5UMQ - Linux User #272983
    3 Rules:
    1) "It doesn't work..." is simply not useful information.
    2) Don't cross post!
    3) If you are asking for help, start by telling us your distro/os and version.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •