Find the answer to your Linux question:
Results 1 to 8 of 8
Suse10 has not mounted my windows partition and /fstab has no entry for it. I used mkdir /mnt/windows and set the following entry in /fstab /dev/sda2 /mnt/windows ntfs ro,defaults,umask=0222 0 ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Sep 2005
    Posts
    62

    /fstab entry for windows partition???????


    Suse10 has not mounted my windows partition and /fstab has no entry for it.
    I used mkdir /mnt/windows and set the following entry in /fstab
    /dev/sda2 /mnt/windows ntfs ro,defaults,umask=0222 0 0
    (this entry works in my Fedora core 5 system)
    It failed during boot with the message "mount mount point 0 does not exist"

    After reading the man pages for fstab and mount, i tried the following fstab entry
    /dev/sda2 /mnt/windows ntfs ro 0 0
    Failed again, same error message.

    Can someone pse tell me what I'm doing wrong with this?

    nomadic

  2. #2
    Linux Newbie jpalfree's Avatar
    Join Date
    Jul 2005
    Location
    Montreal, CA
    Posts
    198
    hmm... strange error message.

    have you tried just mounting it as root?
    Code:
    # mount -r -t ntfs /dev/sda2 /mnt/windows
    If that doesn't work, then the only thing I can think of is that your kernel does not support ntfs as is. Though, it doesn't really seem like it would give that error message. Look into it. Try to find a suse kernel module for ntfs support.

    If you still can't figure it out, post the output of "fdisk" and maybe that will provide more clues.
    Avatar from xkcd.com, a hilarious computer related webcomic.

  3. #3
    Just Joined!
    Join Date
    Sep 2005
    Posts
    62
    jpalfree
    Sorry this is a bit longwinded

    I think ntfs support is installed.
    lsmod shows ntfs size 282896 used by 1

    When I mounted /sda2 under root as you suggested, the /windows icon in my file browser had a red X superimposed on it and when I clicked on it I got the following message
    The folder contents could not be displayed.
    You do not have the permissions necessary to view the contents of
    "windows".

    The output of fdisk is the following

    Disk /dev/sda: 160.0 GB, 160041885696 bytes
    255 heads, 63 sectors/track, 19457 cylindersjpalfree
    Units = cylinders of 16065 * 512 = 8225280 bytes

    Device Boot Start End Blocks Id System
    /dev/sda1 1 9 72261 de Dell Utility
    /dev/sda2 * 10 6957 55809810 7 HPFS/NTFS
    /dev/sda3 6958 7626 5373742+ 6 FAT16
    /dev/sda4 7627 19457 95032507+ f W95 Ext'd (LBA)
    /dev/sda5 7627 8161 4297356 83 Linux
    /dev/sda6 8162 8830 5373711 83 Linux
    /dev/sda7 8831 9085 2048256 82 Linux swap / Solaris
    /dev/sda8 9086 9803 5767303+ 83 Linux
    /dev/sda9 9804 10326 4200966 83 Linux
    /dev/sda10 10327 10588 2104483+ 82 Linux swap / Solaris

    Disk /dev/sdb: 164.6 GB, 164696555520 bytes
    255 heads, 63 sectors/track, 20023 cylinders
    Units = cylinders of 16065 * 512 = 8225280 bytes

    Explanation:
    Windows is sda1 (dell) and sda2
    sda3 is an unused partition.
    sda4 is an extended partition.
    Fedora is sda5(/), sda6(/home) and sda7(/swap)
    Suse is sda8(/), sda9(/home) and sda10(swap).


    /etc/fstab has the following entries

    /dev/sda8 / ext3 acl,user_xattr 1 1
    /dev/sda9 /home ext3 acl,user_xattr 1 2
    /dev/sda7 swap swap defaults 0 0
    /dev/sda10 swap swap defaults 0 0
    proc /proc proc defaults 0 0
    sysfs /sys sysfs noauto 0 0
    usbfs /proc/bus/usb usbfs noauto 0 0
    devpts /dev/pts devpts mode=0620,gid=5 0 0
    /dev/sda5 /data1 auto noauto,user 0 0
    /dev/sda6 /data2 auto noauto,user 0 0
    /dev/cdrom /media/cdrom subfs noauto,fs=cdfss,ro,procuid,nosuid,nodev,exec,iocha rset=utf8 0 0
    /dev/cdrecorder /media/cdrecorder subfs noauto,fs=cdfss,ro,procuid,nosuid,nodev,exec,iocha rset=utf8 0 0
    /dev/fd0 /media/floppy subfs noauto,fs=floppyfss,procuid,nodev,nosuid,sync 0 0
    none /subdomain subdomainfs noauto 0 0
    /dev/sda2 /mnt/windows ntfs
    ro 0 0

    The /windows mount fails during startup happens too quickly to see exactly what the message is but the entries from the startup log are the following
    /dev/sda2 on /mnt/windows type ntfs (rw)
    mount: mount point 0 does not exist

    I am probably doing something stupid with the fstab entry but I cant see what.

    Nomadic

  4. #4
    Linux Engineer d38dm8nw81k1ng's Avatar
    Join Date
    Mar 2005
    Location
    Newcastle
    Posts
    793
    ok, when you mount it manually, it is being mounted without read or access permissions to the normal user. you'll be able to access it as root, but that's no good. do the following:

    Code:
    chmod -R o+r /mnt/windows
    after you've mounted it. i think that's the right thing anyway. the man page for chmod isn't very clear on the issue. i don't know about the fstab entry though, sorry.
    Here's why Linux is easier than Windows:
    Package Managers! Apt-Get and Portage (among others) allow users to install programs MUCH easier than Windows can.
    Hardware Drivers. In SuSE, ALL the hardware is detected and installed automatically! How is this harder than Windows' constant disc changing and rebooting?

  5. #5
    Just Joined!
    Join Date
    Sep 2005
    Posts
    62

    Still cannot mount windows partition in Suse10?????

    d38dm8nw81k1ng

    Thanks but that did not work.
    It seemed to run through all of the Windows files giving error messages on lots of them - something about this operation not being supported.

    At the end of it I can see the windows folders in /mnt/windows but there is nothing behind them.

    Nomadic

  6. #6
    Just Joined!
    Join Date
    Sep 2005
    Posts
    62
    d38dm8nw81k1ng

    After trial and error:
    I can mount the windows partition manually with the following under root
    mount -t ntfs /dev/sda2 /mnt/windows -o ro,umask=0222

    I still cannot get an etc/fstab mount command to work for windows!!!!!!!!!
    My latest one (failed) was the following
    /dev/sda2 /mnt/windows ntfs
    ro,umask=0222 0 0
    The entry in the startup log is the following
    /dev/sda2 on /mnt/windows type ntfs (rw)
    mount: mount point 0 does not exist

    Nomadic

  7. #7
    Linux Newbie jpalfree's Avatar
    Join Date
    Jul 2005
    Location
    Montreal, CA
    Posts
    198
    Quote Originally Posted by nomadic
    d38dm8nw81k1ng
    ...
    /dev/sda2 /mnt/windows ntfs
    ro,umask=0222 0 0
    The entry in the startup log is the following
    /dev/sda2 on /mnt/windows type ntfs (rw)
    mount: mount point 0 does not exist
    forgive me if this is a stupid question, but is linux forums word wrapping your fstab entry or is it actually on two lines. Because if it were on two lines then it would explain the error message since it's trying to mount ro,umask=0222 onto 0 with option 0...which, of course, makes no sense at all.

    just trying to eliminate possibilities. If you can mount it with
    Code:
    # mount -t ntfs /dev/sda2 /mnt/windows -o ro,umask=0222
    then the fstab entry:
    /dev/sda2 /mnt/windows ro,umask=0222,users 0 0
    really, should work unless there's something very strange going on ... (which there might be).
    Avatar from xkcd.com, a hilarious computer related webcomic.

  8. #8
    Just Joined!
    Join Date
    Sep 2005
    Posts
    62

    SUCCESS!!!!!!! item closed

    jpalfree
    You were right.
    I put the full mount command in /etc/fstab on one line and it worked.

    I had it spread over two lines because there are 5 other mount commands in /etc/fstab spread over two lines, all working fine, so I put the windows mount in exactly the same format.
    I dont understand why they work and the windows mount would not, but hey it now works.

    Many thanks jpalfree.

    Nomadic

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •