Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 12
Hi, I have just installed SUSE Linux 10.1, in YaST, under Software, the software manager icon does not respond to my clicking, can anyone advise what happen? Thanks cgc101...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jun 2006
    Posts
    5

    SUSE 10.1 Software Management


    Hi, I have just installed SUSE Linux 10.1, in YaST, under Software, the software manager icon does not respond to my clicking, can anyone advise what happen?

    Thanks
    cgc101

  2. #2
    Linux Guru bigtomrodney's Avatar
    Join Date
    Nov 2004
    Location
    Ireland
    Posts
    6,133
    I've seen this problem once before, I think there was a file lock or some bad temporary files. Open a terminal such as konsole or gnome-terminal and run the following commands
    Code:
    su - //enter password when prompted
    yast
    You can navigate around using the tab key and enter. Just run this way once and it should be okay afterwards. If you are still having problems please post back.

  3. #3
    Linux Guru bryansmith's Avatar
    Join Date
    Nov 2004
    Location
    /Ontario/Canada
    Posts
    2,619
    If you are just looking to install a piece of software, try (as root):
    Code:
    yast -i x
    Replaced x with the program name.

    Bryan
    Looking for a distro? Look here.
    "There can be no doubt that all our knowledge begins with experience." - Immanuel Kant (Critique of Pure Reason)
    Queen's University - Arts and Science 2008 (Sociology)
    Registered Linux User #386147.

  4. #4
    Just Joined!
    Join Date
    Jun 2006
    Posts
    5
    Hi bigtomrodney, thanks for your advice, I tried that but the result remains the same, when enter on "software management", it simply does not respond......

  5. #5
    Just Joined!
    Join Date
    Jun 2006
    Location
    Australia
    Posts
    2

    Software Management Problem.

    hey, 1st srry for hijacking your post man, well i have SuSE10.1 and got the same problem i've tryed what bigtomrodney and bryansmith said but i get the same message for both:

    warning: the ncurses frontend is installed but does not work
    You need to install yast2-ncurses to use the YaST2 text mode interfac

    if there is any information
    any info will be welcome, by the way if there is another command for me to be able to install 'yast2-ncurses' will be great! thanks.

  6. #6
    Linux Guru bigtomrodney's Avatar
    Join Date
    Nov 2004
    Location
    Ireland
    Posts
    6,133
    cgc101, Do you get that from both software management in yast and yast2? yast is the text based version, yast2 having a full GUI interface.

    c0r3 - Go to your install CDs and browse them looking for that package - something like yast2-ncurses-2.13.27-3.rpm. Just install it manually either by right clicking on it, or using the command line as root
    Code:
    rpm -Uvh /path/to/rpm/file/yast2-ncurses-2.13.27-3.rpm

  7. #7
    Just Joined!
    Join Date
    Jun 2006
    Posts
    5
    bigtomrodney, I guess by yast you mean the one which I executed via the terminal or console, and yast2 is the one via the graphical interface which are activated through the green icon at the right bottom corner, right? well, both did not work......

  8. #8
    Just Joined!
    Join Date
    Jun 2006
    Location
    Australia
    Posts
    2
    Quote Originally Posted by cgc101
    bigtomrodney, I guess by yast you mean the one which I executed via the terminal or console, and yast2 is the one via the graphical interface which are activated through the green icon at the right bottom corner, right? well, both did not work......
    Yes you're right, did you receive any messages when you tried through the konsole?

    i received an error message when i tried to install the packege file: yast2-ncurses-2.13.27-3.i586

    error: Failed dependencies:
    libzypp.so.0 is needed by yast2-ncurses-2.13.27-3.i586

    Does that mean i have to install the libzypp Packages?
    well i tried anyways
    Here are the results:
    (1)
    c0r3:/media/SU1010_001/suse/i586 # rpm -Uvh libzypp-0.0.8-154.i586.rpm
    Preparing... ########################################### [100%]
    package libzypp-1.1.0-1.11 (which is newer than libzypp-0.0.8-154) is already installed
    c0r3:/media/SU1010_001/suse/i586 #
    never mind about that one.
    (2)
    c0r3:/media/SU1010_001/suse/i586 # rpm -Uvh libzypp-devel-0.0.8-154.i586.rpm
    error: Failed dependencies:
    libxml2-devel is needed by libzypp-devel-0.0.8-154.i586
    curl-devel is needed by libzypp-devel-0.0.8-154.i586
    openssl-devel is needed by libzypp-devel-0.0.8-154.i586
    rpm-devel is needed by libzypp-devel-0.0.8-154.i586
    zlib-devel is needed by libzypp-devel-0.0.8-154.i586
    e2fsprogs-devel is needed by libzypp-devel-0.0.8-154.i586
    popt-devel is needed by libzypp-devel-0.0.8-154.i586
    dbus-1-devel is needed by libzypp-devel-0.0.8-154.i586
    glib2-devel is needed by libzypp-devel-0.0.8-154.i586
    hal-devel is needed by libzypp-devel-0.0.8-154.i586
    boost-devel is needed by libzypp-devel-0.0.8-154.i586
    libstdc++-devel is needed by libzypp-devel-0.0.8-154.i586
    c0r3:/media/SU1010_001/suse/i586 #
    (3)
    c0r3:/media/SU1010_001/suse/i586 # rpm -Uvh libzypp-zmd-backend-7.1.1.0-40.i586.rpm
    error: Failed dependencies:
    libzypp.so.0 is needed by libzypp-zmd-backend-7.1.1.0-40.i586
    c0r3:/media/SU1010_001/suse/i586 #
    am I using the right command to try install them?

    also here is some more info:
    this message was displayed when i try to run the software management:

    c0r3:/media/SU1010_001/suse/i586 # yast2
    Command: /sbin/yast2 sw_single &
    Error loading language plugin /usr/lib/YaST2/plugin/libpy2lang_perl.so: libzypp.so.0: cannot open shared object file: No such file or directory
    No such client module sw_single

    at this stage im thinking about re-installing linux
    any help at all will be welcome, thank you.

  9. #9
    Linux Guru bigtomrodney's Avatar
    Join Date
    Nov 2004
    Location
    Ireland
    Posts
    6,133
    c0r3 you can use the --force option to force it to install if you don't want to go straight to a reinstall, then fix up dependencies if you can get YaST running.


    cgc101 is there any type of error at all? If you try Bryan's method of going straight to the installer (yast -i) do you get any error there?

  10. #10
    Just Joined!
    Join Date
    Jun 2006
    Posts
    5
    Hi all, originally, I installed 10.1 with KDE, and I decided to give it a try to reinstall the 10.1 but with Gnome, guess what, the problem is solved!! I do not understand what was the problem with KDE, but certainly, with the Gnome, everything is working fine.
    Thanks to all of you for helping.

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •