Find the answer to your Linux question:
Results 1 to 6 of 6
I have installed XGL and Compiz, but cant seem to get them to work. Firstly what line to i add to my ~/.xinitrc to run "xgl" from #startx and how ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Apr 2006
    Location
    West Sussex
    Posts
    37

    XGL problems


    I have installed XGL and Compiz, but cant seem to get them to work.

    Firstly what line to i add to my ~/.xinitrc to run "xgl" from #startx

    and how do i fix the problems with the configuration of my graphics card
    (screenshot of output http://img143.imageshack.us/img143/8...roblems6mc.png)

    thanks

  2. #2
    Linux Guru bigtomrodney's Avatar
    Join Date
    Nov 2004
    Location
    Ireland
    Posts
    6,133
    Which distro/release version are you using? If you are using Suse 10.1 just activate it using the '3d Desktop' module in Gnome-Control-Center.

    EDIT- I see you have tried to activate this unsuccessfully. It looks like you have not installed the proprietary nVidia drivers. You will need to do this to get 3D acceleration. Also by the looks of things you configured it by hand, this is not necessary, just use the control center module. Try the update settings option. Failing that you may need to undo any previous howtos and start from scratch here.
    Last edited by bigtomrodney; 06-26-2006 at 11:17 AM.

  3. #3
    Just Joined!
    Join Date
    Apr 2006
    Location
    West Sussex
    Posts
    37
    i am on suse 10.1, and yes i have downloaded the offical nvidia drivers, 3D acceleration is not in my control center either

  4. #4
    Linux Guru bigtomrodney's Avatar
    Join Date
    Nov 2004
    Location
    Ireland
    Posts
    6,133
    What results are you getting from glxgears? Run it in a terminal and take note of the FPS rating you are getting. What happens when you run the 'Update 3d Desktop Settings' in the control center?

  5. #5
    Just Joined!
    Join Date
    Jun 2006
    Posts
    2

    XGL Problems

    Have you fixed this yet?
    I had the same issue.
    I followed this guide and everything worked great.

    http://www.thejemreport.com/mambo/content/view/254/42/

    I hope that helps.

  6. #6
    Linux Newbie oryxz's Avatar
    Join Date
    Feb 2006
    Posts
    111
    Looks like the guide used older suse 10.1 (RC1,2,3):
    As long you get 3d acceleration for your computer. Just install xgl,xgl-hardware list, and compiz from your yast. Then Enable Xgl right from your control center if you using gnome. For KDE well there a lot of work need to do to make it work.
    Linux User #409695.
    Acer Aspire 5500, Suse Linux 10.1
    Get counted as Linux user [Linux Counter]

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •