Find the answer to your Linux question:
Results 1 to 3 of 3
i gave up trying to get yast to install the nvidia drivers so I used the tiny-nvidia-installer. everything went fine and ill admit i was rather impressed at how simple ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Newbie
    Join Date
    Apr 2005
    Posts
    235

    nvidia drivers stopped working


    i gave up trying to get yast to install the nvidia drivers so I used the tiny-nvidia-installer. everything went fine and ill admit i was rather impressed at how simple it was, and I was playing ut2k4 in no time. This morning however the nvidia drivers dont seem to be working, and glxgears is giving me 10 fps or so. The nvidia drivers are still installed according to the tiny-nvidia-installer, and ive re-run nvidia-xconfig. I've also checked xorg.conf myself and couldnt find anything wrong with it.

    # nvidia-xconfig: X configuration file generated by nvidia-xconfig
    # nvidia-xconfig: version 1.0 (buildmeister@builder3) Thu Sep 14 15:50:24 PDT 2006

    # /.../
    # SaX generated X11 config file
    # Created on: 2006-09-23T10:29:24+0800.
    #
    # Version: 7.1
    # Contact: Marcus Schaefer <sax@suse.de>, 2005
    # Contact: SaX-User list <https://lists.berlios.de/mailman/listinfo/sax-users>
    #
    # Automatically generated by [ISaX] (7.1)
    # PLEASE DO NOT EDIT THIS FILE!
    #

    Section "ServerLayout"
    Identifier "Layout[all]"
    Screen "Screen[0]" 0 0
    InputDevice "Keyboard[0]" "CoreKeyboard"
    InputDevice "Mouse[1]" "CorePointer"
    Option "Clone" "off"
    Option "Xinerama" "off"
    EndSection

    Section "Files"
    InputDevices "/dev/gpmdata"
    InputDevices "/dev/input/mice"
    FontPath "/usr/X11R6/lib/X11/fonts/misc:unscaled"
    FontPath "/usr/X11R6/lib/X11/fonts/local"
    FontPath "/usr/X11R6/lib/X11/fonts/75dpi:unscaled"
    FontPath "/usr/X11R6/lib/X11/fonts/100dpi:unscaled"
    FontPath "/usr/X11R6/lib/X11/fonts/Type1"
    FontPath "/usr/X11R6/lib/X11/fonts/URW"
    FontPath "/usr/X11R6/lib/X11/fonts/Speedo"
    FontPath "/usr/X11R6/lib/X11/fonts/PEX"
    FontPath "/usr/X11R6/lib/X11/fonts/cyrillic"
    FontPath "/usr/X11R6/lib/X11/fonts/latin2/misc:unscaled"
    FontPath "/usr/X11R6/lib/X11/fonts/latin2/75dpi:unscaled"
    FontPath "/usr/X11R6/lib/X11/fonts/latin2/100dpi:unscaled"
    FontPath "/usr/X11R6/lib/X11/fonts/latin2/Type1"
    FontPath "/usr/X11R6/lib/X11/fonts/latin7/75dpi:unscaled"
    FontPath "/usr/X11R6/lib/X11/fonts/baekmuk:unscaled"
    FontPath "/usr/X11R6/lib/X11/fonts/japanese:unscaled"
    FontPath "/usr/X11R6/lib/X11/fonts/kwintv"
    FontPath "/usr/X11R6/lib/X11/fonts/truetype"
    FontPath "/usr/X11R6/lib/X11/fonts/uni:unscaled"
    FontPath "/usr/X11R6/lib/X11/fonts/CID"
    FontPath "/usr/X11R6/lib/X11/fonts/ucs/misc:unscaled"
    FontPath "/usr/X11R6/lib/X11/fonts/ucs/75dpi:unscaled"
    FontPath "/usr/X11R6/lib/X11/fonts/ucs/100dpi:unscaled"
    FontPath "/usr/X11R6/lib/X11/fonts/hellas/misc:unscaled"
    FontPath "/usr/X11R6/lib/X11/fonts/hellas/75dpi:unscaled"
    FontPath "/usr/X11R6/lib/X11/fonts/hellas/100dpi:unscaled"
    FontPath "/usr/X11R6/lib/X11/fonts/hellas/Type1"
    FontPath "/usr/X11R6/lib/X11/fonts/misc/sgi:unscaled"
    FontPath "/usr/X11R6/lib/X11/fonts/xtest"
    FontPath "/opt/kde3/share/fonts"
    EndSection

    Section "Module"
    Load "type1"
    Load "dbe"
    Load "freetype"
    Load "glx"
    Load "v4l"
    Load "extmod"
    EndSection

    Section "ServerFlags"
    Option "AllowMouseOpenFail" "on"
    EndSection

    Section "InputDevice"
    Identifier "Keyboard[0]"
    Driver "kbd"
    Option "Protocol" "Standard"
    Option "XkbLayout" "us"
    Option "XkbModel" "pc104"
    Option "XkbRules" "xfree86"
    EndSection

    Section "InputDevice"
    Identifier "Mouse[1]"
    Driver "mouse"
    Option "Buttons" "10"
    Option "Device" "/dev/input/mice"
    Option "Name" "Microsoft Optical Mouse with Tilt Wheel"
    Option "Protocol" "explorerps/2"
    Option "Vendor" "Sysp"
    Option "ZAxisMapping" "4 5"
    EndSection

    Section "Modes"
    Identifier "Modes[0]"
    ModeLine "1152x864" 107.9 1152 1224 1352 1552 864 865 868 903
    ModeLine "1152x864" 106.5 1152 1224 1352 1552 864 865 868 903
    ModeLine "1152x864" 105.0 1152 1224 1352 1552 864 865 868 902
    ModeLine "1024x768" 96.7 1024 1088 1200 1376 768 769 772 808
    ModeLine "1024x768" 95.5 1024 1088 1200 1376 768 769 772 807
    ModeLine "1024x768" 94.4 1024 1088 1200 1376 768 769 772 807
    ModeLine "1024x600" 96.9 1024 1088 1200 1376 600 601 604 640
    ModeLine "1024x600" 95.8 1024 1088 1200 1376 600 601 604 639
    ModeLine "1024x600" 95.0 1024 1088 1200 1376 600 601 604 639
    ModeLine "800x600" 75.5 800 848 936 1072 600 601 604 640
    ModeLine "800x600" 74.7 800 848 936 1072 600 601 604 639
    ModeLine "800x600" 74.0 800 848 936 1072 600 601 604 639
    ModeLine "768x576" 73.0 768 824 904 1040 576 577 580 616
    ModeLine "768x576" 72.3 768 824 904 1040 576 577 580 615
    ModeLine "768x576" 71.6 768 824 904 1040 576 577 580 615
    ModeLine "640x480" 60.6 640 680 752 864 480 481 484 520
    ModeLine "640x480" 60.1 640 680 752 864 480 481 484 519
    ModeLine "640x480" 59.6 640 680 752 864 480 481 484 519
    EndSection

    Section "Monitor"
    Identifier "Monitor[0]"
    VendorName "EMA"
    ModelName "EVIEW 17F3"
    UseModes "Modes[0]"
    DisplaySize 320 240
    HorizSync 30.0 - 70.0
    VertRefresh 43.0 - 160.0
    Option "DPMS"
    EndSection

    Section "Device"
    Identifier "Device[0]"
    Driver "nvidia"
    VendorName "NVidia"
    BoardName "GeForce 6600 GT (0x00F2)"
    EndSection

    Section "Screen"
    Identifier "Screen[0]"
    Device "Device[0]"
    Monitor "Monitor[0]"
    DefaultDepth 24
    SubSection "Display"
    Depth 15
    Modes "1152x864" "1024x768" "1024x600" "800x600" "768x576" "640x480"
    EndSubSection
    SubSection "Display"
    Depth 16
    Modes "1152x864" "1024x768" "1024x600" "800x600" "768x576" "640x480"
    EndSubSection
    SubSection "Display"
    Depth 24
    Modes "1152x864" "1024x768" "1024x600" "800x600" "768x576" "640x480"
    EndSubSection
    SubSection "Display"
    Depth 32
    Modes "1152x864" "1024x768" "1024x600" "800x600" "768x576" "640x480"
    EndSubSection
    SubSection "Display"
    Depth 8
    Modes "1152x864" "1024x768" "1024x600" "800x600" "768x576" "640x480"
    EndSubSection
    EndSection

    even more strangly is my init has stopped working, well going from init 5 to init 3 wont kill X. I can init 3 to 4 with a console loggin. Any ideas.

  2. #2
    Linux Newbie
    Join Date
    Apr 2005
    Posts
    235
    ok i gave up and reinstalled, but i have a felling it was Yast that what having a go at me. for now on im gonna just recompile the drivers each time.

  3. #3
    Linux Guru
    Join Date
    Nov 2004
    Posts
    6,110
    Did you by any chance do a kernel upgrade after installing the drivers? Were there any updates you installed?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •