Find the answer to your Linux question:
Results 1 to 4 of 4
Like Tree1Likes
  • 1 Post By jayd512
i need some help....... I want to make my computer an ftp server(small scale) , i read an online tutorial to do the same when i type: service vsftpd start ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Oct 2006
    Posts
    8

    FTP server


    i need some help.......
    I want to make my computer an ftp server(small scale) , i read an online tutorial to do the same
    when i type:
    service vsftpd start
    it gives me an error message whoch read as follows :
    Starting vsftpd startproc: exit status of parent of /usr/sbin/vsftpd: 1
    failed

  2. #2
    Banned joewee's Avatar
    Join Date
    Sep 2006
    Posts
    113
    Setting up VerySecure FTP http://susewiki.org/index.php?title=...VerySecure_FTP
    From SUSE Wiki
    Jump to: navigation, search

    Type: Howto, Application-Specific (vsFTP)

    Tested Versions: 10.0, 10.1

    Written By: z0man

    TFTP(Trivial FTP) is a basic option with no secruity. vsftp(Very Secrue FTP) is far more secure

    Providing you have setup your network IP on the server, there are four steps in order to get vsftp to work.
    Contents
    [hide]

    * 1 Installation
    * 2 Configuration
    * 3 Adjusting SUSE Firewall
    * 4 Testing

    [edit]
    Installation

    Using "Yast Software Management" search for and install "vsftp"

    There are two ways to start up VSFTP, we can use xinetd services to start it or standalone server(where you configure it in your boot up scripts). Xinetd is more secure so lets get that enabled if you have not done so. In YAST visit System->Network Services->Network Services(xinetd). Click "Toggle (Enable)"

    Once enabled, a list will be visible and you should find near the top "vsftpd". The line will probably read something like (Use left and right arrows/horizontal scroll bar)

    │ --- │ftp │stream│ tcp │No │root │/usr/sbin/vsftpd....

    Make sure that row is highlighted and then "toggle Status" to ON
    [edit]
    Configuration

    Now we have to configure vsftpd to open for users on Linux. Edit /etc/vsftpd.conf. This is read when vsftpd is started, lines with # at the beginning are ignored as most deamons are. Important note, the more you uncomment the less secure it is.

    Look for the following lines and uncomment:

    write_enable=YES
    local_umask=022
    local_enable=YES

    Comment out(If you don't like anonymous users just coming in looking around freely)

    #anonymous_enable=YES

    Change Listen line to

    Listen=NO

    Changing "Listen" to no allows xinetd to start up the service rather setting up a boot script for /usr/sbin/vsftpd
    [edit]
    Adjusting SUSE Firewall

    If you're running this you need to adjust this. In EXTERNAL ZONE you will need to ALLOW a couple of ports on TCP/UDP. In Yast visit

    Secruity & Users -> Firewall

    TAB or click on "Allow Services" then select "Advanced", add the following ports

    TCP Ports
    20 21
    UDP Ports
    20 21

    Then click OK. Then click NEXT to see the Summary for SuSeFirewall changes and accept. 21 and 20 are standard ports for FTP communication and they need to be enabled on both UDP and TCP.
    [edit]
    Testing

    Restart SuSeFirewall and vsftp with the following commands

    # rcnetwork restart
    # rcxinetd restart

    Use your desired FTP client software to connect to your Server IP on port 21 and enjoy On Linux I'd type

    $ ftp 192.168.0.2

    Then use a username on the server.

  3. #3
    Just Joined!
    Join Date
    Jan 2012
    Posts
    11
    Currently I installed SLES (SUSE Linux Enterprise Server 10) with SP3 and I solved the ftp configuration above guide line. But root account can not access to ftp. The other user can ftp to server.
    Anyone who konw how to let root account ftp to server? please help me

  4. $spacer_open
    $spacer_close
  5. #4
    Administrator jayd512's Avatar
    Join Date
    Feb 2008
    Location
    Kentucky
    Posts
    5,023
    Hello, princox! Welcome to LinuxForums!

    Please refrain from reviving old threads. But, please, feel free to start a new thread concerning any questions you may have about Linux.
    princox likes this.
    Jay

    New users, read this first.
    New Member FAQ
    Registered Linux User #463940
    I do not respond to private messages asking for Linux help. Please keep it on the public boards.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •