Find the answer to your Linux question:
Results 1 to 2 of 2
as title... just says "Starting INET services... (xinetd) failed." It won't tell me why it's failed. What I've tried so far: 1) Run "/etc/init.d/xinetd -d" (d for debug), but it ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Newbie
    Join Date
    Nov 2006
    Posts
    123

    help! xinetd won't start...


    as title... just says "Starting INET services... (xinetd) failed."
    It won't tell me why it's failed.
    What I've tried so far:
    1) Run "/etc/init.d/xinetd -d" (d for debug), but it just prints usage.
    2) Looked in /var/log/xinetd.log, but it just contains "06/11/14@16:06:19: START: ftp pid=22969 from=127.0.0.1"

    I'm looking for clues on how I can find out why it failed to start, if anybody can shed any light on it?

    My /etc/xinetd.conf is:
    Code:
    #
    # xinetd.conf
    #
    # Copyright (c) 1998-2001 SuSE GmbH Nuernberg, Germany.
    # Copyright (c) 2002 SuSE Linux AG, Nuernberg, Germany.
    #
    
    defaults
    {
    	log_type        = FILE /var/log/xinetd.log 
            log_on_success  = HOST EXIT DURATION
    	log_on_failure	= HOST ATTEMPT
    #        only_from       = localhost
            instances       = 30
    	cps		= 50 10
    
    #
    # The specification of an interface is interesting, if we are on a firewall.
    # For example, if you only want to provide services from an internal
    # network interface, you may specify your internal interfaces IP-Address.
    #
    #	interface	= 127.0.0.1
    
    }
    
    
    
    #includedir /etc/xinetd.d
    service proftpd
    {
    	socket_type     = stream
    	protocol        = tcp
    	wait            = no
    	user            = nobody
    	group           = nogroup
    	server          = /usr/local/sbin/proftpd
    }
    service apache2
    {
    	socket_type     = stream
    	protocol        = tcp
    	wait            = no
    	user            = nobody
    	group           = nogroup
    	server          = /etc/init.d/apache2
    }
    my /etc/apache2/httpd.conf is:
    Code:
    Include /etc/apache2/server-tuning.conf
    ErrorLog /var/log/apache2/error_log
    Include /etc/apache2/sysconfig.d/loadmodule.conf
    Include /etc/apache2/listen.conf
    Include /etc/apache2/mod_log_config.conf
    Include /etc/apache2/sysconfig.d/global.conf
    Include /etc/apache2/mod_status.conf
    Include /etc/apache2/mod_info.conf
    Include /etc/apache2/mod_usertrack.conf
    Include /etc/apache2/mod_autoindex-defaults.conf
    TypesConfig /etc/apache2/mime.types
    DefaultType text/plain
    Include /etc/apache2/mod_mime-defaults.conf
    Include /etc/apache2/errors.conf
    Include /etc/apache2/ssl-global.conf
    <Directory />
        Options None
        AllowOverride None
        Order deny,allow
        Deny from all
    </Directory>
    
    # use .htaccess files for overriding,
    AccessFileName .htaccess
    # and never show them
    <Files ~ "^\.ht">
        Order allow,deny
        Deny from all
    </Files>
    
    # List of resources to look for when the client requests a directory
    DirectoryIndex index.html index.html.var
    
    ### 'Main' server configuration #############################################
    #
    # The directives in this section set up the values used by the 'main'
    # server, which responds to any requests that aren't handled by a
    # <VirtualHost> definition.  These values also provide defaults for
    # any <VirtualHost> containers you may define later in the file.
    #
    # All of these directives may appear inside <VirtualHost> containers,
    # in which case these default settings will be overridden for the
    # virtual host being defined.
    #
    Include /etc/apache2/default-server.conf
    
    
    # Another way to include your own files
    #
    # The file below is generated from /etc/sysconfig/apache2,
    # include arbitrary files as named in APACHE_CONF_INCLUDE_FILES and
    # APACHE_CONF_INCLUDE_DIRS
    Include /etc/apache2/sysconfig.d/include.conf
    
    
    ### Virtual server configuration ############################################
    #
    # VirtualHost: If you want to maintain multiple domains/hostnames on your
    # machine you can setup VirtualHost containers for them. Most configurations
    # use only name-based virtual hosts so the server doesn't need to worry about
    # IP addresses. This is indicated by the asterisks in the directives below.
    #
    # Please see the documentation at
    # <URL:http://httpd.apache.org/docs-2.2/vhosts/>
    # for further details before you try to setup virtual hosts.
    #
    # You may use the command line option '-S' to verify your virtual host
    # configuration.
    #
    Include /etc/apache2/vhosts.d/*.conf
    
    
    # Note: instead of adding your own configuration here, consider 
    #       adding it in your own file (/etc/apache2/httpd.conf.local)
    #       putting its name into APACHE_CONF_INCLUDE_FILES in 
    #       /etc/sysconfig/apache2 -- this will make system updates 
    #       easier :)
    and my /usr/local/etc/proftpd.conf is:
    Code:
    # This is a basic ProFTPD configuration file (rename it to 
    # 'proftpd.conf' for actual use.  It establishes a single server
    # and a single anonymous login.  It assumes that you have a user/group
    # "nobody" and "ftp" for normal operation and anon.
    
    ServerName			"ProFTPD Default Installation"
    ServerType			inetd
    DefaultServer			on
    
    # Port 21 is the standard FTP port.
    Port				21
    
    # Umask 022 is a good standard umask to prevent new dirs and files
    # from being group and world writable.
    Umask				022
    
    # To prevent DoS attacks, set the maximum number of child processes
    # to 30.  If you need to allow more than 30 concurrent connections
    # at once, simply increase this value.  Note that this ONLY works
    # in standalone mode, in inetd mode you should use an inetd server
    # that allows you to limit maximum number of processes per service
    # (such as xinetd).
    MaxInstances			30
    
    # Set the user and group under which the server will run.
    User				nobody
    Group				nogroup
    
    # To cause every FTP user to be "jailed" (chrooted) into their home
    # directory, uncomment this line.
    #DefaultRoot ~
    
    # Normally, we want files to be overwriteable.
    AllowOverwrite		on
    
    # Bar use of SITE CHMOD by default
    <Limit SITE_CHMOD>
      DenyAll
    </Limit>
    
    # A basic anonymous configuration, no upload directories.  If you do not
    # want anonymous users, simply delete this entire <Anonymous> section.
    #<Anonymous ~ftp>
    #  User				ftp
    #  Group				ftp
    
      # We want clients to be able to login with "anonymous" as well as "ftp"
    #  UserAlias			anonymous ftp
    
      # Limit the maximum number of anonymous logins
    #  MaxClients			10
    
      # We want 'welcome.msg' displayed at login, and '.message' displayed
      # in each newly chdired directory.
    #  DisplayLogin			welcome.msg
    #  DisplayFirstChdir		.message
    
      # Limit WRITE everywhere in the anonymous chroot
    #  <Limit WRITE>
    #    DenyAll
    #  </Limit>
    #</Anonymous>

  2. #2
    Linux Newbie
    Join Date
    Nov 2006
    Posts
    123
    ah, got past that particular hurdle - it was that the service name in xinetd.conf didn't match the name in /etc/services.
    But I still can't get the damn ftp server working...aaaah!!

    netstat -pant returns:
    Code:
    Active Internet connections (servers and established)
    Proto Recv-Q Send-Q Local Address           Foreign Address         State       PID/Program name
    tcp        0      0 0.0.0.0:111             0.0.0.0:*               LISTEN      2756/portmap
    tcp        0      0 0.0.0.0:80              0.0.0.0:*               LISTEN      30738/xinetd
    tcp        0      0 127.0.0.1:2544          0.0.0.0:*               LISTEN      2895/zmd
    tcp        0      0 0.0.0.0:21              0.0.0.0:*               LISTEN      30738/xinetd
    tcp        0      0 0.0.0.0:631             0.0.0.0:*               LISTEN      3035/cupsd
    tcp        0      0 127.0.0.1:25            0.0.0.0:*               LISTEN      3053/master
    tcp        0      0 :::22                   :::*                    LISTEN      20690/sshd
    tcp        0      0 ::1:25                  :::*                    LISTEN      3053/master
    so it is listening, but I get:
    Code:
    benscomputer:~ # su - ben
    ben@benscomputer:~> ftp localhost
    Trying 127.0.0.1...
    Connected to localhost.
    421 Service not available, remote server has closed connection.
    what the devil is wrong with this *****?


    the httpd server doesn't seem to be working either.
    The /etc/xinetd.conf is now:
    Code:
    #
    # xinetd.conf
    #
    # Copyright (c) 1998-2001 SuSE GmbH Nuernberg, Germany.
    # Copyright (c) 2002 SuSE Linux AG, Nuernberg, Germany.
    #
    
    defaults
    {
    	log_type        = FILE /var/log/xinetd.log 
            log_on_success  = HOST EXIT DURATION
    	log_on_failure	= HOST ATTEMPT
    #        only_from       = localhost
            instances       = 30
    	cps		= 50 10
    
    #
    # The specification of an interface is interesting, if we are on a firewall.
    # For example, if you only want to provide services from an internal
    # network interface, you may specify your internal interfaces IP-Address.
    #
    #	interface	= 127.0.0.1
    
    }
    
    
    
    includedir /etc/xinetd.d
    service ftp
    {
    	socket_type     = stream
    	protocol        = tcp
    	wait            = no
    	user            = nobody
    	group           = nogroup
    	server          = /usr/local/sbin/proftpd
    }
    service www
    {
    	socket_type     = stream
    	protocol        = tcp
    	wait            = no
    	user            = nobody
    	group           = nogroup
    	server          = /etc/init.d/apache2
    }
    anybody?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •