Find the answer to your Linux question:
Results 1 to 9 of 9
Hi. I am using openSUSE 10.2 on my system. Recently, I screwed up my system while updating the kernel to 2.6.19.1 and so I had to do a reinstall. Later, ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    hsd
    hsd is offline
    Just Joined!
    Join Date
    Jan 2007
    Location
    India
    Posts
    4

    Question configure command not found


    Hi.
    I am using openSUSE 10.2 on my system. Recently, I screwed up my system while updating the kernel to 2.6.19.1 and so I had to do a reinstall. Later, while trying to install a game (Super Maryo Chronicles), I followed the following steps:

    1) sh ./autogen.sh (there was a file called autogen.sh in the untarred SMC folder)
    2) The above command created a file called configure in the directory.
    But when I try to run ./configure, bash says "configure : Comand not found".
    I tried to see if theres a manual entry for configure (man configure) but theres not even a manual entry for it.
    THe thing is all these commands were working fine before the reinstall. What could be wrong? I tried the ./configure command for other packages but got the same result.
    What do i need to do to resolve this?

  2. #2
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    hi hsd !

    Welcome to the LinuxForums !

    configure is not a command. its a file ( script ) that contains configuration instructions. autogen.sh created a configure script for SMC you have to execute configure script now. 'cd' to the folder having configure script, it must be listed in the output of 'ls' command. execute ./configure again.





    Casper
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  3. #3
    Trusted Penguin Dapper Dan's Avatar
    Join Date
    Oct 2004
    Location
    The Sovereign State of South Carolina
    Posts
    4,630
    Hi hsd and welcome to the forums.

    Sorry to hear of your trouble. If you are inside the untarred directory and there is a file in there called "configure" and you then run ./configure it should work. It's been a long time since I ran SuSE, but it could possibly be a permissions issue. This untarred directory you are inside of is in your home directory? I suppose you have tried running ./configure as su? ...and configure will not work with anything else either? Not trying to insult your intelligence, (it's just that I've personally done this... ) but the file IS configure and not Configure or just config? Sorry I couldn't help more...

    Dapper

    EDIT: I see devils_casper got posted before me. Listen to him hsd, he'll get this sorted for you!
    Linux Mint + IceWM Registered: #371367 New Members: click here

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Enthusiast apoorv_khurasia's Avatar
    Join Date
    Feb 2005
    Posts
    624
    This is not a permissions problem as it is saying configure command not found. Try running
    Code:
    sh configure
    "There is no sixth rule"
    --Rob Pike
    Registered Linux User: 400426 home page

  6. #5
    hsd
    hsd is offline
    Just Joined!
    Join Date
    Jan 2007
    Location
    India
    Posts
    4
    autogen.sh created a configure script for SMC you have to execute configure script now. 'cd' to the folder having configure script, it must be listed in the output of 'ls' command. execute ./configure again
    Hi. Thanks. I am following those exact steps. I cd to the folder where I have unzipped and untarred the SMC source files. Then I ran sh ./autogen.sh.
    Then autogen asked me to run ./configure. I did sudo ./configure. AM i missing anything?

    but the file IS configure and not Configure or just config? Sorry I couldn't help more...
    Hi dapper dan. Thanx. Yea the file is configure.

    hey apoorv...i'll try it n get back to u.

  7. #6
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    Quote Originally Posted by hsd
    Then I ran sh ./autogen.sh.
    Then autogen asked me to run ./configure. I did sudo ./configure. AM i missing anything?
    execute sh autogen.sh OR ./autogen.sh. same is with configure file. you should use 'su' instead of 'sudo' to gain root privileges. i dont think you need root privileges for configure.




    Casper
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  8. #7
    hsd
    hsd is offline
    Just Joined!
    Join Date
    Jan 2007
    Location
    India
    Posts
    4
    hey...its working now. I tried sh configure, which works. Later i did chmod a+x configure. after this, ./configure is working too.
    Thanks a lot.

  9. #8
    Just Joined!
    Join Date
    Jul 2012
    Posts
    1
    One thing that helped me resolve the issue is:

    Open the Properties, go to Permissions tab and check the 'Enable executing file as program' option.

  10. #9
    oz
    oz is offline
    forum.guy
    Join Date
    May 2004
    Location
    arch linux
    Posts
    18,733
    Guys, this thread is approaching 6 years old so I'm going to go ahead and close it, but please feel free to start fresh threads if any of you continue to have problems with Linux.

    Thank you.
    oz

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •