Find the answer to your Linux question:
Results 1 to 9 of 9
Hello I've been using OpenSUSE 10.2 for a few months now but have not figured out how to telnet to my machine from another computer on our network. Per the ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Dec 2006
    Posts
    4

    Unable to Telnet to SUSE 10.2 box


    Hello
    I've been using OpenSUSE 10.2 for a few months now but have not figured out how to telnet to my machine from another computer on our network. Per the OpenSUSE website I have used the Yast software management tool to install the telnet server software and had have toggled the /usr/sbin/in.telnetd server on via the Network Service Config. I am able to ping my machine ok. When I do a chkconfig telnetd on the reply is "unknown service" and when I try to execute /etc/init.d/xinetd start it fails.

    Could I get some help of the step I am missing please?
    Thanks!!

  2. #2
    Just Joined! ch@meleon's Avatar
    Join Date
    Mar 2007
    Location
    Pretoria. South Africa
    Posts
    40

    xinetd

    According to my understanding of SuSE...you need to enable xinetd first. Go into yast -> network services -> xinetd(network services). Click on enable and select telnet. This is just an extra level of security in SuSE's extended network services. See if this works. Also make sure that the telnet package is installed.

    Also check if your firewall are blocking telnet ports. I have also installed 10.2 and will do some testing and let you know the outcome.

    Regards

  3. #3
    Just Joined!
    Join Date
    Dec 2006
    Posts
    4
    Thanks for the tips. Actually I have already installed all required packages and enabled the telnet feature. my xinetd start command is still failing which bothers me but I will check into my firewall. Thanks!!

  4. #4
    Just Joined! ch@meleon's Avatar
    Join Date
    Mar 2007
    Location
    Pretoria. South Africa
    Posts
    40

    telnet testing

    I have tested on my machine and telnet and xinetd works fine. What error message is the xinetd command giving you. Can I have a look at your telnet file in /etc/xinetd.d/telnet.

    It sounds that you have got more of an xinetd issue than a telnet issue.

    Regards

  5. #5
    Just Joined!
    Join Date
    Dec 2006
    Posts
    4
    I am a secure network so I temporarily disabled my firewall and I can now telnet to my machine however receiving the following error
    telnetd: /usr/lib/mit/sbin/login.krb5: No such file or directory

    Also here is a copy of the file you were interested in...
    # default: off
    # description: Telnet is the old login server which is INSECURE and should \
    # therefore not be used. Use secure shell (openssh).
    # If you need telnetd not to "keep-alives" (e.g. if it runs over a ISDN \
    # uplink), add "-n". See 'man telnetd' for more details.
    service telnet
    {
    socket_type = stream
    protocol = tcp
    wait = no
    user = root
    server = /usr/sbin/in.telnetd
    }

    Thanks so much for you help!!

  6. #6
    Just Joined! ch@meleon's Avatar
    Join Date
    Mar 2007
    Location
    Pretoria. South Africa
    Posts
    40

    telnet services

    In yast go to xinetd settings and disable the second telnet service /usr/lib/mit/telnetd and make sure that only the first one is enabled. Restart xinetd.

    Test by using telnet localhost.

    See if this helps.

    Regards

  7. #7
    Just Joined!
    Join Date
    Dec 2006
    Posts
    4
    That worked!! Thanks so much. I still have to have my firewall disabled but I imagine there are settings w/ in that I can manipulate to be able to telnet through it. I will do some research on that and check back if I still have problems. Thanks again!!

  8. #8
    Just Joined! ch@meleon's Avatar
    Join Date
    Mar 2007
    Location
    Pretoria. South Africa
    Posts
    40
    No Probs...Glad I could help

  9. #9
    Just Joined!
    Join Date
    Aug 2012
    Posts
    1
    Thanks for the posts above.

    I am also facing the same issue. So I followed the methods mentioned in the above posts.

    If I turn off the first telnet service(/usr/lib/mit/telnetd), I get the below error:

    telnet <ip>
    Trying <ip>...
    telnet: connect to address <ip>: Connection refused

    If I turn off the second telnet service, I get the error as below:

    (Linux release 2.6.16.60-0.85.1-smp #1 SMP Thu Mar 17 11:45:06 UTC 2011) (1)

    telnetd: /usr/lib/mit/sbin/login.krb5: No such file or directory
    .
    Connection closed by foreign host.

    Also I'm not able to FTP. May there be a possibility that xinetd service is not functioning properly??

    Please suggest...

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •