Find the answer to your Linux question:
Results 1 to 2 of 2
I tried to mount my back-up partition located on another hard-drive. mount -t ext3 /dev/sda2 /local With the following result: mount: wrong fs type, bad option, bad superblock on /dev/sda2, ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Mar 2007
    Posts
    4

    Bad superblock, wrong fs type, missing codepage...help!


    I tried to mount my back-up partition located on another hard-drive.
    mount -t ext3 /dev/sda2 /local
    With the following result:
    mount: wrong fs type, bad option, bad superblock on /dev/sda2,
    missing codepage or other error
    In some cases useful info is found in syslog - try
    dmesg | tail or so

    Is all hope out. Can I save my back-up data?
    Any advise is welcome.
    thanks
    P

  2. #2
    Linux User cyberinstru's Avatar
    Join Date
    Jan 2007
    Location
    India
    Posts
    362
    It could because of unclean filesystem.

    Running fsck against ur FS shud solve the issue.

    Do
    fsck /dev/sda2
    ---------------------------------
    Registered Linux User #440311
    HI2ARUN _AT_ GMAIL _DOT_ COM
    ---------------------------------

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •