Find the answer to your Linux question:
Results 1 to 9 of 9
Let me say first your help is much appriciated. I am running Suse 10.2 w/ gnome Here is me delima... I want to install and use gstm (an ssh manager) ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Newbie AboveNBeyond's Avatar
    Join Date
    Mar 2007
    Posts
    120

    Installing gstm in SuSE 10.2


    Let me say first your help is much appriciated. I am running Suse 10.2 w/ gnome
    Here is me delima...
    I want to install and use gstm (an ssh manager)
    I download the tar
    I uncompress it (i think) I say think cause it shows as black text with green back ground. I ran this command "tar zxf gstm-1.2.tar.gz "
    so I run ./configure
    and get this...
    checking for a BSD-compatible install... /usr/bin/install -c
    checking whether build environment is sane... yes
    checking for gawk... gawk
    checking whether make sets $(MAKE)... yes
    checking whether to enable maintainer-specific portions of Makefiles... no
    checking for style of include used by make... GNU
    checking for gcc... gcc
    checking for C compiler default output file name... a.out
    checking whether the C compiler works... yes
    checking whether we are cross compiling... no
    checking for suffix of executables...
    checking for suffix of object files... o
    checking whether we are using the GNU C compiler... yes
    checking whether gcc accepts -g... yes
    checking for gcc option to accept ANSI C... none needed
    checking dependency style of gcc... gcc3
    checking for library containing strerror... none required
    checking for gcc... (cached) gcc
    checking whether we are using the GNU C compiler... (cached) yes
    checking whether gcc accepts -g... (cached) yes
    checking for gcc option to accept ANSI C... (cached) none needed
    checking dependency style of gcc... (cached) gcc3
    checking for gcc... (cached) gcc
    checking whether we are using the GNU C compiler... (cached) yes
    checking whether gcc accepts -g... (cached) yes
    checking for gcc option to accept ANSI C... (cached) none needed
    checking dependency style of gcc... (cached) gcc3
    checking how to run the C preprocessor... gcc -E
    checking for egrep... grep -E
    checking for ANSI C header files... yes
    checking for pkg-config... /usr/bin/pkg-config
    checking pkg-config is at least version 0.9.0... yes
    checking for PACKAGE... configure: error: Package requirements (libgnomeui-2.0) were not met.
    Consider adjusting the PKG_CONFIG_PATH environment variable if you
    installed software in a non-standard prefix.

    Alternatively you may set the PACKAGE_CFLAGS and PACKAGE_LIBS environment variables
    to avoid the need to call pkg-config. See the pkg-config man page for
    more details.

    Now I am stuck...
    Do I need to install a compiler or something?

    Please help, thank you.

  2. #2
    Linux User tech_man's Avatar
    Join Date
    Jan 2007
    Location
    USA
    Posts
    385
    I will give you one hint on what you need to install "Package requirements (libgnomeui-2.0) were not met."
    'Tis better to be silent and be thought a fool, than to speak and remove all doubt.'
    --Abraham Lincoln

  3. #3
    Linux Newbie AboveNBeyond's Avatar
    Join Date
    Mar 2007
    Posts
    120
    No tech_man, you think...

    I appriciate your help/comment but I can read, I look in yast and I have libgnomeui 2.16.1-20-x86_64 installed. I am on a 64 bit system, do you think the app requires 32bit to be installed?? Hmmm maybe I will try and see...

    ** Just tried installing 32 bit version as well... NO GO. 'sigh'

  4. #4
    Linux User tech_man's Avatar
    Join Date
    Jan 2007
    Location
    USA
    Posts
    385
    Quote Originally Posted by AboveNBeyond
    I am on a 64 bit system
    You mean you have a 64bit processor or are you running Suse 64bit?
    'Tis better to be silent and be thought a fool, than to speak and remove all doubt.'
    --Abraham Lincoln

  5. #5
    Linux Newbie AboveNBeyond's Avatar
    Join Date
    Mar 2007
    Posts
    120
    Yes to both

  6. #6
    Linux User tech_man's Avatar
    Join Date
    Jan 2007
    Location
    USA
    Posts
    385
    ^^^ You are probably running into library conflicts between 32bit and 64bit. Read this, because with a 64 bit OS installing software from source and be a real pain in the ass, even some precompiled binaries will not work. I have 64bit Ubuntu installed and removed it within a week because it was an incredible pain to install software. You have no real reason running 64bit, don't. Thats my advise.

    As to gstm I took a look at their website and everything seems to be in order accept for the libgnomeui. The only other thing I can think of is uninstalling and reinstalling it, and then rerunning configure. Also make sure you are running the commands as root.
    'Tis better to be silent and be thought a fool, than to speak and remove all doubt.'
    --Abraham Lincoln

  7. #7
    Linux Newbie AboveNBeyond's Avatar
    Join Date
    Mar 2007
    Posts
    120
    Thank you for your help.

    I am running 64 bit well basically cause the Suse 10.2 dvd installed it I am guessing from hardware detection. Hmm...

    I am a newbie to linux and have already tested a few versions, but I seem impressed so far with Suse.

    Wouldn't the performance be hurt using the 32bit??

  8. #8
    Linux User tech_man's Avatar
    Join Date
    Jan 2007
    Location
    USA
    Posts
    385
    Quote Originally Posted by AboveNBeyond
    Wouldn't the performance be hurt using the 32bit??
    Yes, theoretically. No, practically. In going from 64bit Ubuntu to 32bit Ubuntu, I didn't notice anything.
    'Tis better to be silent and be thought a fool, than to speak and remove all doubt.'
    --Abraham Lincoln

  9. #9
    Just Joined! BlueSky77's Avatar
    Join Date
    Jan 2007
    Posts
    5
    Quote Originally Posted by AboveNBeyond View Post
    Let me say first your help is much appriciated. I am running Suse 10.2 w/ gnome
    Here is me delima...
    <snip>
    Now I am stuck...
    Do I need to install a compiler or something?

    Please help, thank you.
    I know it's been a while since you asked this question so if you got it working, great. If not, I have it running on my OpenSuse 10.2 installation. You not only need the "libgnomeui 2.0" package but you also need to install "libgnomeui-devel". After installing the libgnomeui-devel package, I was able to configure and install gstm with no problems.

    I hope this helps.


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •