Find the answer to your Linux question:
Page 1 of 4 1 2 3 4 LastLast
Results 1 to 10 of 31
ive bin trying for ages to get a tunnel setup with putty from my work pc with xp, to my suse10.2 box at home. on the xp box, i get ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Mar 2007
    Location
    liverpool, uk
    Posts
    65

    Angry ssh tunnel from winxp to suse 10.2 with putty!


    ive bin trying for ages to get a tunnel setup with putty from my work pc with xp, to my suse10.2 box at home. on the xp box, i get time out error in putty. i havent edited my sshd_config file yet! i checked netstat and ssh is listening, and my firewall is set to accept ssh!

    any advice on editing the sshd_config file, and what settings would need to be used in putty?

    ive set putty to use ver. 2, and to use UTF-8

    thanks in advance.

  2. #2
    Linux Guru sdousley's Avatar
    Join Date
    Feb 2004
    Posts
    1,790
    firstly, can you ssh into the computer without setting up any tunnels? If so, how are you setting up the tunnel in putty?

    The way i do it (for this example i will use the example i use of VNC'ing into my desktop at home) is to go to the "tunnels" section, and in the "source port" put the port u want to forward. I usually use port 1025.

    In the "Destination" you need to put the destination IP (the internal one on the network) AND port you want to forward to. So i put 192.x.x.113:5900 (my desktop is on 192.x.x.113 and VNC server runs on port 5900)

    Then when that's all connected and logged in, i tell the VNC client to connec to localhost on port 1025, and the ssh tunnel will pick that up and send it down the tunnel, and i will hve a VNC connection to my desktop.

    The IP can be anything the computer you're ssh'ing into can access. for example i actually ssh into my server on 192.x.x.2 so the connection appears (to my desktop) to come from there, not wherever i am.

    If needed, i can paste a screenshot of a working setup.
    "I am not an alcoholic, alcoholics go to meetings"
    Registered Linux user = #372327

  3. #3
    Linux Newbie harner's Avatar
    Join Date
    Jun 2004
    Location
    PA, USA
    Posts
    209
    Turn the firewall off in YaST or at least enable SSH to work. If you want to do file transfers then I am going to recommend WinSCP3. Check it out.
    I praise Webmin and PuTTy!
    Registered Linux User: 439431

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Mar 2007
    Location
    liverpool, uk
    Posts
    65
    I cant connect without a tunnel, cos i only have port 8080 open, due to the work proxy!

    ive put the proxy in the proxy field, obviously, then in the tunnel, i set the source to 8080, then destination is set to myip:5905.

    then in the session part again i put myip:5905

    ive set the sshd_config port from the 22 default to 5905.

    when i do this, and press open, it hangs for about 3mins, then timesout! it never asks me for any login details. theres just the green cursor on the black background!!

    do i need to set login details in in sshd_config? if so how?

    once i get the tunnel set up, i can use firefox instead of vnc with 127.0.0.1 set as the proxy, coz vnc is locked down on the xp box!

  6. #5
    Just Joined!
    Join Date
    Mar 2007
    Location
    liverpool, uk
    Posts
    65
    thanks harner, but i dont fancy turning my firewall off, as then there would be nothing between me and the nasty world!! ive already enabled ssh in the firewall tho!

  7. #6
    Linux Newbie framp's Avatar
    Join Date
    Jul 2006
    Location
    Stuttgart, Germany
    Posts
    240
    Have you tested that the ssh server can be access on your system at home without any tunneling? Ask a friend to connect to your system with ssh.
    "Really, I'm not out to destroy Microsoft. That will just be a completely unintentional side effect." Linus Benedict Torvalds

  8. #7
    Linux Guru bigtomrodney's Avatar
    Join Date
    Nov 2004
    Location
    Ireland
    Posts
    6,133
    Hint :- Ports 80 and 443 ...consider running your SSH server on one of those ports. 443 is the SSL port and is the best way to go as it is almost universally open for SSL connections.

  9. #8
    Just Joined!
    Join Date
    Mar 2007
    Location
    liverpool, uk
    Posts
    65

    Smile

    i only have port 8080 which goes thru work proxy, which then goes to my suse box. i want to tunnel with putty.

    ssh is running properly, cos its listening in netstat on the port i am setting up to use, which is 5905. and the firewall is set up correctly to allow ssh and thru port 5905.

    the connection times out tho in putty, it doesnt ask for any login details!

    i think were nearly there. thanks so far.

  10. #9
    Linux Newbie
    Join Date
    May 2006
    Location
    Kansas
    Posts
    187
    I'd almost bet you just aren't able to reach the listening port on your home box. A simple way to tell if you can get to it or not is to use "telnet". On your work machine, type:
    telnet <home ip> 5905

    You see something like this if everything is good:

    localhost:/tmp:$ telnet <home ip> 5905
    Trying...
    Connected to <home ip>.
    Escape character is '^]'.
    SSH-2.0-OpenSSH_4.1

    Protocol mismatch.
    Connection closed.
    localhost:/tmp:$

    If that just hangs, you aren't getting to your machine.
    If you are getting "Connection Refused", and you are 100% sure your 5905 port is listening, some one between you and your ssh daemon is blocking the traffic.

  11. #10
    Linux Newbie
    Join Date
    May 2006
    Location
    Kansas
    Posts
    187
    Quote Originally Posted by kahoona
    localhost:/tmp:$ telnet <home ip> 5905
    Of course this doesn't actually establish a usable connection, it is just for testing connectivity.

Page 1 of 4 1 2 3 4 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •