Well, I had it before and I can't get it back! What's that you ask? Well, twinview setup using compiz, XGL. I was able to maximise a window and it would snap to the screen it was on - NOT span both desktops which is driving me crazy. I read somewhere that it may be the ServerLayout options in Xorg.conf that I need to edit. However I have no idea what to do. Incidentally the dual monitors are coming off one Nvidea card. Nvidia GeForce4 TI 4800 SE to be precise. I am on Suse Enterprise Desktop (10.1) and have twinview working perfectly EXCEPT expanding windows fully spreads across both screens instead of snapping to the one their on. I am not interested in cloned multihead by the way...

I am submitting my xorg.conf below in the deparate hope that some very smart person out there can help. Some have said it cannot be done but I have already done it in the recent past, although I don't know what I di to get it working! Thanks! Here's the xorg.conf...

# /.../
# SaX generated X11 config file
# Created on: 2007-04-23T14:35:30+1000.
#
# Version: 7.1
# Contact: Marcus Schaefer <sax@suse.de>, 2005
# Contact: SaX-User list <https://lists.berlios.de/mailman/listinfo/sax-users>
#
# Automatically generated by [ISaX] (7.1)
# PLEASE DO NOT EDIT THIS FILE!
#

Section "Files"
FontPath "/usr/X11R6/lib/X11/fonts/misc:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/local"
FontPath "/usr/X11R6/lib/X11/fonts/75dpi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/100dpi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/Type1"
FontPath "/usr/X11R6/lib/X11/fonts/URW"
FontPath "/usr/X11R6/lib/X11/fonts/Speedo"
FontPath "/usr/X11R6/lib/X11/fonts/PEX"
FontPath "/usr/X11R6/lib/X11/fonts/cyrillic"
FontPath "/usr/X11R6/lib/X11/fonts/latin2/misc:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/latin2/75dpi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/latin2/100dpi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/latin2/Type1"
FontPath "/usr/X11R6/lib/X11/fonts/latin7/75dpi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/baekmuk:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/japanese:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/kwintv"
FontPath "/usr/X11R6/lib/X11/fonts/truetype"
FontPath "/usr/X11R6/lib/X11/fonts/uni:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/CID"
FontPath "/usr/X11R6/lib/X11/fonts/ucs/misc:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/ucs/75dpi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/ucs/100dpi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/hellas/misc:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/hellas/75dpi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/hellas/100dpi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/hellas/Type1"
FontPath "/usr/X11R6/lib/X11/fonts/misc/sgi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/xtest"
FontPath "/opt/kde3/share/fonts"
InputDevices "/dev/gpmdata"
InputDevices "/dev/input/mice"
EndSection

Section "ServerFlags"
Option "AllowMouseOpenFail" "on"
EndSection

Section "Module"
Load "extmod"
Load "type1"
Load "glx"
Load "freetype"
Load "dbe"
Load "v4l"
EndSection

Section "InputDevice"
Driver "kbd"
Identifier "Keyboard[0]"
Option "Protocol" "Standard"
Option "XkbLayout" "us"
Option "XkbModel" "pc104"
Option "XkbRules" "xfree86"
EndSection


Section "InputDevice"
Driver "mouse"
Identifier "Mouse[1]"
Option "Buttons" "11"
Option "Device" "/dev/input/mice"
Option "Name" "Microsoft IntelliMouse?? Explorer"
Option "Protocol" "explorerps/2"
Option "Vendor" "Sysp"
Option "ZAxisMapping" "4 5"
EndSection


Section "Monitor"
Option "CalcAlgorithm" "XServerPool"
DisplaySize 305 230
HorizSync 31-48
Identifier "Monitor[0]"
ModelName "1024X768@60HZ"
Option "DPMS"
VendorName "--> VESA"
VertRefresh 50-60
UseModes "Modes[0]"
EndSection


Section "Modes"
Identifier "Modes[0]"
Modeline "1024x768" 65.00 1024 1048 1184 1344 768 771 777 806 -HSync -VSync
Modeline "1024x768" 65.0 1024 1048 1184 1344 768 771 777 806 -hsync -vsync
EndSection


Section "Screen"
DefaultDepth 24
SubSection "Display"
Depth 15
Modes "1024x768" "1024x600" "800x600" "768x576" "640x480"
EndSubSection
SubSection "Display"
Depth 16
Modes "1024x768" "1024x600" "800x600" "768x576" "640x480"
EndSubSection
SubSection "Display"
Depth 24
Modes "1024x768" "1024x600" "800x600" "768x576" "640x480"
EndSubSection
SubSection "Display"
Depth 8
Modes "1024x768" "1024x600" "800x600" "768x576" "640x480"
EndSubSection
Device "Device[0]"
Identifier "Screen[0]"
Monitor "Monitor[0]"
EndSection


Section "Device"
BoardName "GeForce4 Ti 4800 SE"
BusID "1:0:0"
Driver "nvidia"
Identifier "Device[0]"
Option "CIOverlay"
Option "Dac8Bit"
Option "SaXDualHead"
Option "TwinView"
Option "SaXDualMonitorVendor" "--> VESA"
Option "SecondMonitorHorizSync" "31-50"
Option "SaXDualMonitorModel" "1024X768@60HZ"
Option "SaXDualVSync" "50-60"
Option "MetaModes" & quot;[MONITORLAYOUT]:1024x768,[MONITORLAYOUT]:1024x768;[MONITORLAYOUT]:1024x600,
[MONITORLAYOUT]:1024x600;[MONITORLAYOUT]:800x600,[MONITORLAYOUT]:800x600;[MONITO
RLAYOUT]:768x576,[MONITORLAYOUT]:768x576;[MONITORLAYOUT]:640x480,[MONITORLAYOUT]
:640x480"
Option "SaXDualOrientation" "RightOf"
Option "SaXDualResolution" "1024x768"
Option "ConnectedMonitor" "[MONITORLAYOUT]"
Option "TwinViewOrientation" "RightOf"
Option "SaXDualMode" "Xinerama"
Option "SecondMonitorVertRefresh" "50-60"
Option "SaXDualHSync" "31-50"
Screen 0
VendorName "NVIDIA"
EndSection


Section "ServerLayout"
Identifier "Layout[all]"
InputDevice "Keyboard[0]" "CoreKeyboard"
InputDevice "Mouse[1]" "CorePointer"
Option "Clone" "off"
Option "Xinerama" "off"
Screen "Screen[0]"
EndSection


Section "DRI"
Group "video"
Mode 0660
EndSection

Section "Extensions"
EndSection