Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 11
i ve installed beryl with all packages needed etc. i have installed the latest ati drivers as described in a forum i read. when i dont have beryl enabled, the ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Newbie
    Join Date
    Apr 2007
    Posts
    117

    Beryl with suse 10.2


    i ve installed beryl with all packages needed etc. i have installed the latest ati drivers as described in a forum i read. when i dont have beryl enabled, the "cube" moves normally, fast etc.. But when i enable beryl everything goes increadibly slow. I tried to reduce some effects but nothing. i have ati xpress 200m at a gateway laptop

  2. #2
    Linux Newbie
    Join Date
    Apr 2007
    Posts
    117
    This is weird.. I created a new user, with normal user rights as the previous one, i enabled beryl and everything goes smooth. It seems to me that i should maintain 2 accounts, one for everyday operations and a second in order to test first whether certain features work.. Any ideas for the cause of the previous issue?

  3. #3
    Linux Guru gogalthorp's Avatar
    Join Date
    Oct 2006
    Location
    West (by God) Virginia
    Posts
    3,104
    You probably have a bad configuration file in the home directory. I had a situation like this with sound. For some reason my main user at the time had two copies of kdesktop running which hosed sound on some programs. I created a new user and all was well for him. So I simple moved all the personal stuff from the old user to the new one and all has been well for some time. Never did figure out where the problem was.

    For the user that has problems you might want to run ps -A to veiw the process running. See if you have any apperant duplicates.

  4. #4
    Linux Newbie
    Join Date
    Mar 2007
    Posts
    243
    I found out that Suse creates a new file when you try a new feature and locates it in a different directory. That happened to me with DCOPserver, which ended up screwing up my opensuse updater. My solution was to delete one of the files, and all is well now. (DCOPserver changed after I tried 3D and special effects in the desktop. On top of that the system takes away rw privileges to the old user in the new file, so unless you delete the "bad" file you end up screwed up. If you decide to delete the file, you have to reboot and the system creates a new file that fixes everything. The other solution is to grant privileges to the new file.) I don't know if this would help. I hope so. Good luck!

  5. #5
    Linux Newbie
    Join Date
    Apr 2007
    Posts
    117

    Cool

    Where do i find those files? Again after some time i have the same problems with Beryl, so i dont have it anymore to load at startup. If i load it everything goes slow like a turtle. Which Beryl files should i look to? Where could i find them? Also, what should i do if i would like to restore Beryl and Emeralda to their "factory" defaults?
    Ubuntu 8.04 [32bit] @ Gateway MX6453 Notebook

  6. #6
    Linux Newbie
    Join Date
    Apr 2007
    Posts
    117

    Angry Aaaaaaaaaaah!!!!!!!

    ok i tried to update beryl, emerald and everything related to see whether the problem would be solved but nothing. whenever beryl loads everything goes so damn slow plus i cannot even type anywhere! what should i do guys, please check my previous post to see whether sth of those would be relevant to the solution.

    Thank you very much
    Ubuntu 8.04 [32bit] @ Gateway MX6453 Notebook

  7. #7
    Linux Newbie
    Join Date
    Apr 2007
    Posts
    117

    Thumbs down

    Also relevant is the below, when i type "beryl" at the console, either as root, or as a regular user. By the way, I tried to uninstall beryl and the window decorators, reinstall it and reload it. It worked only once. Afterwards i got some error msgs which i dont have and finally i am left with the msgs below:

    ************************************************** ************
    * Beryl system compatiblity check *
    ************************************************** ************
    Detected xserver : XGL
    Checking Display :0 ...
    Checking for XComposite extension : passed (v0.3)
    Checking for XDamage extension : passed
    Checking for RandR extension : passed
    Checking for XSync extension : passed

    beryl: GLX_EXT_texture_from_pixmap is missing
    beryl: Using non-tfp mode
    beryl: GLX_SGIX_fbconfig is missing
    beryl: Failed to manage screen: 0
    beryl: No manageable screens found on display :0
    Ubuntu 8.04 [32bit] @ Gateway MX6453 Notebook

  8. #8
    Linux Guru gogalthorp's Avatar
    Join Date
    Oct 2006
    Location
    West (by God) Virginia
    Posts
    3,104
    Have you installed a 3d Driver for your Video card?

  9. #9
    Linux Newbie
    Join Date
    Mar 2007
    Posts
    243
    Quote Originally Posted by gogalthorp View Post
    Have you installed a 3d Driver for your Video card?
    Also check hardware compatibility. Take a look at this:


    ##
    ## ATI cards supported by radeon driver
    ##
    DRIVER =
    PACKAGES =
    SETUP = /etc/X11/xgl-intel-setup.sh
    XGL_OPTS = -accel glxbuffer -accel xvbuffer

    # Supported ATI cards
    G 1002:3150 # MOBILITY RADEON X600 (M24 3150)
    G 1002:4966 # RV250 If
    G 1002:4e44 # RADEON 9700 PRO (R300 4E44)
    G 1002:4e47 # FireGL X1 (R300 4E47)
    G 1002:5157 # RV200 QW
    G 1002:5653 # MOBILITY RADEON X700 (M26 5653)
    G 1002:5960 # RV280 5960
    G 1002:5961 # RV280 5961
    G 1002:5b64 # FireGL V3100 (RV370 5B64)

    # Unsupported-but-partially-working ATI cards
    S 1002:5159 # Radeon VE

    # Non-Xgl-compatible ATI cards

    # Unrecognized ATI cards
    U 1002:4c57 # Radeon LW
    U 1002:4e50 # MOBILITY RADEON 9600/9700 (M10/M11 4E50)
    U 1002:5b60 # RADEON X300/X550 (RV370 5B60)


    ##
    ## ATI cards
    ##
    DRIVER = fglrx
    PACKAGES = x11-video-fglrx ati-fglrx-kmp
    SETUP = /etc/X11/xgl-fglrx-setup.sh
    XGL_OPTS = -accel glxbuffer -accel xvbuffer

    # Supported ATI cards
    G 1002:3150 # M24 1P [Radeon Mobility X600]
    G 1002:4a4d # R420 JM [FireGL X3]
    G 1002:4e54 # M10 NT [FireGL Mobility T2]
    G 1002:5460 # M22 [Radeon Mobility M300]
    G 1002:5b62 # RV370 5B62 [Radeon X600 (PCIE)]
    G 1002:5b72 # RV380 5B62 [Radeon X600 (PCIE)]
    G 1002:7146 # RADEON X1300 LE (RV515 7146)
    G 1002:71c4 # MOBILITY FireGL V5200 (M56 71C4)

    # Unsupported-but-partially-working ATI cards
    S 1002:4c57 # Radeon Mobility M7 LW [Radeon Mobility 7500]

    # Non-Xgl-compatible ATI cards
    B 1002:4752 # Rage XL
    B 1002:4c66 # Radeon R250 Lf [FireGL 9000]
    B 1002:5961 # RV280 [Radeon 9200]
    B 1002:7100 # R520 [Radeon X1800]
    B 1002:7120 # R520 [Radeon X1800] (Secondary)
    B 1002:71c2 # RADEON X1600 PRO (RV530 71C2)

    Good luck!

  10. #10
    Linux Newbie
    Join Date
    Apr 2007
    Posts
    117

    Unhappy

    i formatted the linux partitions...
    tried to reinstall ati BUT i noticed something: the system dialog of the ATI installer says that i have glibc 2.1. However at Yast, software mgt. it says that i have 2.5 (at the details section) ...
    dont know what to do..
    Ubuntu 8.04 [32bit] @ Gateway MX6453 Notebook

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •