Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 11
Just installed openSuse 10.2 and I am solving the problems one by one. Amongst the first ones is the size of the system fonts which are too small for my ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    May 2007
    Location
    Thessaloniki, Greece
    Posts
    12

    System fonts in KDE - too small


    Just installed openSuse 10.2 and I am solving the problems one by one. Amongst the first ones is the size of the system fonts which are too small for my old eyes. I have been unable to find a way of changing them anywhere (but I am sure a way will be there somewhere). I checked previous threads but the references I found were for the fonts used in the Konsole/Terminal, where indeed this is easy.
    Any ideas?
    PS: I have also done something terrible. I changed the font size in QT (easily doable). I have mistakenly put a font size which now places the box to change it back outside my screen and the thing wont scroll!! Therefore, impossible to change it back! The value to change will be in some file somewhere which I can access through the konsole and change it with vi but I don't know which file this may be. Oh, and I was root at the time.
    Thanks for any help anyone can give.

  2. #2
    oz
    oz is offline
    forum.guy
    Join Date
    May 2004
    Location
    arch linux
    Posts
    18,733
    I don't fool with Suse much so probably can't be of much help, but maybe you can change your DPI on your screen to make the system fonts smaller.

    On the setting that now resides outside the screen edges, maybe you can switch to a higher resolution so you can see the setting and change it, then change the resolution back afterwards.
    oz

  3. #3
    Just Joined!
    Join Date
    May 2007
    Location
    Thessaloniki, Greece
    Posts
    12
    Many fhanks for this. In fact, I want to make system fonts bigger so I would have to lower the resolution. The current ones are 9pt and they certainly look even smaller. I am long in the tooth, longsighted and shortsighted at the same time. Lowering the resolution further would have side effects elsewhere (the obvious one being the information windows may carry considering that all other elements, such as icons, would also get bigger).

    I am afraid the box is outside the screen even on the maximum resolution of my screen, so the answer has to be the manual editing of some parameters' file somewhere.

  4. #4
    oz
    oz is offline
    forum.guy
    Join Date
    May 2004
    Location
    arch linux
    Posts
    18,733
    Quote Originally Posted by ozar View Post
    but maybe you can change your DPI on your screen to make the system fonts smaller.
    Yeah, I meant bigger... sorry.
    oz

  5. #5
    Linux Guru budman7's Avatar
    Join Date
    Oct 2004
    Location
    Knee deep in Grand Rapids, Michigan
    Posts
    3,242
    You need to edit the kdeglobals file.
    See this old topic.
    http://www.linuxforums.org/forum/man...t-problem.html
    How to know if you are a geek.
    when you respond to "get a life!" with "what's the URL?"
    - Birger

    New users read The FAQ

  6. #6
    Just Joined!
    Join Date
    May 2007
    Location
    Thessaloniki, Greece
    Posts
    12
    Thanks for this, I'll try it (and though I haven't used vi for 18 years, I still remember how to). A question, though. What exactly will it fix? It sounds as if it will fix the general font problem, not the specific one on QT (which at the moment yields huge letters as it did for you). If so (if it fixes the general problem of system fonts) are the values proposed reasonable for making the system fonts bigger? in other words, I need to make the QT fonts smaller and the system fonts bigger!
    I will probably try it tomorrow, though, as it's past midnight over here.

  7. #7
    Linux User IsaacKuo's Avatar
    Join Date
    Feb 2005
    Location
    Baton Rouge, LA, USA
    Posts
    405
    If you haven't used vi in 18 years, I'm guessing you're new to Linux and probably new to what's been happening with X in the last...umm...decade.

    One thing which you'll probably find surprising is that the dpi setting is actually determined indirectly. In the X configuration file (/etc/X11/xorg.conf), the SIZE of the screen is specified, in millimeters.

    The result is that the physical size of the fonts will be roughly the same regardless of what resolution you choose. For example, if a 9 point font is 9 pixels tall at 800x600 resolution, it'll be 18 pixels tall at 1600x1200 resolution.

    This forces you to do some arithmetical gymnastics to get the results you want. In order to make all the fonts look bigger, you can either configure all font sizes individually, or tell the X server that the size of the screen is smaller than it really is. Unfortunately, some software ignores this information and assumes their own ideas about what "dpi" the display should be.
    Isaac Kuo, ICQ 29055726 or Yahoo mechdan

  8. #8
    Just Joined!
    Join Date
    May 2007
    Location
    Thessaloniki, Greece
    Posts
    12
    Thanks this is great help. If anything because I now see that I was looking/thinking in the wrong direction, and I also see how much I missed in the last ... umm ... decade. I won't lie to X about my screen size because I dread the side effects - I guess that along with the fonts all sorts of other things may get bigger while others will stay the same, for the reasons you state, causing havoc.
    I looked at the xorg.conf. It describes my screen exactly as you say as 432x324 mm. At the top of the file it gives several font paths. I suspect the offending font is the one 4th from the bottom in directory "/opt/kde3/share/fonts", in the file console8x16.pcf.gz. This is just a guess of course. Problem is I don't know how to configure fonts. Could you recommend something I can read and learn?

  9. #9
    Linux Guru gogalthorp's Avatar
    Join Date
    Oct 2006
    Location
    West (by God) Virginia
    Posts
    3,104
    The easiest way is to open
    (Assuming KDE)

    Personal Setting (configure Desktop)->Appearance & Themes->Fonts

    Note some applications might not honor these settings but the vast majority should.

    Also a hint on moving windows. If you can get to an edge right click it and you will get a menu...The rest is obvious

  10. #10
    Just Joined!
    Join Date
    May 2007
    Location
    Thessaloniki, Greece
    Posts
    12
    Oooops!! Echoes of Columbus' egg over here. Great. Both problems solved!! Thank you gogalthorp.

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •