Find the answer to your Linux question:
Page 2 of 3 FirstFirst 1 2 3 LastLast
Results 11 to 20 of 21
Actually the following did the trick in 10.2 edit /etc/nsswitch.conf: change: hosts: files dns to: hosts: files dns wins But in 10.3 that wouldn't work and then when I went ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #11
    Just Joined!
    Join Date
    Jun 2005
    Posts
    27

    Actually the following did the trick in 10.2
    edit /etc/nsswitch.conf:
    change: hosts: files dns
    to: hosts: files dns wins

    But in 10.3 that wouldn't work and then when I went back to adding the IP and I got the following error.
    mount error 13 = Permission denied
    Refer to the mount.cifs( manual page (e.g.man mount.cifs)

    I've resorted to running windows virtually and using that to listen to music while I'm working.

    Warning rant starting:

    This is exactly the kind of thing that drives me nuts with Linux as a desktop OS and why I'll probably wind up replacing this box with a Mac. Setting up a home network should be relatively simple, it should sniff the network by default, and not require delving into conf files to do something as simple as mount a network share. If Linux developers can't figure this out Linux will always be regulated to the OS of servers, power geeks and masochists.

  2. #12
    Linux Guru gogalthorp's Avatar
    Join Date
    Oct 2006
    Location
    West (by God) Virginia
    Posts
    3,104
    If running kde have you tried smb4k??

  3. #13
    Just Joined! whiplash.2006's Avatar
    Join Date
    Nov 2007
    Location
    Newcastle upon Tyne, UK
    Posts
    5

    Samba and Suse 10.2

    I have to say that I have had never ending problems with Samba shares and windows domain membership. The most annoying of all is that every time the machine in question is re-booted it simply forgets every samba configuration change I have made and all needs doing again. Does the machine you are using stay on all the time? If it does (and I am in no way implying that this is a permenant solution but it is what I have had to do) what I would do is after confuiguration simply restart the services using Yast run level services tool and go from there. Not permenant but hey thats what I have been reduced to if I want to use this machine on my home network and browse the net and share files. EEK! Good luck though, will be interested too see if anyone has a genuine solution to this. Also if anyone knows if any of these faults were ironed out in 10.3 as I am still running 10.2.

  4. #14
    Linux Guru gogalthorp's Avatar
    Join Date
    Oct 2006
    Location
    West (by God) Virginia
    Posts
    3,104
    The only problem I have had is that the firewall is not opened up correctly. You must do that manually. To see if that is the problem turn off the firewall and test.

    Here is a good place to start

    for the firrewall
    SuSEfirewall2: HowTo Firewall a Suse/openSUSE Workstation for LAN Network Traffic

    for SAMBA
    Samba: HowTo Set up a Suse-Windows Home Office LAN

  5. #15
    Linux Guru gogalthorp's Avatar
    Join Date
    Oct 2006
    Location
    West (by God) Virginia
    Posts
    3,104
    Also you can configure samba more directly by editing it's config file or in a browser

    localhost:901

    enter root and root password when asked

  6. #16
    Just Joined!
    Join Date
    Jun 2005
    Posts
    27
    Whatever you do just run smb4k as root do not attempt to set it up to use sudo
    It FUBARS the sudoers file.

    >>> sudoers file: syntax error, line 18 <<<
    >>> sudoers file: syntax error, line 19 <<<
    >>> sudoers file: syntax error, line 23 <<<
    >>> sudoers file: syntax error, line 27 <<<
    >>> sudoers file: syntax error, line 30 <<<
    >>> sudoers file: syntax error, line 35 <<<
    >>> sudoers file: syntax error, line 45 <<<
    >>> sudoers file: syntax error, line 56 <<<
    >>> sudoers file: syntax error, line 63 <<<
    >>> sudoers file: syntax error, line 63 <<<


    Thanks for the tip on smb4k, it's more or less the kind of thing I was looking for. On the upside I can at least mount samba shares without hard coding the IP , on the down side I have to do it manually each time I login.

    Oddly, it doesn't show up in a Yast Software search for "samba" even with the description box checked
    Last edited by Baloo; 11-09-2007 at 06:00 PM. Reason: Danger Will Robinson Danger

  7. #17
    Linux Guru gogalthorp's Avatar
    Join Date
    Oct 2006
    Location
    West (by God) Virginia
    Posts
    3,104
    The samba configuration is stored in a text file. These don't simply go away or change. Are you shutting down properly ie not just cutting power???

    Odd I had no problem running smbk as user. There is a setup section where you can set the password. I think. Not running it at present so it is hard to check that.

  8. #18
    Just Joined!
    Join Date
    Jun 2005
    Posts
    27
    It wasn't smb.conf that got screwed up it was /etc/sudoers.

    running smb4k as a regular user it couldn't mount any of the samba shares (popped uo an error msg when I tried), running as root it could (kind of makes since considering that mount requires root privileges) I found a setting in smb4k under super user to use sudo to mount and unmount shares. After I applied it (by clicking Apply then OK) sudo quit working. When using the run as different user gui it kept balking at my root password. Once I finally tried sudo from the command line I got the error I posted above.

    I opened a command line and logged in as root the opened /etc/sudoers with jpico. I found numerous carriage returns inserted in the middle of comments. Once I removed those sudo was fixed and smb4k could mount and umount when run as a regular user.

    So on the upside I'm back to using Amarok to listen to music on my box. Thanks.

    On the downside this is still a ridiculously kludgey way to manage the mounting of network drives.
    1) I now have 3 different interfaces for interacting with Samba (Yast, Control Center, and now smb4k)
    2) I have to open smb4k and hand mount all samba shares each time I log in.
    3) It uses kwallet which I also don't like. Sorry but asking for a password to get at my other passwords strikes me as overkill. If I'm that concerned about a password I won't store it.

    This and "security updates" that install new kernels thereby screwing up most of the code (like video drivers) compiled against the current kernel are the two things that keep me swearing at my box, and prevent me from recommending linux to casual users

  9. #19
    Linux Guru gogalthorp's Avatar
    Join Date
    Oct 2006
    Location
    West (by God) Virginia
    Posts
    3,104
    You forgot the best one localhost:901 (in a web browser)
    This one gives you full control over samba.

    On my machine smb4k reconnected after a restart. Only problem was if the target machine was not available. Then you needed to force an unmount and remount the share. I don't remember it using wallet at all. I just installed it did the configuration and it worked.

  10. #20
    Linux Guru gogalthorp's Avatar
    Join Date
    Oct 2006
    Location
    West (by God) Virginia
    Posts
    3,104
    Here is another good tutorial includes smb4k

    How To Samba With Suse 10.3 And Windows XP

Page 2 of 3 FirstFirst 1 2 3 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •