Find the answer to your Linux question:
Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 21
I'm attempting to auto-mount a samba share on a Suse 10.2 install. First: adding smb://kitchen/music to Konqueror's location bar pulls up the share I started with the following in fstab: ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jun 2005
    Posts
    27

    Samba woes


    I'm attempting to auto-mount a samba share on a Suse 10.2 install.

    First: adding smb://kitchen/music to Konqueror's location bar pulls up the share
    I started with the following in fstab:
    //kitchen/music /mnt/Music cifs username=un,password=pw,gid=users 0 0
    produces the following when I attempt to mount maunally
    norm@Office:~> sudo mount /mnt/Music
    mount: unknown filesystem type 'smbfs'
    After some Googling I attempted
    //kitchen/music /mnt/Music cifs username=un,password=pw,gid=users 0 0
    and got
    norm@Office:~> sudo mount /mnt/Music
    mount error: could not find target server. TCP name kitchen/music not found
    No ip address specified and hostname not found

    I switched back to smbfs and attempeted to start (actually restart as it was listed as running) it in Yast's system services GUI and got the following:

    /etc/init.d/smbfs start returned 6 (program is not configured):
    Mount CIFS File Systems .

    As far as I can tell Samba is configured as running and I know of no way to configure smbfs. I could care less is I use smbfs or cifs (I've had no problems with smbfs in the past) .

    Could someone either let me in on the evidently well kept secrets (Google came up blank) of how to either "configure" smbfs so I can get it running or the appropriate syntax so that cifs can find my Samba share.

    Edited to add: Oh and I'd rather not put the boxes on static IPs

    Thanks for any help and just in case any was wondering:
    norm@Office:~> ls -l /mnt
    total 4
    drwxrwxrwx 2 root users 4096 2007-06-16 12:01 Music
    the local folder does exist

  2. #2
    Linux Newbie
    Join Date
    May 2006
    Location
    Kansas
    Posts
    187
    Quote Originally Posted by Baloo View Post
    norm@Office:~> sudo mount /mnt/Music
    mount error: could not find target server. TCP name kitchen/music not found
    No ip address specified and hostname not found
    This error occurs because your box cannot resolve the hostname "kitchen" to an IP address.

    You should only need the smbd running if you plan to share files from your local machine. You shouldn't need it to connect to your "kitchen" machine. Check your /var/log/messages for errors when you try and restart smb stuff.

  3. #3
    Just Joined!
    Join Date
    Jun 2005
    Posts
    27
    Thanks for the reply but I'm not quite sure what you mean. smb appears to be running fine. It's smbfs I can't get running (and there are no messages in /var/log/messages when I 'restart' smbfs via the System Services GUI in YaST). The only message I get is the one from the pop-up mentioned in my first post. Stating that it's not configured and cifs is starting instead.

    Evidently smbfs been replaced by cifs in the default Suse 10.2 Samba package, but I can't get cifs to mount via fstab unless I plug in the IP address of the Kitchen Box (the two boxes are on a LAN)
    //192.168.1.102/kitchen/music /mnt/Music cifs username=un,password=pw,gid=users 0 0 works just fine, but ip addresses are currently assigned dynamically by the router and I'd prefer to keep it that way, especially since I didn't have this problem with smbfs in 9.3 or 10.1.

    I ran across this
    "Here's a very curious and somewhat annoying openSUSE bug: In openSUSE 10.2 you can use the netBIOS name (e.g. suseserver) instead of the IP address (e.g. 192.168.44.100) in the fstab entry but only if SuseFirewall2 has been turned off."
    in this tutorial: HowTo Mount a CIFS Network Share [AKA Map Network Drive] in openSUSE 10.2+ :: Samba Networking VIII , but shutting down the firewall and setting the Kitchen Box's netBIOS hostname to "Kitchen" didn't work with this fstab line: //kitchen/music /mnt/Music cifs username=un,password=pw,gid=users 0 0

    So I'm still left wanting to know how do I either:

    Stop using cifs and go back to smbfs

    or

    Edit /etc/fstab so that cifs will recognize computer names and not require IP addresses.

    thanks again.

  4. #4
    Just Joined!
    Join Date
    Jun 2005
    Posts
    27
    Bump
    Anyone?

  5. #5
    Linux Newbie
    Join Date
    May 2006
    Location
    Kansas
    Posts
    187
    norm@Office:~> sudo mount /mnt/Music
    mount error: could not find target server. TCP name kitchen/music not found
    No ip address specified and hostname not found
    Can you do "ping kitchen" or "nslookup kitchen"? If neither of those resolve, then your computer is not able to resolve "kitchen" to an IP address.

  6. #6
    Linux Newbie
    Join Date
    May 2006
    Location
    Kansas
    Posts
    187
    I tried starting my "smbfs" without any "cifs" entries in the /etc/fstab and it says 'unused'.

    Then I copy/pasted your entry and modified it for my network, and then started the "smbfs" and it started with "done". Which is good. I haven't done any configuration changes at all from what came with my default 10.2 installation.

    Look in your /var/log/messages for any errors. That may shed some light on what the problem you are having is.

  7. #7
    Just Joined!
    Join Date
    Jun 2005
    Posts
    27
    ping and nslookup don't resolve 'kitchen' but Konqueror is able to resolve 'smb://kitchen'. So somewhere my computer must be able to resolve "kitchen" to an IP.

    To the best of my knowledge I haven't set Samba up any differently that I did in 9.3 or 10.1 (aside from being forced into using cifs over smbfs)

    I looked at the /var/log/messages but not really knowing what to look for I came up empty.
    starting and stopping smbfs (at least via Yast's system services GUI (I know no other way) doesn't produce any lines in /var/log/messages and aside from registering the mount command neither does attempting to mount with either of my //kitchen/ fstab entries.
    thanks again for the help

  8. #8
    Just Joined!
    Join Date
    Nov 2007
    Posts
    1
    Quote Originally Posted by Baloo View Post
    ping and nslookup don't resolve 'kitchen' but Konqueror is able to resolve 'smb://kitchen'. So somewhere my computer must be able to resolve "kitchen" to an IP.

    To the best of my knowledge I haven't set Samba up any differently that I did in 9.3 or 10.1 (aside from being forced into using cifs over smbfs)

    I looked at the /var/log/messages but not really knowing what to look for I came up empty.
    starting and stopping smbfs (at least via Yast's system services GUI (I know no other way) doesn't produce any lines in /var/log/messages and aside from registering the mount command neither does attempting to mount with either of my //kitchen/ fstab entries.
    thanks again for the help
    Try restarting 'cups'. I had stopped it, but apparently that is a needed portion of the name-discovery thing.

  9. #9
    Linux Newbie
    Join Date
    May 2006
    Location
    Kansas
    Posts
    187
    Do you have a wins server specified in your smb.conf?

    Code:
    wins support = yes
    wins server = 192.168.0.100
    Set it to the same as any other machine on your network. It should probably be the IP of your DHCP server (or router).

  10. #10
    Linux Newbie
    Join Date
    May 2006
    Location
    Kansas
    Posts
    187
    Also, make sure you have your "name resolve order" to include "host" (a.k.a. DNS) in your smb.conf:

    Code:
    name resolve order = host wins bcast

Page 1 of 3 1 2 3 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •