Find the answer to your Linux question:
Results 1 to 3 of 3
I am dual booting XP and SUSE using an NTFS USB External HD to store mainly music which I want when I am messing around with Linux. I can see ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    May 2007
    Posts
    11

    Linux/NTFS permissions question


    I am dual booting XP and SUSE using an NTFS USB External HD to store mainly music which I want when I am messing around with Linux.

    I can see my NTFS USB External HD in /media and listen to music no problem but can't delete any of the files or folders from Linux even when I'm root.

    I was a bit concerned about changing the permissions using chmod/chown incase it locks me out when back in Windows. Also I'm not sure what permission to set in Windows (if necessary) that might allow my Linux logon to alter/delete files.

    I understand how to set permissions in Linux and in NTFS but I am not sure about permissions between XP and Linux and if they affect each other.

    Thanks for any help!

  2. #2
    Linux User netstrider's Avatar
    Join Date
    Jul 2005
    Location
    South Africa
    Posts
    478
    It doesn't have anything to do with permissions. Linux can by default not write to NTFS drives. For that you need a special driver called ntfs-3g. I am not too familiar with Suse but I assume you will be able to find it in the Yast repositories if you have the necessary ones enabled, else you can follow the link which will lead you to a straight download. It is likely that you don't have fuse, which you will also have to download in order to get ntfs-3g working, unless you do it via Yast, which will automatically resolve dependencies for you.

    If you choose to do it via source take these steps after downloading the above files.
    tar -zxvf fuse-filename.tar.gz
    change your directory with the 'cd' command to the newly extracted folder.
    ./configure
    make

    (then as root) make install

    After having done that do exactly the same with ntfs-3g, it is a .tgz file but the example is the same.
    To mount your NTFS external drive, I assume it will be automatically mounted, in which case you will have to unmount it first by doing something like:

    umount /dev/sdc1 (as root)
    To make sure that that is your device run the command fdisk -l and check the list for your NTFS external drive. To mount it with read-write permissions do the following as root.

    mkdir /mnt/ExtNTFS
    mount -t ntfs-3g /dev/sdc1 /mnt/ExtNTFS -o defaults,umask=0

    This will then mount it in the directory /mnt/ExtNTFS.

    Good luck

  3. #3
    Just Joined!
    Join Date
    May 2007
    Posts
    11
    Thanks netstrider,

    It was quite easy to do and once I read more about fstab and it settings (umask, uid and gid) I can now let my girlfriend access my music without her deleting it by mistake as the drive mounts the same every time

    I am having a quirky problem with user switching tho, I'll post it seperately:

    http://www.linuxforums.org/forum/sus...tml#post480932

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •