Find the answer to your Linux question:
Results 1 to 4 of 4
hi guys i just installed ubuntu studio on my macbook. for the past two days ive attempted installing the wireless card on the macbook, at first using madwifi and then ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jul 2006
    Posts
    9

    Unhappy ndiswrapper installation issues


    hi guys

    i just installed ubuntu studio on my macbook. for the past two days ive attempted installing the wireless card on the macbook, at first using madwifi and then using ndiswrapper. ive been sticking at my attempts to use ndiswrapper because ive used it successfully in the past on my desktop, but now im getting impatient with as it seems just to not want to work. when i do

    "modprobe ndiswrapper"

    it tells me

    "FATAL: Module ndiswrapper not found."

    ive tried searching for the file on my filesystem but its nowhere to be found.

    so then i tried

    apt-get install build-essential kernel-headers-$(uname -r) module-assistant
    apt-get install ndiswrapper-source
    cd /usr/src
    m-a prepare
    m-a a-i ndiswrapper

    modprobe ndiswrapper

    but after "apt-get install build-essential kernel-headers-$(uname -r) module-assistant"

    i get

    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    build-essential is already the newest version.
    E: Couldn't find package kernel-headers-2.6.22-14-rt

    so it cant find my headers?

    any help with this would be very much appreciated!

    thanks

  2. #2
    Linux Newbie
    Join Date
    Oct 2006
    Posts
    101
    I believe that package is just called: kernel-headers

    also, you can search for package with:

    Code:
    apt-cache search kerenel
    or something more specific like

    Code:
    apt-cache search kerenel | grep headers
    I would also do a search for "ndiswrapper" and see what comes up.

    good luck
    --Erik

  3. #3
    Just Joined!
    Join Date
    Jul 2006
    Posts
    9
    i got it fixed!

    what i done was go back through and uninstall niswrapper and madwifi, removed drivers and all that, then, using teh latest version of ndiswrapper, i followed the ndiswrapper section here:

    Triple booting MacBook: OS X, Ubuntu Edgy, Windows XP | Paul Glover - network developer

    which stated:

    cd ~/Desktop
    tar zxf ndiswrapper-1.31.tar.gz
    cd ndiswrapper-1.31
    sudo make uninstall
    make
    sudo make install
    sudo mount /dev/sda4 /mnt
    sudo ndiswrapper -i "/mnt/Program Files/Macintosh Drivers for Windows XP 1.1.2/net5416/net5416.inf"
    sudo modprobe ndiswrapper
    sudo echo >>/etc/modules "ndiswrapper"
    sudo umount /mnt

    that got my wireless going fine, i was able to connect to my router, but after rebooting, the wireless functionality was lost, so i had to

    sudo gedit /etc/modules

    and then add "ndiswrapper" at the end

    going great now! thanks!

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Dec 2007
    Posts
    1

    This got my wireless working on boot

    Hi. I just happened to be looking through the Ubuntu forum, and found this thread, and it helped me get my wireless up and running everytime on boot.

    I am using a Hewlett-Packard dv6646us. I installed first Ubuntu 7.10 live-cd in safe-graphics mode, and then
    installed Ubuntu Studio like so

    apt-get install ubuntustudio*

    This works better for me than to install it from the Ubuntu Studio DVD.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •