Find the answer to your Linux question:
Results 1 to 4 of 4
I'm having some problems configuring php5. I've recently installed apache2 (which works) and mysql. Right now I'm just trying to make php work online. I tried creating the test file ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined! pianomatrix's Avatar
    Join Date
    May 2007
    Location
    Minnesota, USA
    Posts
    39

    help configuring php5


    I'm having some problems configuring php5. I've recently installed apache2 (which works) and mysql. Right now I'm just trying to make php work online. I tried creating the test file phpinfo. However, my browser links to the text of this file instead of the actual page. Also, phpmyadmin doesn't work - my browser links to the folder instead of the program. When I run php -v, I get errors that say "unable to load dynamic library...". I did install php-cli. I would appreciate some advice. Thanks in advance!

  2. #2
    Penguin of trust elija's Avatar
    Join Date
    Jul 2004
    Location
    Either at home or at work or down the pub
    Posts
    3,653
    This is probably a silly question as I think it prompts you to do so
    when you install PHP, but did you install php-common too?
    "I used to be with it, then they changed what it was.
    Now what was it isn't it, and what is it is weird and scary to me.
    It'll happen to you too."

    Grandpa Simpson



    The Fifth Continent

  3. #3
    Just Joined! pianomatrix's Avatar
    Join Date
    May 2007
    Location
    Minnesota, USA
    Posts
    39
    Yes I definately did. I also just installed php5-pgsql and those "unable to load dynamic library..." errors went away. But the phpinfo file and phpmyadmin still don't work online.

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined! pianomatrix's Avatar
    Join Date
    May 2007
    Location
    Minnesota, USA
    Posts
    39
    I just fixed the problem by doing this:

    ln -s /etc/apache2/mods-available/php5.conf /etc/apache2/mods-enabled/php5.conf
    ln -s /etc/apache2/mods-available/php5.load /etc/apache2/mods-enabled/php5.load

    Now everything works.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •