Find the answer to your Linux question:
Results 1 to 7 of 7
Hey I'm new to Linux and have alot of my music on my external harddrive. But when I plug it in the computer recognizes it but it gives me the ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Feb 2008
    Posts
    6

    Unable to mount external hard drive


    Hey I'm new to Linux and have alot of my music on my external harddrive. But when I plug it in the computer recognizes it but it gives me the message unable to mount the volume 'Simons' I think I have to type in a certain command line of some sort but I cant quite figure it out, any help would be great.

  2. #2
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    Hi and Welcome !

    Plug-in External disk and open Terminal. Execute this
    Code:
    sudo fdisk -l
    df -h
    Post output here.
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  3. #3
    Just Joined!
    Join Date
    Feb 2008
    Posts
    6

    Here's What I got

    justin@Justin:~$ sudo fdisk -l

    Disk /dev/sda: 40.0 GB, 40007761920 bytes
    255 heads, 63 sectors/track, 4864 cylinders
    Units = cylinders of 16065 * 512 = 8225280 bytes
    Disk identifier: 0x29212920

    Device Boot Start End Blocks Id System
    /dev/sda1 * 1 4659 37423386 83 Linux
    /dev/sda2 4660 4864 1646662+ 5 Extended
    /dev/sda5 4660 4864 1646631 82 Linux swap / Solaris

    Disk /dev/sdb: 160.0 GB, 160041885696 bytes
    255 heads, 63 sectors/track, 19457 cylinders
    Units = cylinders of 16065 * 512 = 8225280 bytes
    Disk identifier: 0xe6e82b94

    Device Boot Start End Blocks Id System
    /dev/sdb3 48 19415 155573460 7 HPFS/NTFS
    /dev/sdb4 19416 19457 337365 f W95 Ext'd (LBA)
    justin@Justin:~$ df -h
    Filesystem Size Used Avail Use% Mounted on
    /dev/sda1 36G 3.3G 31G 10% /
    varrun 506M 112K 506M 1% /varjustin@Justin:~$ sudo fdisk -l

    Disk /dev/sda: 40.0 GB, 40007761920 bytes
    255 heads, 63 sectors/track, 4864 cylinders
    Units = cylinders of 16065 * 512 = 8225280 bytes
    Disk identifier: 0x29212920

    Device Boot Start End Blocks Id System
    /dev/sda1 * 1 4659 37423386 83 Linux
    /dev/sda2 4660 4864 1646662+ 5 Extended
    /dev/sda5 4660 4864 1646631 82 Linux swap / Solaris

    Disk /dev/sdb: 160.0 GB, 160041885696 bytes
    255 heads, 63 sectors/track, 19457 cylinders
    Units = cylinders of 16065 * 512 = 8225280 bytes
    Disk identifier: 0xe6e82b94

    Device Boot Start End Blocks Id System
    /dev/sdb3 48 19415 155573460 7 HPFS/NTFS
    /dev/sdb4 19416 19457 337365 f W95 Ext'd (LBA)
    justin@Justin:~$ df -h
    Filesystem Size Used Avail Use% Mounted on
    /dev/sda1 36G 3.3G 31G 10% /
    varrun 506M 112K 506M 1% /var/run
    varlock 506M 0 506M 0% /var/lock
    udev 506M 84K 506M 1% /dev
    devshm 506M 0 506M 0% /dev/shm
    lrm 506M 34M 472M 7% /lib/modules/2.6.22-14-generic/volatile
    justin@Justin:~$
    /run
    varlock 506M 0 506M 0% /var/lock
    udev 506M 84K 506M 1% /dev
    devshm 506M 0 506M 0% /dev/shm
    lrm 506M 34M 472M 7% /lib/modules/2.6.22-14-generic/volatile
    justin@Justin:~$

  4. #4
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    According to output of fdisk -l, External disk has two partitions only. /dev/sdb3 and sdb4.
    /dev/sdb4 is an Extended partition.
    I would suggest you to execute this too
    Code:
    fdisk -l /dev/sdb
    Post output here.

    If you are sure that External disk has one partition only then mount it to share data.
    Code:
    sudo mkdir /media/sdb3
    sudo mount -t ntfs /dev/sdb3 /media/sdb3 -o defaults,umask=0
    ls /media/sdb3
    Install ntfs-3g package to enable write access in External disk.
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  5. #5
    Just Joined!
    Join Date
    Feb 2008
    Posts
    6

    New results

    K heres what happens now, im kinda confused about when the prompt says only root can do that, how do I get to root.



    justin@Justin:~$ fdisk -l /dev/sdb

    Disk /dev/sdb: 160.0 GB, 160041885696 bytes
    255 heads, 63 sectors/track, 19457 cylinders
    Units = cylinders of 16065 * 512 = 8225280 bytes
    Disk identifier: 0xe6e82b94

    Device Boot Start End Blocks Id System
    /dev/sdb3 48 19415 155573460 7 HPFS/NTFS
    /dev/sdb4 19416 19457 337365 f W95 Ext'd (LBA)
    justin@Justin:~$ sudo mkdir /media/sdb3
    [sudo] password for justin:
    mkdir: cannot create directory `/media/sdb3': File exists
    justin@Justin:~$ sudo mount -t ntfs /dev/sdb3 /media/sdb3 -o defaults,umask=0
    $LogFile indicates unclean shutdown (0, 0)
    Failed to mount '/dev/sdb3': Operation not supported
    Mount is denied because NTFS is marked to be in use. Choose one action:

    Choice 1: If you have Windows then disconnect the external devices by
    clicking on the 'Safely Remove Hardware' icon in the Windows
    taskbar then shutdown Windows cleanly.

    Choice 2: If you don't have Windows then you can use the 'force' option for
    your own responsibility. For example type on the command line:

    mount -t ntfs-3g /dev/sdb3 /media/sdb3 -o force

    Or add the option to the relevant row in the /etc/fstab file:

    /dev/sdb3 /media/sdb3 ntfs-3g defaults,force 0 0
    justin@Justin:~$ ls /media/sdb3
    justin@Justin:~$ mount -t ntfs-3g /dev/sdb3 /media/sdb3 -o force
    mount: only root can do that
    justin@Justin:~$

  6. #6
    Just Joined!
    Join Date
    Feb 2008
    Posts
    6

    I figured it out :D

    K all I did was logged into root then forced the mount and it worked thanks for all your help Casper

  7. #7
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    Glad to help you.
    Do start a new thread if you have any other question.
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •