Find the answer to your Linux question:
Results 1 to 9 of 9
I was trying to configure a Windows Decorator file I downloaded off kde-look.org. I unpacked it and cd into the folder. When I tried to run ./configure, I got this ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux User SkittleLinux18's Avatar
    Join Date
    Dec 2007
    Location
    Mesa, AZ
    Posts
    310

    ./configure experiences an error in terminal


    I was trying to configure a Windows Decorator file I downloaded off kde-look.org. I unpacked it and cd into the folder. When I tried to run ./configure, I got this error:

    checking for X... configure: error: Can't find X includes. Please check your installation and add the correct paths!
    What does that mean and how do I fix it?? Thanks in advance.
    Using Linux since June 2007
    Distros: Mint 16 KDE
    SPECS: AMD Atholon 64 X2 3.2 Ghz, 4GB RAM, GeForce GTS 250 1GB VRAM
    When your whole life is on one computer, servers and all, choose stability over anything else.

  2. #2
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    Hi SkittleLinux18 !

    You have to install X development libraries first. Execute this
    Code:
    sudo apt-get update
    sudo apt-get install xlibs-dev
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  3. #3
    Linux User SkittleLinux18's Avatar
    Join Date
    Dec 2007
    Location
    Mesa, AZ
    Posts
    310
    Quote Originally Posted by devils casper View Post
    Hi SkittleLinux18 !

    You have to install X development libraries first. Execute this
    Code:
    sudo apt-get update
    sudo apt-get install xlibs-dev
    Hey buddy!! I did apt-get and learned that xlibs-dev is now known as xlibs-static-dev. After installing that, it still would not work. I got hung up on the same error. I tried executing "./configure --prefix=/usr" but it still doesn't work. What am I missing??
    Using Linux since June 2007
    Distros: Mint 16 KDE
    SPECS: AMD Atholon 64 X2 3.2 Ghz, 4GB RAM, GeForce GTS 250 1GB VRAM
    When your whole life is on one computer, servers and all, choose stability over anything else.

  4. #4
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    My mistake ! You are compiling KDE based package and it needs kdebase development libraries too.
    Execute this
    Code:
    sudo apt-get install kdebase-dev
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  5. #5
    Linux User SkittleLinux18's Avatar
    Join Date
    Dec 2007
    Location
    Mesa, AZ
    Posts
    310
    Hey, I got it to configure. Thank you!

    Interestingly enough, I still can't get it to install. It configured just fine, but I keep getting hung up on "make" and "make install." I don't know which. Here is what happens on make:

    root@brian-laptop:/home/kevin/Desktop/crystal-1.0.5# make
    make all-recursive
    make[1]: Entering directory `/home/kevin/Desktop/crystal-1.0.5'
    Making all in pics
    make[2]: Entering directory `/home/kevin/Desktop/crystal-1.0.5/pics'
    make[2]: Nothing to be done for `all'.
    make[2]: Leaving directory `/home/kevin/Desktop/crystal-1.0.5/pics'
    Making all in client
    make[2]: Entering directory `/home/kevin/Desktop/crystal-1.0.5/client'
    Making all in config
    make[3]: Entering directory `/home/kevin/Desktop/crystal-1.0.5/client/config'
    make[3]: Nothing to be done for `all'.
    make[3]: Leaving directory `/home/kevin/Desktop/crystal-1.0.5/client/config'
    make[3]: Entering directory `/home/kevin/Desktop/crystal-1.0.5/client'
    make[3]: Nothing to be done for `all-am'.
    make[3]: Leaving directory `/home/kevin/Desktop/crystal-1.0.5/client'
    make[2]: Leaving directory `/home/kevin/Desktop/crystal-1.0.5/client'
    make[2]: Entering directory `/home/kevin/Desktop/crystal-1.0.5'
    make[2]: Nothing to be done for `all-am'.
    make[2]: Leaving directory `/home/kevin/Desktop/crystal-1.0.5'
    make[1]: Leaving directory `/home/kevin/Desktop/crystal-1.0.5'
    Make install gives this:

    root@brian-laptop:/home/kevin/Desktop/crystal-1.0.5# make install
    Making install in pics
    make[1]: Entering directory `/home/kevin/Desktop/crystal-1.0.5/pics'
    make[2]: Entering directory `/home/kevin/Desktop/crystal-1.0.5/pics'
    make[2]: Nothing to be done for `install-exec-am'.
    make[2]: Nothing to be done for `install-data-am'.
    make[2]: Leaving directory `/home/kevin/Desktop/crystal-1.0.5/pics'
    make[1]: Leaving directory `/home/kevin/Desktop/crystal-1.0.5/pics'
    Making install in client
    make[1]: Entering directory `/home/kevin/Desktop/crystal-1.0.5/client'
    Making install in config
    make[2]: Entering directory `/home/kevin/Desktop/crystal-1.0.5/client/config'
    make[3]: Entering directory `/home/kevin/Desktop/crystal-1.0.5/client/config'
    /bin/bash ../../admin/mkinstalldirs /usr/lib/kde3
    /bin/bash ../../libtool --silent --mode=install /usr/bin/install -c -p kwin_crystal_config.la /usr/lib/kde3/kwin_crystal_config.la
    PATH="$PATH:/sbin" ldconfig -n /usr/lib/kde3
    make[3]: Nothing to be done for `install-data-am'.
    make[3]: Leaving directory `/home/kevin/Desktop/crystal-1.0.5/client/config'
    make[2]: Leaving directory `/home/kevin/Desktop/crystal-1.0.5/client/config'
    make[2]: Entering directory `/home/kevin/Desktop/crystal-1.0.5/client'
    make[3]: Entering directory `/home/kevin/Desktop/crystal-1.0.5/client'
    /bin/bash ../admin/mkinstalldirs /usr/lib/kde3
    /bin/bash ../libtool --silent --mode=install /usr/bin/install -c -p kwin3_crystal.la /usr/lib/kde3/kwin3_crystal.la
    PATH="$PATH:/sbin" ldconfig -n /usr/lib/kde3
    /bin/bash ../admin/mkinstalldirs /usr/share/apps/kwin/
    /usr/bin/install -c -p -m 644 crystal.desktop /usr/share/apps/kwin//crystal.desktop
    make[3]: Leaving directory `/home/kevin/Desktop/crystal-1.0.5/client'
    make[2]: Leaving directory `/home/kevin/Desktop/crystal-1.0.5/client'
    make[1]: Leaving directory `/home/kevin/Desktop/crystal-1.0.5/client'
    make[1]: Entering directory `/home/kevin/Desktop/crystal-1.0.5'
    make[2]: Entering directory `/home/kevin/Desktop/crystal-1.0.5'
    make[2]: Nothing to be done for `install-exec-am'.
    make[2]: Nothing to be done for `install-data-am'.
    make[2]: Leaving directory `/home/kevin/Desktop/crystal-1.0.5'
    make[1]: Leaving directory `/home/kevin/Desktop/crystal-1.0.5'
    I have never been very good at this whole console configure-make-make install thing. Help me here, what am I missing?
    Using Linux since June 2007
    Distros: Mint 16 KDE
    SPECS: AMD Atholon 64 X2 3.2 Ghz, 4GB RAM, GeForce GTS 250 1GB VRAM
    When your whole life is on one computer, servers and all, choose stability over anything else.

  6. #6
    Trusted Penguin Dapper Dan's Avatar
    Join Date
    Oct 2004
    Location
    The Sovereign State of South Carolina
    Posts
    4,630
    I don't see any errors. It looks like you are good to go.
    Linux Mint + IceWM Registered: #371367 New Members: click here

  7. #7
    Linux User SkittleLinux18's Avatar
    Join Date
    Dec 2007
    Location
    Mesa, AZ
    Posts
    310
    Yeah, you're right, Dan. I just had to alter the configure command a little. This is what I had to type:

    ./configure --prefix=/usr
    Have no idea why if someone would love to explain it to me? Teach me a little more, maybe?
    Using Linux since June 2007
    Distros: Mint 16 KDE
    SPECS: AMD Atholon 64 X2 3.2 Ghz, 4GB RAM, GeForce GTS 250 1GB VRAM
    When your whole life is on one computer, servers and all, choose stability over anything else.

  8. #8
    Linux User
    Join Date
    Jan 2006
    Posts
    414
    Most distributions used to install KDE and it's libraries in /opt (I think it was/is the KDE default too), now that things are being put in /usr (like they should be IMO) you need to tell applications where to be installed to, hence --prefix=/usr, in some cases even when installing to /opt you still need to supply a --prefix=/opt.

    Have a bit of a play with it if you want, make a new directory in your home directory and point the prefix to it, then have a look in there after make install. Setting a non-standard prefix is how alot of packages are made, as you can then just tarball the directory you used as a prefix and you have a package (not a deb package though).

  9. #9
    Linux User SkittleLinux18's Avatar
    Join Date
    Dec 2007
    Location
    Mesa, AZ
    Posts
    310
    Quote Originally Posted by darkrose0510 View Post
    Most distributions used to install KDE and it's libraries in /opt (I think it was/is the KDE default too), now that things are being put in /usr (like they should be IMO) you need to tell applications where to be installed to, hence --prefix=/usr, in some cases even when installing to /opt you still need to supply a --prefix=/opt.

    Have a bit of a play with it if you want, make a new directory in your home directory and point the prefix to it, then have a look in there after make install. Setting a non-standard prefix is how alot of packages are made, as you can then just tarball the directory you used as a prefix and you have a package (not a deb package though).
    That makes sense. Thank you.
    Using Linux since June 2007
    Distros: Mint 16 KDE
    SPECS: AMD Atholon 64 X2 3.2 Ghz, 4GB RAM, GeForce GTS 250 1GB VRAM
    When your whole life is on one computer, servers and all, choose stability over anything else.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •