Find the answer to your Linux question:
Results 1 to 6 of 6
I have installed ubuntu 8.04 beta, but grub is failing, so I tried lilo which seems to work but it is veeeeery slow to boot. Hence I want to replace ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Apr 2008
    Posts
    3

    The file /boot/grub/stage1 not read correctly.


    I have installed ubuntu 8.04 beta, but grub is failing, so I tried lilo which seems to work but it is veeeeery slow to boot.
    Hence I want to replace it with grub, but I cannot manage to get it to work.
    My setup is one single partition for / that is located on /dev/sda1.

    When I run grub-install I get this:
    root@lap:~# grub-install /dev/sda
    Searching for GRUB installation directory ... found: /boot/grub
    The file /boot/grub/stage1 not read correctly.

    I have of course googled for that, but haven't found a solution that works for me. One proposed solution was this:
    grub> rootnoverify (hd0,0)
    grub> setup (hd0)
    Error 17: Cannot mount selected partition

    ..well duh, its already mounted..

    grub> find /boot/grub/stage1
    Error 15: File not found

    .. but it is there:
    root@lap:~$ file /boot/grub/stage1
    /boot/grub/stage1: x86 boot sector; GRand Unified Bootloader, stage1 version 0x3, code offset 0x48

    Another suggestion was that the Inode size was something other than 128, but it isn't:
    root@lap:~# tune2fs -l /dev/sda1 |grep "Inode size"
    Inode size: 128

    I don't know what else could be wrong.

    Other info that might be of interest:
    root@lap:~# cat /boot/grub/device.map
    (hd0) /dev/sda

    root@lap:~# cat /etc/mtab
    /dev/sda1 / ext3 rw,relatime,errors=remount-ro 0 0
    proc /proc proc rw,noexec,nosuid,nodev 0 0
    /sys /sys sysfs rw,noexec,nosuid,nodev 0 0
    varrun /var/run tmpfs rw,noexec,nosuid,nodev,mode=0755 0 0
    varlock /var/lock tmpfs rw,noexec,nosuid,nodev,mode=1777 0 0
    udev /dev tmpfs rw,mode=0755 0 0
    devshm /dev/shm tmpfs rw 0 0
    devpts /dev/pts devpts rw,gid=5,mode=620 0 0
    lrm /lib/modules/2.6.24-16-generic/volatile tmpfs rw 0 0
    securityfs /sys/kernel/security securityfs rw 0 0
    gvfs-fuse-daemon /home/mw/.gvfs fuse.gvfs-fuse-daemon rw,nosuid,nodev,user=mw 0 0
    /dev/scd0 /media/cdrom0 iso9660 rw,nosuid,nodev,utf8,user=mw 0 0

    root@lap:~# cat /etc/fstab
    # /etc/fstab: static file system information.
    #
    # <file system> <mount point> <type> <options> <dump> <pass>
    proc /proc proc defaults 0 0
    /dev/sda1 / ext3 relatime,errors=remount-ro 0 1
    /dev/sda5 none swap sw 0 0
    /dev/scd0 /media/cdrom0 udf,iso9660 user,noauto,exec,utf8 0 0

  2. #2
    Linux Guru Jonathan183's Avatar
    Join Date
    Oct 2007
    Posts
    3,045
    From your description you should find to setup grub
    Code:
    sudo grub
    root (hd0,0)
    setup (hd0)
    quit
    works ... what does
    Code:
    dmesg | grep mount
    dmesg | error
    report?

  3. #3
    Just Joined!
    Join Date
    Apr 2008
    Posts
    3
    Quote Originally Posted by Jonathan183 View Post
    From your description you should find to setup grub
    Code:
    sudo grub
    root (hd0,0)
    setup (hd0)
    quit
    works ... what does
    Code:
    dmesg | grep mount
    dmesg | error
    report?
    As I wrote I have tried rootnoverify (hd0,0) in the grub console, only root (hd0,0) gives the same error..

    root@lap:~# dmesg |grep mount
    [ 125.658759] EXT3-fs: mounted filesystem with ordered data mode.

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Apr 2008
    Posts
    3
    I managed to solve it by using the GParted Live CD to make myself a /boot partition, then using the Ubuntu Live CD to mount, chroot, copy etc as per How to install Grub from a live Ubuntu cd. - Ubuntu Forums

  6. #5
    Linux Guru Jonathan183's Avatar
    Join Date
    Oct 2007
    Posts
    3,045
    Glad you are sorted and thanks for sharing the solution ... it may help others in future.

  7. #6
    Just Joined!
    Join Date
    Aug 2008
    Posts
    1
    I just encountered this problem on debian while upgrading grub and a new kernel at the same time. The updating procedure missed a step:

    Code:
    grub-install /dev/sda
    Searching for GRUB installation directory ... found: /boot/grub
    The file /boot/grub/stage1 not read correctly.
    
    depmod
    update-grub
    Searching for GRUB installation directory ... found: /boot/grub
    Searching for default file ... found: /boot/grub/default
    Testing for an existing GRUB menu.lst file ... 
    
    
    Generating /boot/grub/menu.lst
    Searching for splash image ... none found, skipping ...
    Found kernel: /boot/vmlinuz-2.6.25-2-686
    Found kernel: /boot/vmlinuz-2.6.24-1-686
    Found kernel: /boot/vmlinuz-2.6.22-3-686
    Updating /boot/grub/menu.lst ... done

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •