Find the answer to your Linux question:
Results 1 to 6 of 6
hello! yesterday I reinstalled my kubuntu 7.10, and then I wanted to install drivers for the graphic card (I am using an asus notebook with graphic card nVidia GeForce 8400M ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Nov 2007
    Location
    prague, czech republic
    Posts
    20

    Unhappy wrong nVidia drivers


    hello!

    yesterday I reinstalled my kubuntu 7.10, and then I wanted to install drivers for the graphic card (I am using an asus notebook with graphic card nVidia GeForce 8400M G). I thought I could use the same drivers that worked well while I was installing kubuntu last time, so I copied them from my backup cd and tried to install them: it is "NVIDIA-Linux-x86-100.14.19-pkg1.run". the installer wanted me to download "libc development package", as it needed "libc header files". so I typed "sudo apt-get install build-essential", no problems appeared. so I started kubuntu in recovery mode and tried to install the drivers once more, this time the installer told me there were no problems and the installation was succesfull.

    unfortunately, after rebooting, the xserver did not start. I had to log on without the gui, then I tried "startx" command. it ended with the following:

    error: API mismatch: this NVIDIA driver component has version 100.14.19, but the NVIDIA kernel module´s version does not match.
    NVIDIA: failer to initialize the NVIDIA kernel module
    aborting
    (EE) screen(s) found, but none have usable configuration
    fatal server error: no screens found
    XIO: fatal IO error 104 (connection reset by peer) on X server ":0.0" after 0 requests (0 known processed) with 0 events remaining.
    Xauth: error in locking authority file /home/lambdda/.Xauthority

    please, can you advise me how to tell kubuntu not to use this drivers any more, so that I can log in normally, start web browser and dowload another drivers? I am confused :'(, as I proceed the same way last time when installing these drivers and there were no problems with them. or do you know about newer drivers that would work better? I remember it was hard to find any drivers for this card at all, so I was happy they worked ... and now they work no more

    thank you for any advice!

  2. #2
    Linux User
    Join Date
    Jan 2006
    Posts
    414
    try it the easy way:
    Ensure you have the 'restricted' repository enabled (should be able to enable it in adept if it isn't already enabled).
    Then just install 'nvidia-glx-new' from adept or the command line.

    To get the driver work you can then either reboot, or load the module manually:
    Code:
    sudo modprobe nvidia
    and restart X
    Code:
    sudo /etc/init.d/kdm restart

  3. #3
    Just Joined!
    Join Date
    Nov 2007
    Location
    prague, czech republic
    Posts
    20
    thank you.
    I tried. however, after installing "nvidia-glx-new", I was told that I have already the newest version. then I typed "sudo modprobe nvidia", nothing happened, and after "sudo /etc/init.d/kdm restart", all I got was nothing but a black display. so I turned the computer off, turned it on and wanted to boot kubuntu, but x server still do not want to start, it always ends with the
    report I posted...
    please, is there a possibility how to discard changes made with graphic drivers? how to "uninstall" them? because, as far as I comprehend, they are not the proper ones ... (

  4. #4
    Just Joined!
    Join Date
    Nov 2007
    Location
    prague, czech republic
    Posts
    20
    I forgot to say that I am using dual boot: kubuntu and windows. I experienced problems starting windows after trying to install graphic drivers for kubuntu. is there any possible relation between it? before trying to install the drivers, windows booted well ... so now, I have two operating systems and none of them works properly ...
    thanks for any ideas!

  5. #5
    Linux User
    Join Date
    Jan 2006
    Posts
    414
    Well that is the correct drivers for your card, so try uninstalling them then reinstalling them.
    Code:
    sudo apt-get remove --purge nvidia-glx-new
    sudo apt-get install nvidia-glx-new
    Remove the old module and insert the new module and restart kdm.
    Code:
    sudo modprobe -r nvidia
    sudo modprobe nvidia
    sudo /etc/init.d/kdm restart
    Note that modprobe won't return anything unless there's an error, you'll just get the prompt back and that's it.

    If it's not working then reconfigure the xserver.
    Code:
    sudo dpkg-reconfigure xserver-xorg
    there's a nice little video walkthrough on youtube for this:
    YouTube - Dpkg Reconfigure Xserver Xorg : Nvidia
    The main thing is ensuring you choose 'nvidia' for your driver.
    And restart kdm again.
    Code:
    sudo /etc/init.d/kdm restart
    It should now be working.
    If not, try dpkg-reconfigure xserver-xorg again and use the 'nv' open source driver, restart kdm and see if that works, you can also try the 'vesa' driver, we just wanna see if you can get a working Xserver at all.
    If the nv or vesa drivers work, go here and get the latest stable nvidia drivers and try a manual install of them.

    No idea what is wrong with windows as I haven't used it for years. Probably just eating itself as usual.

  6. #6
    Just Joined!
    Join Date
    Nov 2007
    Location
    prague, czech republic
    Posts
    20
    this time x server started after restarting kdm.
    thank you! without your advice, I would never be able to fix it. thanks a lot!

    ps: well, windows aren't wonderful operating system, I know. many times kubuntu helped me to save files while windows collapsed. but I still need them, as I am using 3ds max, photoshop and other graphic software for my work .

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •