Find the answer to your Linux question:
Results 1 to 6 of 6
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1

    ALSA lib pcm_dmix.c:862:(snd_pcm_dmix_open) unable to open slave


    After a recent reboot I am unable to play any sounds. For example

    prompt> aplay somefile.wav
    ALSA lib pcm_dmix.c:862snd_pcm_dmix_open) unable to open slave
    aplay: main:547: audio open error: Device or resource busy

    prompt> usr/bin/speaker-test -t pink -p 2000000000 -r 100

    speaker-test 1.0.11

    Playback device is default
    Stream parameters are 4000Hz, S16_LE, 1 channels
    Using 16 octaves of pink noise
    ALSA lib pcm_dmix.c:862snd_pcm_dmix_open) unable to open slave
    Playback open error: -16,Device or resource busy


    prompt> mpg321 somefile.mp3
    < SNIP generic messages >
    ALSA lib pcm_dmix.c:862snd_pcm_dmix_open) unable to open slave
    ALSA snd_pcm_open error: Device or resource busy
    ALSA lib pcm_dmix.c:862snd_pcm_dmix_open) unable to open slave
    Can't find a suitable libao driver. (Is device in use?)

    I have checked all the Google matches for my error message. The only one which looks somewhat promising is this but I
    I haven't tried the solution mentioned (remove the file /var/lib/alsa/asound.state and reboot) because I'd rather avoid rebooting if at all possible. I'm hoping that someone will have some suggestion which doesn't involve rebooting. I'm also hoping for some insight as to why the problem appeared after a reboot. Before, I've never had problems with sound and apart from the programmes I mention above I've watched DVDs with ogle with no sound issues whatsoever.

    lsof | grep snd
    produces no output. I'm running edgy.

  2. #2
    If an ALSA start-up script generated an error would the error appear in some log file ?

  3. #3
    It turns out that it was Firefox which was occupying the sound device ! If I kill firefox then I can play sounds. If I restart it with no other application playing sounds then once again I can't play any sounds although I'm not using Firefox to access any page with sounds. On the other hand if I start Firefox when some other application is playing sounds then Firefox produces the message
    open dsp: Device or resource busy
    but other applications can play sounds.

    This leads to 2 questions:

    1) Is there any way to make Firefox not selfish with regards to sounds meaning it can share the sound device with other applications ?
    2) If not, is there a way to make sure that it doesn't try to use the sound device at all ? I haven't seen any settings which mention sound.

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined! kozaki's Avatar
    Join Date
    Apr 2005
    Location
    UE
    Posts
    2

    Arrow

    Had precisely the same issue than Santa, with Firefox only (Opera 10 or Konqueror did not show the issue) :
    Code:
    ALSA lib pcm_dmix.c:1008:(snd_pcm_dmix_open) unable to open slave
    Tried every single config change (from safe mode to hacking ~/.asoundrc, etc etc) without any luck.
    Then moved flash plugin (libflashplayer.so i.e. Flash 10 64-bit) to another place and restarted FF : had sound.
    Closed FF and put flash plugin back where it was, then restarted FF : have sound... for a minute, then back to the very same issue !?!

  6. #5
    Just Joined! kozaki's Avatar
    Join Date
    Apr 2005
    Location
    UE
    Posts
    2

    Smile

    BTW, "Tried every single config change (from safe mode to hacking ~/.asoundrc, etc etc) without any luck." included installing FlashBlock, which didn't change the issue, and let me think the issue was not Flash related. This was wrong.

    Have deactivated both 2 FF Flash-related extensions: Flash Video Ressources Downloader and NetVideoHunter, and now the sound is crystal clear, and other audio apps can play at the same time FF is open as well

  7. #6
    -->
    I'm having this problem on my HP Pavilion dv6000 running Ubuntu 8.10. Sounds seems to die after about 8 hours. My temporary fix, without rebooting, is to run
    Code:
      sudo /sbin/alsa force-reload
    .

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •