Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 16
Hello, My Hard Drive is as follow C:XP, D: DATA and E: UBUNTU I save my files to DATA from XP. I just installed Ubuntu some weeks ago and now ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Apr 2008
    Location
    Angers, France
    Posts
    91

    [SOLVED] Saving from Ubuntu to DATA (NTFS)


    Hello,
    My Hard Drive is as follow C:XP, D: DATA and E: UBUNTU
    I save my files to DATA from XP. I just installed Ubuntu some weeks ago and now I have creating files... I want to save them to DATA which is NTFS. When I go to SAVING my file under Ubuntu, I cannot find DATA. So I don't know if this has to do with the formating or something else. Someone told me that I could save my files into DATA easily. Do I need a software to recognize DATA From Ubuntu or something else is wrong.
    Thank you.

    Emmanuel

  2. #2
    Linux Guru Jonathan183's Avatar
    Join Date
    Oct 2007
    Posts
    3,043
    Can you post the output of
    Code:
    sudo fdisk -l
    mount
    ntfs-3g

  3. #3
    Just Joined!
    Join Date
    Apr 2008
    Location
    Angers, France
    Posts
    91
    ok this is what I have. I do not know at all what this means:

    manu@manu-laptop:~$ sudo fdisk -1
    [sudo] password for manu:
    fdisk: invalid option -- 1

    Usage: fdisk [-b SSZ] [-u] DISK Change partition table
    fdisk -l [-b SSZ] [-u] DISK List partition table(s)
    fdisk -s PARTITION Give partition size(s) in blocks
    fdisk -v Give fdisk version
    Here DISK is something like /dev/hdb or /dev/sda
    and PARTITION is something like /dev/hda7
    -u: give Start and End in sector (instead of cylinder) units
    -b 2048: (for certain MO disks) use 2048-byte sectors
    manu@manu-laptop:~$ mount
    /dev/sda3 on / type ext3 (rw,relatime,errors=remount-ro)
    proc on /proc type proc (rw,noexec,nosuid,nodev)
    /sys on /sys type sysfs (rw,noexec,nosuid,nodev)
    varrun on /var/run type tmpfs (rw,noexec,nosuid,nodev,mode=0755)
    varlock on /var/lock type tmpfs (rw,noexec,nosuid,nodev,mode=1777)
    udev on /dev type tmpfs (rw,mode=0755)
    devshm on /dev/shm type tmpfs (rw)
    devpts on /dev/pts type devpts (rw,gid=5,mode=620)
    lrm on /lib/modules/2.6.24-19-generic/volatile type tmpfs (rw)
    securityfs on /sys/kernel/security type securityfs (rw)
    binfmt_misc on /proc/sys/fs/binfmt_misc type binfmt_misc (rw,noexec,nosuid,nodev)
    gvfs-fuse-daemon on /home/manu/.gvfs type fuse.gvfs-fuse-daemon (rw,nosuid,nodev,user=manu)
    manu@manu-laptop:~$ ntfs-3g
    ntfs-3g: No device is specified.
    Please type 'ntfs-3g --help' for more information.
    manu@manu-laptop:~$

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Apr 2008
    Location
    Angers, France
    Posts
    91
    Sorry I made a typo

    manu@manu-laptop:~$ sudo fdisk -l

    Disk /dev/sda: 40.0 GB, 40007761920 bytes
    255 heads, 63 sectors/track, 4864 cylinders
    Units = cylinders of 16065 * 512 = 8225280 bytes
    Disk identifier: 0xf2cff2cf

    Device Boot Start End Blocks Id System
    /dev/sda1 * 1 1188 9542578+ 7 HPFS/NTFS
    /dev/sda2 1189 3426 17976735 f W95 Ext'd (LBA)
    /dev/sda3 3427 4763 10739452+ 83 Linux
    /dev/sda4 4764 4864 811282+ 82 Linux swap / Solaris
    /dev/sda5 1189 3426 17976703+ 7 HPFS/NTFS
    manu@manu-laptop:~$

  6. #5
    Just Joined!
    Join Date
    Dec 2006
    Location
    Leeds UK
    Posts
    5
    you have mistyped "sudo fdisk -l"
    after the "-" is "lower-case-L", not "1"

    also try :- sudo df -l
    again lower-case-L

    another useful one is :- cat /etc/mstab

    these 3 all tell you about what disks/partitions the operating system can detect

    I personally use a FAT16 partition rather than NTFS for saving data from linux and windows
    Last edited by UpsideDownFace; 06-28-2008 at 01:39 PM. Reason: more information after a little thought!

  7. #6
    Just Joined!
    Join Date
    Apr 2008
    Location
    Angers, France
    Posts
    91
    yes I saw that and posted it. I am putting it again.

    manu@manu-laptop:~$ sudo fdisk -l

    Disk /dev/sda: 40.0 GB, 40007761920 bytes
    255 heads, 63 sectors/track, 4864 cylinders
    Units = cylinders of 16065 * 512 = 8225280 bytes
    Disk identifier: 0xf2cff2cf

    Device Boot Start End Blocks Id System
    /dev/sda1 * 1 1188 9542578+ 7 HPFS/NTFS
    /dev/sda2 1189 3426 17976735 f W95 Ext'd (LBA)
    /dev/sda3 3427 4763 10739452+ 83 Linux
    /dev/sda4 4764 4864 811282+ 82 Linux swap / Solaris
    /dev/sda5 1189 3426 17976703+ 7 HPFS/NTFS
    manu@manu-laptop:~$

  8. #7
    Just Joined!
    Join Date
    Apr 2008
    Location
    Angers, France
    Posts
    91
    I tried again to save to DATA. Then it says the following in a window

    "COULD NOT MOUNT DATA
    You are not supposed to show
    G_IO_ERROR_FAILED_HANDLED in the UI"

    I don't know if this helps

    Emmanuel

  9. #8
    Linux Guru Jonathan183's Avatar
    Join Date
    Oct 2007
    Posts
    3,043
    I am assuming the D: data you referred to is sda5. You need to create a folder to mount it too. Lets say you make this /windows/d then use
    Code:
    sudo mkdir /windows /windows/d
    Next mount the partition
    Code:
    sudo ntfs-3g /dev/sda5 /windows/d
    You should now be able to read & write data to the partition. You should be able to use a GUI file manager to explore the partition information (go to /windows/d) or you can list the contents using
    Code:
    ls /windows/d
    etc.

    Once you have the partition mounted the way you want and are happy you can read/write as required, you can add mounting the partition automatically ... type
    Code:
    cat /etc/mtab
    and note the contents of the line refering to /dev/sda5 you need to add this line to /etc/fstab which you can do typing
    Code:
    sudo nano /etc/fstab
    Last edited by Jonathan183; 06-28-2008 at 01:48 PM. Reason: add sudo to ntfs-3g command line ;)

  10. #9
    Just Joined!
    Join Date
    Apr 2008
    Location
    Angers, France
    Posts
    91
    OK I did the first command and it is fine.
    Then for the second one, this came up

    manu@manu-laptop:~$ sudo ntfs-3g /dev/sda5 /windows/d
    $LogFile indicates unclean shutdown (0, 0)
    Failed to mount '/dev/sda5': Operation not supported
    Mount is denied because NTFS is marked to be in use. Choose one action:

    Choice 1: If you have Windows then disconnect the external devices by
    clicking on the 'Safely Remove Hardware' icon in the Windows
    taskbar then shutdown Windows cleanly.

    Choice 2: If you don't have Windows then you can use the 'force' option for
    your own responsibility. For example type on the command line:

    mount -t ntfs-3g /dev/sda5 /windows/d -o force

    Or add the option to the relevant row in the /etc/fstab file:

    /dev/sda5 /windows/d ntfs-3g force 0 0
    manu@manu-laptop:~$

    So what shall I do?

    emmanuel

  11. #10
    Linux Guru Jonathan183's Avatar
    Join Date
    Oct 2007
    Posts
    3,043
    Go back into windows and run a filesystem check, make sure you shutdown windows correctly and try again.
    Ed: eg don't use suspend or other feature but select shutdown option for windows.

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •