Hi.

I'm running postfix 2.5.1-2 and procmail 3.22 under ubuntu 8.04, and found out that my machine (kcrimson) tried to send mail last night to root@kcrimson.sdsu.edu but left off the hostname. So the mail went instead to root@sdsu.edu, and a sysadmin who (understandably) would prefer not to get any more of these. Looking through mail.log, this is the first mail the system has tried to send to root in two weeks, and since then I changed /etc/postfix/main.cf to add a relayhost (sciences.sdsu.edu). I think that's the only change I've made since this broke, but don't understand why that would mess up the root mail. Other incoming mail seems to be okay. I'll attach main.cf and master.cf below. If anyone's got an idea what the problem is, I'd sure appreciate it.

Thanks.
Andy

---------------------main.cf------------------
# See /usr/share/postfix/main.cf.dist for a commented, more complete version


# Debian specific: Specifying a file name will cause the first
# line of that file to be used as the name. The Debian default
# is /etc/mailname.
#myorigin = /etc/mailname

smtpd_banner = $myhostname ESMTP $mail_name (Ubuntu)
biff = no

# appending .domain is the MUA's job.
append_dot_mydomain = no

# Uncomment the next line to generate "delayed mail" warnings
#delay_warning_time = 4h

readme_directory = no

# TLS parameters
smtpd_tls_cert_file=/etc/ssl/certs/ssl-cert-snakeoil.pem
smtpd_tls_key_file=/etc/ssl/private/ssl-cert-snakeoil.key
smtpd_use_tls=yes
smtpd_tls_session_cache_database = btree:${data_directory}/smtpd_scache
smtp_tls_session_cache_database = btree:${data_directory}/smtp_scache

# See /usr/share/doc/postfix/TLS_README.gz in the postfix-doc package for
# information on enabling SSL in the smtp client.

myhostname = kcrimson.sdsu.edu
notify_classes = resource, software, bounce, delay
alias_maps = hash:/etc/aliases
alias_database = hash:/etc/aliases
# myorigin = /etc/mailname
myorigin = $mydomain
mydestination = kcrimson.sdsu.edu, localhost.sdsu.edu, , localhost
relayhost = sciences.sdsu.edu
mynetworks = 127.0.0.0/8 [::ffff:127.0.0.0]/104 [::1]/128
mailbox_size_limit = 0
recipient_delimiter = +
inet_interfaces = all
maximal_queue_lifetime = 2h

mailbox_command = /usr/X11R6/bin/procmail -f- -a "$USER"