Find the answer to your Linux question:
Results 1 to 3 of 3
I have googled for hours trying to figure what Ubuntu/Linux drivers would make this D-link Pcmcia wna-1330 card with Atheros AR2413 chipset work . Every tutorial and driver I could ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Guru
    Join Date
    Jul 2008
    Posts
    4,204

    Arrow PCMCIA Dlink WNA-1330 wireless woes


    I have googled for hours trying to figure what Ubuntu/Linux drivers would make this D-link Pcmcia wna-1330 card with Atheros AR2413 chipset work . Every tutorial and driver I could find was for PCl cards and not PCMCIA. In the compatibility section it shows wna-1330 is compatible but with a different chipset. I have tried madwifi and a 5007 targz that in one site showed compatability with linux and awn-1330 but it also was for PCl type card. I am now posting this to see if anyone knows how to set this up because the card works,(the LED is flashing like a train crossing signal) worked on the ol'ladys ibm laptop with windows with our wireless Belkin N router and Ubuntu sees the router and in Device drivers in admin I have the proprietary drivers Atheros Hal and Atheros Support for 802,11 wirelees LAN both enabled so I am in gridlock as to how to get this working. Laptop is a Panasonic Toughbook CF-48 running Ubuntu 8.04 Hardy Heron early edition,(been using it for a while using land line).By the way I figure the only way Ubuntu recognizes the wireless router right now is because of land line hookup.

  2. #2
    Just Joined!
    Join Date
    Jul 2008
    Posts
    1

    re: dlink wna-1330 pcmcia under linux

    Look into trying this, might work under Ubuntu also:

    1.Activate*PCMCIA: Open /etc/sysconfig/pcmcia in a text editor (kwrite is fine), and make it look exactly as follows:
    PCMCIA=yes
    PCIC=yenta_socket
    PCIC_OPTS=do_scan=0
    CORE_OPTS=
    CARDMGR_OPTS=-f

    Then save the changed file.

    2.Make sure that it's set to load the PCMCIA service at boot:

    1.Go into the PCLinuxOS control Center.
    2.Select "System" on the left then*"Configure the system services".*
    3.Scroll down*to the line that begins with pcmcia and make sure "On boot" is selected. Press "OK" on that page and restart the laptop.
    3.After restarting go back int the PCLinuxOS Control Center and select "Networking" on the left then "Create a new network interface".
    4.Select "Wireless connection" and press the "Next" button.
    5.It should already show the "Net device" as being "ath0: Atheros Communications Inc. | 802.11b/g Wireless PCI Adapter". *Press the "Next" button.
    6.Wireless parameters: Set *the fields on this page (picture is missing when pasted)

    1."Operating Mode" = Managed
    2."Network name (ESSID)" = Here enter the "Wireless Network Name" you had used in step 4 above.
    3."Encryption Mode" = Open WEP
    4."Encryption key: Here enter the 26 character*network key you wrote down.
    5.Press "Next".
    7.Select "Automatic IP" (BOOTP/DHCP) and press "Next" again.
    8.Click "Next" on the next 3 screens until you get to "Do you want to allow users to start the connection?" Normally you would select "yes" here then press "Next" again.
    9.Congratulations. Click "Finish".
    10. Linux OS used was PclinuxOS

  3. #3
    Linux Guru
    Join Date
    Jul 2008
    Posts
    4,204
    Thank you so much for replying to my thread. I haven;t been able to try your suggestion yet because I'm in a wheelchair and it takes awhile to set everything up. I'll try this out tommorrow and give an update on results. I posted this problem in Ubuntu Forums a few days before I posted here in LinuxForums.org and didn't even receive 1 reply. So you can see why I appreciate your suggestion. I have googled my brains out trying to resolve this problem.Thank you again.

  4. $spacer_open
    $spacer_close

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •