Find the answer to your Linux question:
Results 1 to 9 of 9
When I installed Compiz, I set it up so that moving my mouse to a corner of the screen would shrink all the open windows and arrange them so I ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jul 2008
    Posts
    14

    Compiz in 8.04


    When I installed Compiz, I set it up so that moving my mouse to a corner of the screen would shrink all the open windows and arrange them so I could see them all and select one. Since I upgraded to Ubuntu 8.04, this hasn't worked, and when I try to fix it through System --> Preferences --> GL Desktop, I get the error message "Type mismatch: Expected list, got string". Does anyone know a solution to this problem? (By googling I found that other people had the same problem, but I haven't seen a solution.)

    Thanks!

  2. #2
    Linux Guru bigtomrodney's Avatar
    Join Date
    Nov 2004
    Location
    Ireland
    Posts
    6,133
    Try installing ccsm , the advanced configuration tool It enables all of the additional plugins and gives you a better interface to work with. It is available in the repositories, you can search for it in System > Administration > Synaptic Package Manager.

  3. #3
    Just Joined!
    Join Date
    Jul 2008
    Posts
    14
    I tried, and it didn't seem to make any difference (even after restarting).

  4. #4
    Linux Guru jmadero's Avatar
    Join Date
    Jul 2007
    Location
    California
    Posts
    1,998
    do you have compizconfig-settings-manager installed? (I think this was what was earlier called ccsm). If you do go to system, preferences, advanced desktop effects settings. You should be able to get it working that way. Do other compiz settings work for you?

  5. #5
    Linux Guru bigtomrodney's Avatar
    Join Date
    Nov 2004
    Location
    Ireland
    Posts
    6,133
    Quote Originally Posted by AdinaG View Post
    I tried, and it didn't seem to make any difference (even after restarting).
    Did you go into the settings for the plugins you require? Once installed you can find it as System > Preferences > Advanced Desktop Effects Settings. I think you're looking for the scale plugin and you can enable hot corners on the bindings tab.

  6. #6
    Linux Guru jmadero's Avatar
    Join Date
    Jul 2007
    Location
    California
    Posts
    1,998
    with Hardy don't you have to make the hot keys with a mouse click? For mine I can't just go up to the right corner any more I need to go up to the right corner and click the left mouse button for it to get the same effect. I used to just have it to where if my mouse went to the corner it did the action but can't seem to get that any more

  7. #7
    Linux Engineer scrarfussi's Avatar
    Join Date
    Aug 2006
    Posts
    1,029
    I think its the expo plugin you just go to compiz manager select expo and under bindings you can choose which button to use

  8. #8
    Linux Guru bigtomrodney's Avatar
    Join Date
    Nov 2004
    Location
    Ireland
    Posts
    6,133
    Quote Originally Posted by jmadero View Post
    with Hardy don't you have to make the hot keys with a mouse click?
    I believe that's an option, but as far as I'm aware you can still enable hot corners using the method I've suggested.

  9. #9
    Just Joined!
    Join Date
    Jul 2008
    Posts
    14
    Ok, so it was the Scale plugin I was looking for. I still can't get it to enable hot corners -- it says they're enabled but moving my mouse to the corner has no effect -- but I at least managed to enable the keyboard shortcut.

    When it says "button 1", is it referring to a mouse button? If so what are buttons 2 through 9?

    Also, it used to be that when I hit "show desktop", the windows would move to the corners until I hit "show desktop" again, and then they would return, but now they get stuck in the corners and I don't know how to bring them back.

    And sometimes when I try to switch windows using Alt-Tab, a white box comes to the middle of the screen which I can't get rid of, and my mouse disappears, and the only way I've found of getting back to work is to use Ctrl-Alt-F2, sudo halt, and start again.

    Has anyone else had these issues?

    My other compiz settings (eg cube) all seem to be working fine...

    Thanks everyone for your replies!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •