Find the answer to your Linux question:
Results 1 to 9 of 9
I have install ntfs-3g for mount my ntfs drive.but it didn't work.Any my fstab configuration is like this # /etc/fstab: static file system information. # # <file system> <mount point> ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    May 2006
    Location
    London ,UK
    Posts
    74

    [SOLVED] ntfs mount help


    I have install ntfs-3g for mount my ntfs drive.but it didn't work.Any my fstab configuration is like this
    # /etc/fstab: static file system information.
    #
    # <file system> <mount point> <type> <options> <dump> <pass>
    proc /proc proc defaults 0 0
    # /dev/sdb1
    UUID=bdc562e4-eb0f-486c-a036-4cf43d7943d2 / ext3 relatime,errors=remount-ro 0 1
    /dev/scd0 /media/cdrom0 udf,iso9660 user,noauto,exec,utf8 0 0
    /dev/fd0 /media/floppy0 auto rw,user,noauto,exec,utf8 0 0
    /dev/sda1 /media/sda1 ntfs-3g defaults,umask=0 0 0
    /dev/sda5 /media/sda5 ntfs-3g defaults,umask=0 0 0
    /dev/sda6 /media/sda6 ntfs-3g defaults,umask=0 0 0
    /dev/sda7 /media/sda7 ntfs-3g defaults,umask=0 0 0
    /dev/sdb5 /media/sdb5 ntfs-3g defaults,umask=0 0 0
    /dev/sdb6 /media/sdb6 ntfs-3g defaults,umask=0 0 0
    /dev/sdb7 /media/sdb7 ntfs-3g defaults,umask=0 0 0

    And it got error that Only root could mount /dev/sda1 on /media/sda1
    Why help me out?

  2. #2
    Linux Newbie
    Join Date
    Jun 2006
    Location
    Greece, Athens
    Posts
    214
    Start gparted and set the mount options for the ntfs partition from there.

  3. #3
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    Which version of Ubuntu are you using?
    Code is correct in /etc/fstab file. Did you reboot machine or executed this
    Code:
    sudo mount -a
    ?

    Post the output of sudo fdisk -l and df -h commands.
    Code:
    sudo fdisk -l
    df -h
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  4. #4
    Just Joined!
    Join Date
    May 2006
    Location
    London ,UK
    Posts
    74
    I'm using Ubuntu 8.04.
    fdisk -l output is:
    Disk /dev/sda: 40.0 GB, 40020664320 bytes
    255 heads, 63 sectors/track, 4865 cylinders
    Units = cylinders of 16065 * 512 = 8225280 bytes
    Disk identifier: 0x331b331a

    Device Boot Start End Blocks Id System
    /dev/sda1 * 1 1813 14562891 7 HPFS/NTFS
    /dev/sda2 1814 4865 24515190 f W95 Ext'd (LBA)
    /dev/sda5 1814 1825 96358+ 7 HPFS/NTFS
    /dev/sda6 1826 4290 19800081 7 HPFS/NTFS
    /dev/sda7 4291 4865 4618656 7 HPFS/NTFS

    Disk /dev/sdb: 80.0 GB, 80026361856 bytes
    255 heads, 63 sectors/track, 9729 cylinders
    Units = cylinders of 16065 * 512 = 8225280 bytes
    Disk identifier: 0xccdeccde

    Device Boot Start End Blocks Id System
    /dev/sdb1 * 2 1567 12578863+ 83 Linux
    /dev/sdb2 1568 9729 65561265 f W95 Ext'd (LBA)
    /dev/sdb3 1 1 8001 1 FAT12
    /dev/sdb5 1568 3188 13020651 7 HPFS/NTFS
    /dev/sdb6 3189 6375 25599546 7 HPFS/NTFS
    /dev/sdb7 6376 9729 26940973+ 7 HPFS/NTFS

    Partition table entries are not in disk order

    And
    df -h
    output is

    Filesystem Size Used Avail Use% Mounted on
    /dev/sdb1 12G 3.4G 8.0G 30% /
    varrun 251M 116K 251M 1% /var/run
    varlock 251M 0 251M 0% /var/lock
    udev 251M 80K 251M 1% /dev
    devshm 251M 0 251M 0% /dev/shm
    lrm 251M 39M 213M 16% /lib/modules/2.6.24-19-generic/volatile

    And
    mount -a output is

    Windows is hibernated, refused to mount.
    Failed to mount '/dev/sda1': Operation not permitted
    The NTFS partition is hibernated. Please resume and shutdown Windows
    properly, or mount the volume read-only with the 'ro' mount option, or
    mount the volume read-write with the 'remove_hiberfile' mount option.
    For example type on the command line:

    mount -t ntfs-3g /dev/sda1 /media/sda1 -o remove_hiberfile

    $LogFile indicates unclean shutdown (0, 0)
    Failed to mount '/dev/sda5': Operation not supported
    Mount is denied because NTFS is marked to be in use. Choose one action:

    Choice 1: If you have Windows then disconnect the external devices by
    clicking on the 'Safely Remove Hardware' icon in the Windows
    taskbar then shutdown Windows cleanly.

    Choice 2: If you don't have Windows then you can use the 'force' option for
    your own responsibility. For example type on the command line:

    mount -t ntfs-3g /dev/sda5 /media/sda5 -o force

    Or add the option to the relevant row in the /etc/fstab file:

    /dev/sda5 /media/sda5 ntfs-3g force 0 0
    $LogFile indicates unclean shutdown (0, 1)
    Failed to mount '/dev/sda6': Operation not supported
    Mount is denied because NTFS is marked to be in use. Choose one action:

    Choice 1: If you have Windows then disconnect the external devices by
    clicking on the 'Safely Remove Hardware' icon in the Windows
    taskbar then shutdown Windows cleanly.

    Choice 2: If you don't have Windows then you can use the 'force' option for
    your own responsibility. For example type on the command line:

    mount -t ntfs-3g /dev/sda6 /media/sda6 -o force

    Or add the option to the relevant row in the /etc/fstab file:

    /dev/sda6 /media/sda6 ntfs-3g force 0 0
    $LogFile indicates unclean shutdown (0, 0)
    Failed to mount '/dev/sda7': Operation not supported
    Mount is denied because NTFS is marked to be in use. Choose one action:

    Choice 1: If you have Windows then disconnect the external devices by
    clicking on the 'Safely Remove Hardware' icon in the Windows
    taskbar then shutdown Windows cleanly.

    Choice 2: If you don't have Windows then you can use the 'force' option for
    your own responsibility. For example type on the command line:

    mount -t ntfs-3g /dev/sda7 /media/sda7 -o force

    Or add the option to the relevant row in the /etc/fstab file:

    /dev/sda7 /media/sda7 ntfs-3g force 0 0
    $LogFile indicates unclean shutdown (0, 0)
    Failed to mount '/dev/sdb5': Operation not supported
    Mount is denied because NTFS is marked to be in use. Choose one action:

    Choice 1: If you have Windows then disconnect the external devices by
    clicking on the 'Safely Remove Hardware' icon in the Windows
    taskbar then shutdown Windows cleanly.

    Choice 2: If you don't have Windows then you can use the 'force' option for
    your own responsibility. For example type on the command line:

    mount -t ntfs-3g /dev/sdb5 /media/sdb5 -o force

    Or add the option to the relevant row in the /etc/fstab file:

    /dev/sdb5 /media/sdb5 ntfs-3g force 0 0
    $LogFile indicates unclean shutdown (0, 0)
    Failed to mount '/dev/sdb6': Operation not supported
    Mount is denied because NTFS is marked to be in use. Choose one action:

    Choice 1: If you have Windows then disconnect the external devices by
    clicking on the 'Safely Remove Hardware' icon in the Windows
    taskbar then shutdown Windows cleanly.

    Choice 2: If you don't have Windows then you can use the 'force' option for
    your own responsibility. For example type on the command line:

    mount -t ntfs-3g /dev/sdb6 /media/sdb6 -o force

    Or add the option to the relevant row in the /etc/fstab file:

    /dev/sdb6 /media/sdb6 ntfs-3g force 0 0
    $LogFile indicates unclean shutdown (0, 0)
    Failed to mount '/dev/sdb7': Operation not supported
    Mount is denied because NTFS is marked to be in use. Choose one action:

    Choice 1: If you have Windows then disconnect the external devices by
    clicking on the 'Safely Remove Hardware' icon in the Windows
    taskbar then shutdown Windows cleanly.

    Choice 2: If you don't have Windows then you can use the 'force' option for
    your own responsibility. For example type on the command line:

    mount -t ntfs-3g /dev/sdb7 /media/sdb7 -o force

    Or add the option to the relevant row in the /etc/fstab file:

    /dev/sdb7 /media/sdb7 ntfs-3g force 0 0

    Now what to do?

  5. #5
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    Is Windows OS installed in any NTFS Partition? Which Windows OS are you using and does it boot up properly?
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  6. #6
    Just Joined!
    Join Date
    May 2006
    Location
    London ,UK
    Posts
    74
    I've installed windows xp in this drive
    /dev/sda2 1814 4865 24515190 f W95 Ext'd (LBA)
    And windows xp in that drive working smoothly.From live cd of Ubuntu 8.04 can full access all my partition even in ntfs drive.
    so what is the solution?

  7. #7
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    /dev/sda2 1814 4865 24515190 f W95 Ext'd (LBA)
    Thats not possible. You can't install any OS in Extended Partition ( /dev/sda2 ) . It is like a container and /dev/sda5, 6 and 7 are Logical Partitions inside it.

    Anyways, boot up Windows OS and shutdown it properly. Do that 2 times atleast.
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  8. #8
    Just Joined!
    Join Date
    May 2006
    Location
    London ,UK
    Posts
    74
    It's works.
    thank you devil casper.

  9. #9
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    Glad to help you !
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •