Find the answer to your Linux question:
Results 1 to 5 of 5
I am a new (old man though) Linux user and an old has been IT administrator but never worked with anything but Winblows, Excuse me, I meant Windows NT etc.. ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Sep 2008
    Posts
    3

    Cool HP printer drivers


    I am a new (old man though) Linux user and an old has been IT administrator but never worked with anything but Winblows, Excuse me, I meant Windows NT etc..
    I got fed up with Winblows, I mean Windows XP and although I truly like the look and feel of Ubuntu, I'm truly baffled.
    Am I to understand there is NOT a printer driver for a Deskjet d2345 or my Officejet 4315v All-in-one that allows me to print booklets, etc.?
    thanks

  2. #2
    oz
    oz is offline
    forum.guy
    Join Date
    May 2004
    Location
    arch linux
    Posts
    18,733
    Welcome to the forums!

    I've never used either printer so can't say for sure, but take a look around OpenPrinting.org for your printers and more information on them.

    It appears that you are in luck on the OfficeJet 4315v:

    OpenPrinting database - Printer: HP OfficeJet 4315v all-in-one

    I was unable to find anything specific on the other printer, but you might be able to use the driver for a similar printer.

    Hope you are able to get them going.
    oz

  3. #3
    Linux Engineer Freston's Avatar
    Join Date
    Mar 2007
    Location
    The Netherlands
    Posts
    1,049
    Welcome!

    The best thing you can try is hook up the printer, fire up the browser and go to
    localhost:631
    Log in as root and see which devices are detected.

    'cuz as it seems, you are in luck: HP-Deskjet D2345. The driver they mention is installed on most Linux distro's by default, and Ubuntu is amongst them.

    If you can't access the web interface (localhost:631) then you'll need to start CUPS (Common Unix Printing System). I don't know how to do that in Ubuntu, but I think it's on by default.
    Can't tell an OS by it's GUI

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    May 2011
    Posts
    5

    similar printer issue, no idea how to use cups

    having similar trouble installing hplip-3.11.5 for HP Photosmart C4680. Terminal goes through all the setup stuff and then stops and displays a message to the effect of 'no feedback after 300seconds', i've tried restarting and running hp-setup from Terminal, but HP manager does not recognize my printer (there's nothing showing up in the device list). Can anyone help?
    I've been through enabling/disabling repositories (one of the setup instructions) and that doesn't seem to work.
    I've not tried CUPS, but all the advice i've had for the past while has said to install hplip.

  6. #5
    oz
    oz is offline
    forum.guy
    Join Date
    May 2004
    Location
    arch linux
    Posts
    18,733
    Hello and welcome aboard, mpettitt!

    I'm locking this thread because it's going on 3 year old, but please feel free to start a fresh thread of your own with any details if you are having problems with Linux.

    Thank you.
    oz

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •