Find the answer to your Linux question:
Results 1 to 4 of 4
I have a Dell system that is based on Vista using 2 250gb drives in a RAID0 configuration. One of the disks, the one with the OS, indicates there is ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Oct 2008
    Posts
    8

    cant see windows drive using ubuntu live cd to access


    I have a Dell system that is based on Vista using 2 250gb drives in a RAID0 configuration.
    One of the disks, the one with the OS, indicates there is an error but that the RAID0 system is functional.
    I tried booting through my Ubuntu Live CD as this is usually an easy way to see the drives and extract the files.
    However, Ubuntu does not show the drives in COMPUTER.
    I do see them in fdisk, one is listed with 3 partitions and having the OS in HPFS/NTFS format and the 2nd drive is listed as not having a partition table.

    Why cant I see the drives? Is it because of the raid0? I just need to extract the data and this fix has worked for non raid setups where the Windows OS has crashed and wont boot.

  2. #2
    Just Joined!
    Join Date
    Oct 2008
    Posts
    8
    This is what I got when trying to do "sudo dmraid -ay"

    ERROR: isw device for volume "ARRAY" broken on /dev/sdb in RAID set "isw_jibghiihe_ARRAY"
    ERROR: isw: wrong # of devices in RAID set "isw_jibghiihe_ARRAY" [1/2] on /dev/sdb


    Also says the NTFS volume on the first disk, sda1 is not valid.

    When trying to do apt-get install ms-sys, it says ms-sys package not found as well, in order to try to reorganize the MBR to access.

    The drives just dont show up, my usb thumb does but the 2 raid0 drives do not.

    Any thoughts?

  3. #3
    Linux Guru smolloy's Avatar
    Join Date
    Apr 2005
    Location
    CA, but from N.Ireland
    Posts
    2,414
    Ubuntu's not good with RAIDs or LVMs. Perhaps you could try a different liveCD (like Knoppix, or Fedora)?

    If they don't work, then you might have a real problem with your RAID config. Remember, RAID0 isn't really redundant (as RAID is supposed to be), and comes with a higher chance of failure than a single disc. Which is why you have backups. Right?
    Registered Linux user #388328 || Registered LFS user #15880
    AMD 64 X2 4600+ :: 2X1GB DDR2 800 :: GeForce 9400 GT 512MB :: ASUS M2N32 Deluxe :: 4X250GB SATAII
    Need instant help? Try us on IRC -- #linuxforums on freenode

  4. #4
    Linux Guru
    Join Date
    Nov 2007
    Posts
    1,746
    This is probably a RAID set made possible via a special Windows device driver. If you don't have a Linux driver for the SATA/RAID chip, you won't be able to access the drives the same way Windows does.

    Hint: If you see both HDD's, you don't have the Linux driver for the SATA/RAID chip.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •