Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 12
* * * * * Greetings from a frustrated dual-boot Linux user! I have Windows XP Pro and Ubuntu 0.10 "dual-booted" on my internal ("C") drive. Everything works fine when ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Dec 2008
    Posts
    5

    Question ~ Cannot access INTERNAL hard drive (C") from within Linux ~


    * * * * *

    Greetings from a frustrated dual-boot Linux user!

    I have Windows XP Pro and Ubuntu 0.10 "dual-booted" on my internal ("C") drive. Everything works fine when I am in either Windows or Linux. LOVE it!

    However, I cannot access any Windows files on my INTERNAL (C") drive from within Linux. (Strangely, I CAN access Windows files from an added EXTERNAL ("F") drive OK!) Can anybody out there help me out, please?

    FYI, below is my drive information:
    Code:
    Disk /dev/sda: 500.1 GB, 500107862016 bytes
    
    255 heads, 63 sectors/track, 60801 cylinders
    
    Units = cylinders of 16065 * 512 = 8225280 bytes
    
    Disk identifier: 0x0e00c6f4
    
    
       Device Boot      Start          End         Blocks     Id   System
    
    /dev/sda1   *              1       30257   243039321     7   HPFS/NTFS
    
    /dev/sda2           30258       60801   245344680     5   Extended
    
    /dev/sda5           30258       59668   236243826   83   Linux
    
    /dev/sda6           59669        60801      9100791   82   Linux swap / Solaris
    
    
    
    Disk /dev/sdb: 160.0 GB, 160041885696 bytes
    
    255 heads, 63 sectors/track, 19457 cylinders
    
    Units = cylinders of 16065 * 512 = 8225280 bytes
    
    Disk identifier: 0x000055ea
    
    
    
       Device Boot      Start          End          Blocks    Id    System
    
    /dev/sdb1                   2         9562    76798732+    f     W95 Ext'd (LBA)
    
    /dev/sdb2   *        9563       19457    79481587+    7     HPFS/NTFS
    
    /dev/sdb5                   2         9562      76798701    7     HPFS/NTFS
    
    
    

    I suspect that I have something wrong in my /etc/fstab file. Here is my filemy /etc/fstab file is listed below. Can someone please help me? THANK YOU very much!

    Code:
     
    Code:
     # /etc/fstab: static file system information.
    #
    #  -- This file has been automaticly generated by ntfs-config -- 
    #
    # <file system> <mount point>   <type>  <options>       <dump>  <pass>
    
    proc /proc proc defaults 0 0
    # Entry for /dev/sda5 :
    UUID=5f3ed23f-2921-4c8b-b88a-4f6cc1ff454f / ext3 relatime,errors=remount-ro 0 1
    # Entry for /dev/sda6 :
    UUID=35056a68-d94d-4ed7-a343-ab596cccc755 none swap sw 0 0
    /dev/scd0 /media/cdrom0 udf,iso9660 user,noauto,exec,utf8 0 0
    /dev/fd0 /media/floppy0 auto rw,user,noauto,exec,utf8 0 0
    /dev/hda2 /media/windows ntfs-3g defaults,locale=en_US.utf8 0 0
    /dev/sdc1 /media/SGate_FAgnt_ntfs-3g force 0 0
    /dev/hda1 /mnt/ntfs-sys ntfs ro,dmask=0222,fmask=0333 0 0
    /dev/sda1 /mnt/windows ntfs-3g defaults 0 0
    
    
    Last edited by devils casper; 12-23-2008 at 01:16 PM. Reason: Please use deafult font color and size only.

  2. #2
    Linux Guru jmadero's Avatar
    Join Date
    Jul 2007
    Location
    California
    Posts
    1,998
    Start up a terminal type the following:

    sudo mkdir /media/windows


    then type

    sudo mount /dev/sda1 /media/windows

    see if that works, you won't have permissions though but you should be able to read the drive. Post what happens, assuming it works I'll give you the fstab line
    Bodhi 1.3 & Bodhi 1.4 using E17
    Dell Studio 17, Intel Graphics card, 4 gigs of RAM, E17

    "The beauty in life can only be found by moving past the materialism which defines human nature and into the higher realm of thought and knowledge"

  3. #3
    Linux Guru bigtomrodney's Avatar
    Join Date
    Nov 2004
    Location
    Ireland
    Posts
    6,133
    Have you been recycling your fstab for a few years? Devices are no longer referred to as /dev/hd? regardless of the controller type. There are also entries for /dev/sdc which doesn't appear in the initial output you posted.

    Post back after following jmadero's advice and we can get this cleaned up with you.

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Guru jmadero's Avatar
    Join Date
    Jul 2007
    Location
    California
    Posts
    1,998
    While you're at it post what happens with

    sudo fdisk -l

    I know you posted a lot of stuff up there...but it's too much and I don't have the patience to go through each line so just post that because your fstab is really sloppy, if the mount works and you post the fdisk stuff I think I can write you a whole new fstab that is clean.
    Bodhi 1.3 & Bodhi 1.4 using E17
    Dell Studio 17, Intel Graphics card, 4 gigs of RAM, E17

    "The beauty in life can only be found by moving past the materialism which defines human nature and into the higher realm of thought and knowledge"

  6. #5
    Just Joined!
    Join Date
    Dec 2008
    Posts
    5

    Question

    Greetings!

    I really appreciate your response!

    Below is the result from typing sudo mkdir /media/windows in a terminal.
    Thus, typing sudo mount /dev/sda1 /media/windows, of course, did not work.
    I still cannot access my internal Widows partition.

    I know my etc/fstab file is a mess but do not know how to correct it.
    I probably know just enough to be dangerous, so treat me like a relative newbie.

    Once again, I really appreciate your help.

    Lloyd



    lloyd@lloyd-desktop:~$ sudo mkdir /media/windows
    [sudo] password for lloyd:
    mkdir: cannot create directory `/media/windows': File exists
    lloyd@lloyd-desktop:~$ sudo mount /dev/sda1 /media/windows
    lloyd@lloyd-desktop:~$



    Quote Originally Posted by jmadero View Post
    Start up a terminal type the following:

    sudo mkdir /media/windows


    then type

    sudo mount /dev/sda1 /media/windows

    see if that works, you won't have permissions though but you should be able to read the drive. Post what happens, assuming it works I'll give you the fstab line

  7. #6
    Just Joined!
    Join Date
    Dec 2008
    Posts
    5

    Question

    Quote Originally Posted by bigtomrodney View Post
    Have you been recycling your fstab for a few years? Devices are no longer referred to as /dev/hd? regardless of the controller type. There are also entries for /dev/sdc which doesn't appear in the initial output you posted.

    Post back after following jmadero's advice and we can get this cleaned up with you.
    Greetings!

    I really appreciate your response!

    I have been "Linuxing" for a few years, but this Ubuntu installation is a fresh install on a new computer
    [Dell GX280 OptiPlex, 4 Gb Ram, 500 Gb Hard Drive].
    I'm not sure where all those codes in my /etc/fstab file came from. I need help.

    Below is the result from typing sudo mkdir /media/windows in a terminal.
    Thus, typing sudo mount /dev/sda1 /media/windows, of course, did not work.
    I still cannot access my internal Widows partition.

    I know my etc/fstab file is a mess but do not know how to correct it.
    I probably know just enough to be dangerous, so treat me like a relative newbie.

    Once again, I really appreciate your help.

    Lloyd



    lloyd@lloyd-desktop:~$ sudo mkdir /media/windows
    [sudo] password for lloyd:
    mkdir: cannot create directory `/media/windows': File exists
    lloyd@lloyd-desktop:~$ sudo mount /dev/sda1 /media/windows
    lloyd@lloyd-desktop:~

    PS
    I'm new on this forum and it is really great!

  8. #7
    Linux Guru jmadero's Avatar
    Join Date
    Jul 2007
    Location
    California
    Posts
    1,998
    glad to help.

    so first off....looks like the mount worked, no errors were spit out

    So now edit your fstab

    sudo gedit /etc/fstab

    first just for the windows partition write the following line:

    /dev/sda1 /media/windows nfts defaults,users,rw 0 0

    then save and close, now do the following in terminal

    sudo chmod 777 /media/windows


    reboot, your windows partition should be good to go

    if you want me to look at the rest you'll have to post the results from sudo fdisk -l

    hope that works
    Bodhi 1.3 & Bodhi 1.4 using E17
    Dell Studio 17, Intel Graphics card, 4 gigs of RAM, E17

    "The beauty in life can only be found by moving past the materialism which defines human nature and into the higher realm of thought and knowledge"

  9. #8
    Just Joined!
    Join Date
    Dec 2008
    Posts
    5

    Question Cannot-access-internal-hard-drive

    Hello again,

    Thanks again for your reply. I followed your instructions implicitly, but still cannot access my INTERNAL Windows ("C") Drive. Below are the results from typing sudo fdisk -l.


    lloyd@lloyd-desktop:~$ sudo gedit /etc/fstab
    [sudo] password for lloyd:
    Fontconfig error: "~/.fonts.conf", line 45: junk after document element
    lloyd@lloyd-desktop:~$ sudo chmod 777 /media/windows
    lloyd@lloyd-desktop:~$
    lloyd@lloyd-desktop:~$ sudo fdisk -l

    Disk /dev/sda: 500.1 GB, 500107862016 bytes
    255 heads, 63 sectors/track, 60801 cylinders
    Units = cylinders of 16065 * 512 = 8225280 bytes
    Disk identifier: 0x0e00c6f4

    Device Boot Start End Blocks Id System
    /dev/sda1 * 1 30257 243039321 7 HPFS/NTFS
    /dev/sda2 30258 60801 245344680 5 Extended
    /dev/sda5 30258 59668 236243826 83 Linux
    /dev/sda6 59669 60801 9100791 82 Linux swap / Solaris

    Disk /dev/sdb: 160.0 GB, 160041885696 bytes
    255 heads, 63 sectors/track, 19457 cylinders
    Units = cylinders of 16065 * 512 = 8225280 bytes
    Disk identifier: 0x000055ea

    Device Boot Start End Blocks Id System
    /dev/sdb1 2 9562 76798732+ f W95 Ext'd (LBA)
    /dev/sdb2 * 9563 19457 79481587+ 7 HPFS/NTFS
    /dev/sdb5 2 9562 76798701 7 HPFS/NTFS

    Disk /dev/sdc: 250.0 GB, 250059350016 bytes
    255 heads, 63 sectors/track, 30401 cylinders
    Units = cylinders of 16065 * 512 = 8225280 bytes
    Disk identifier: 0x16c09e11

    Device Boot Start End Blocks Id System
    /dev/sdc1 1 17165 137877831 7 HPFS/NTFS
    lloyd@lloyd-desktop:~$
    lloyd@lloyd-desktop:~$



    Once again, here is my /etc/fstab file:

    # /etc/fstab: static file system information.
    #
    # -- This file has been automaticly generated by ntfs-config --
    #
    # <file system> <mount point> <type> <options> <dump> <pass>

    proc /proc proc defaults 0 0
    # Entry for /dev/sda5 :
    UUID=5f3ed23f-2921-4c8b-b88a-4f6cc1ff454f / ext3 relatime,errors=remount-ro 0 1
    # Entry for /dev/sda6 :
    UUID=35056a68-d94d-4ed7-a343-ab596cccc755 none swap sw 0 0
    /dev/scd0 /media/cdrom0 udf,iso9660 user,noauto,exec,utf8 0 0
    /dev/fd0 /media/floppy0 auto rw,user,noauto,exec,utf8 0 0
    /dev/hda2 /media/windows ntfs-3g defaults,locale=en_US.utf8 0 0
    /dev/sdc1 /media/SGate_FAgnt_ntfs-3g force 0 0
    /dev/hda1 /mnt/ntfs-sys ntfs ro,dmask=0222,fmask=0333 0 0
    /dev/sda1 /media/windows nfts defaults,users,rw 0 0

    (I know I really need help to straighten out my /etc/fstab file)

    Last edited by devils casper; 12-23-2008 at 01:20 PM.

  10. #9
    Linux User
    Join Date
    Dec 2007
    Location
    Idaho USA
    Posts
    362
    Questions:
    1) You have 2 internal hdd's, sda and sdb ?
    2) 1 external hdd, sdc ?
    3) On sda, sdb you can not mount XP partitions ?
    4) on sdc you can mount XP partitions?

    5) With the XP partitions you can mount , what is the mounted directory/ mount point ?
    6) What mount point do you want for the other XP partitions ?

    In your fstab file put a # in front of /dev/hda1 ,reboot, can you now mount sda1 XP partition in /media/windows ?

    IF so change /dev/hda2 /media/windows to /dev/sda2 /media/windows1 (keep the rest of line the same), can not have the same mount point for 2 partitions. reboot, will it now mount ?

  11. #10
    Linux Guru
    Join Date
    Oct 2007
    Location
    Tucson AZ
    Posts
    3,190
    Your fdisk -l output shows four windows partitions. The commands you were asked to enter should allow you to view files on sda1. You also have sdb2 which is marked active, sdb5 and sdc1. You need to repeat the commands for each partition and put separate entries for each in fstab. Do you have another windows operating system on sdb2? sda1 and sdb2 are both marked active (with the asterisk *).

    Enter the following commands for each partition:
    sudo mkdir /media/windows2
    sudo mkdir /media/windows3
    sudo mkdir /media/windows4

    After doing the above, open your file manager to see if the directories are there.
    If you have the file manager open before running the above commands, you will need to refresh to see them. Also, you can change the windows2,3,4 to something that makes more sense to you.

    then type:

    sudo mount /dev/sdb2 /media/windows2
    sudo mount /dev/sdb5 /media/windows3
    sudo mount /dev/sdc1 /media/windows4

    After doing this, make the changes in fstab as recommended above.

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •