Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 14
I have tried at least 10 times to install versions of Ubuntu higher than 7.10 and none will install. I reach step 4 of 7 titled: prepare partitions. At that ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jan 2009
    Location
    Virginia
    Posts
    5

    Ubuntu 8.10 problem with partition step


    I have tried at least 10 times to install versions of Ubuntu higher than 7.10 and none will install. I reach step 4 of 7 titled: prepare partitions. At that point, nothing happens. I am presented with only two active buttons: back and forward. If I go forward, I get an error that the previous step was not completed. If I go back, the step still fails. I have tried to install 8.10 on a disk that already had a running earlier version and I have tried to install it on a disk that was formatted with ext 3 and had nothing installed. The result is the same.

    Can anyone figure out what causes this problem? Is there a solution?

  2. #2
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    Hi and Welcome !

    We have to check partition structure of your Harddisk first. Boot up from any LiveCD and post the output of sudo fdisk -l command here.

    Code:
    sudo fdisk -l
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  3. #3
    Just Joined!
    Join Date
    Jan 2009
    Location
    Virginia
    Posts
    5
    Thank you. I used a Ubuntu live disk (tried Puppy, but it would not respond to the command). All I got was a list of fdisk usage. I tried every combination of the fdisk commands that I could guess, but got no response.

    I expect that I don't understand Linux well enough to be using it. At the moment, Ubuntu 7.10 is running on the machine. FWIW, I built the machine on an Asus board, with an A64/3400 cpu & 1GB ram. There is one serial HD of 120 GB. For whatever reason, only a few distributions of Lynux will run on that computer. I have had much more success (using live disks and virtual machines) on my other two computers, one of which is similar to the Linux machine, in that it uses an A64/4000 cpu.

  4. #4
    Linux Guru
    Join Date
    Oct 2007
    Location
    Tucson AZ
    Posts
    3,190
    it would not respond to the command). All I got was a list of fdisk usage
    You get the above result if you don't use sudo or if you enter the number one (1) rather than a lower case letter L in the 'fdisk -l' command.

  5. #5
    Just Joined!
    Join Date
    Jan 2009
    Location
    Virginia
    Posts
    5
    Thanks. I used sudo with the number and got the usage info. That told me that I needed to use a lower case L, so the subsequent tries were with the letter. This morning, I booted from the HD, using Ubuntu 7.10 and tried the command. It worked:

    Disk /dev/sda: 120.0 GB, 120034123776 bytes
    255 heads, 63 sectors/track, 14593 cylinders
    Units = cylinders of 16065 * 512 = 8225280 bytes
    Disk identifier: 0xfd366107

    Device Boot Start End Blocks Id System
    /dev/sda1 * 1 14218 114206053+ 83 Linux
    /dev/sda2 14219 14593 3012187+ 5 Extended
    /dev/sda5 14219 14593 3012156 82 Linux swap / Solaris

  6. #6
    Linux Guru
    Join Date
    Oct 2007
    Location
    Tucson AZ
    Posts
    3,190
    The problem is that there is no room to create a partition. Your first partition which has Ubuntu 7.10 takes up almost 117GB of your 120GB drive. The rest (3GB) is an Extended partition with your swap partition in it. There is no place to create a partition.

    I assume, since you are trying to install newer versions of Ubuntu, that you don't necessarily want Ubuntu 7.10 any longer? If that's the case, the easiest thing to do would be to start over, create new (smaller) partitions so that one doesn't take up almost your entire disk. Don't know what your intentions are, so post back?

    It would be a good idea to let us know what you plan to do. If you intend to have only one system the options suggested would be different than if you want a base system and want to experiment with other distributions. Depending upon what you use your computer for, a 5-10GB partition for Ubuntu system files with a separate but larger /home partition would work. You could also just make one partition for root/system and /home partitions.

    So, let us know if you intend to use your computer for multiple OS's. That should help someone to give you good advice.

  7. #7
    Just Joined!
    Join Date
    Jan 2009
    Location
    Virginia
    Posts
    5
    Here is the more detailed story: I was running 7.10 (I think) and everything was fine, but then I saw that I could upgrade via the internet to 8.10. So I tried it. The result was that my computer ended up trashed. So, I reinstalled 7.10, but discovered that Evolution would not run. So, I used Gparted to create two large partitions, with the smaller one being about 20 GB. The swap file partition remained. I tried to install 8.10 on the smaller (20 GB) partition, leaving the larger one for data. After several failures, I went back to 7.10. It installed on the 20 GB partition, but I couldn't remember how to set the permissions to access the other partition. After about 6 hours of searching for how to do that, I tried to reinstall 8.1, using the entire disk. Again, it would not pass the partition stage, as was the case every other time I tried. I then tried to install 7.04, using the entire disk. It worked, but could not find the applications I wanted to load, so I assumed it was obsolete. I then reinstalled 7.10 on one partition and gave up on using Evolution. I don't need multiple boots, although that would be nice to install some other distributions and pick between them. I learned from earlier attempts that I could not figure out Grub (when I tried multiple boots, the machine wouldn't run at all).

    My question was that I don't understand why I can install 7.10 but nothing higher. When I install 7.10 or 7.04 there is no problem with the partition stage. It offers to use the entire disk, or a specified partition. Both worked. But 8.10 hangs up when it reaches the partition stage and does not allow me to do anything other than to abort the installation.

    I suppose I should start a new thread, but one of the things I need to figure out is how to make an image or other backup so that I can return to something that works without having to spend several hours rebuilding Ubuntu.

  8. #8
    Linux Guru D-cat's Avatar
    Join Date
    Jan 2009
    Location
    Bounce between Dover, NH - Shapleigh, ME
    Posts
    1,638
    Couple of ideas.

    Have you tried the Alternate (text only) install disc?

    I'm thinking if you're doing the live install, the swap partition may already be mounted, which will cause any partition edits to fail.

    Doesn't explain a failure to install on existing partitions... however, I do remember from installing the server with existing partitions that I had to tell it which partitions I want to mount where. If you don't tell it which partition to mount to root (/), setup will not go forward; the errors are not exactly intuitive, and manual partitioning doesn't do this for you.

    I don't know if any of this will help, I'm just drawing a some experiences from the past. I hope you get it all work.

  9. #9
    Just Joined!
    Join Date
    Jan 2009
    Location
    Virginia
    Posts
    5
    I haven't tried the text only disk. That might work.

    The instances I tried that failed did not reach the point where I could specify a partition, or tell the installer to use the entire drive. When Hardy Herron (8.04) first came out, I tried to install it and found that it would not run. I can't remember if the failure then was that it stopped on the partition step, or if it simply would not run. When I saw that 8.10 was out, I figured the problem that I had with 8.04 might have gone away.

  10. #10
    Just Joined!
    Join Date
    Jan 2009
    Posts
    2
    hello i am having the same problem. i had windows xp home and went to check my email and the pc froze to where i had to manually shut it down. when i started it back up i got a black screen that said disk boot failure: insert system disk and press enter. well i didnt have any disks for they came as a partition on the hdd and for some reason i was never able to make the disks from the program. well i had been interested in ubuntu 8.10 for a while and this gave me the chance to try it out.i needed a system disk so i dl'ed ubuntu and burned to a disk to try it out.i can use the internet and all as long as cd is in but i can't install it cause of step 4. i am having the same problem as voltan. is the reason that my hdd is bad and i need a new one or what?

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •