Find the answer to your Linux question:
Results 1 to 4 of 4
Hi all, I have just installed Kubuntu 8,10, the problem i faced that the sound always coming from the speaker even with use the headphone How do I solve that??? ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jul 2006
    Posts
    74

    The sound still coming out form the speaker even with using the headphone!!!


    Hi all,

    I have just installed Kubuntu 8,10, the problem i faced that the sound always coming from the speaker even with use the headphone

    How do I solve that???

    Thank you..

  2. #2
    Linux Guru D-cat's Avatar
    Join Date
    Jan 2009
    Location
    Bounce between Dover, NH - Shapleigh, ME
    Posts
    1,638
    What kind of sound card to you have and where are you plugging in the headphones? The jack commonly found in front of a CD-ROM has nothing to do with the computer's sound output. If however, you are using the panel from a SB-Live, the headphones automatically muting the speakers is a software setting speciffic to the driver. The only computer I have that has one of those is over an hour away from me and not available from the Internet, and I can't remember where to find it off the top of my head... sorry. If this is your case, I'll try to look it up.

  3. #3
    Just Joined!
    Join Date
    Jul 2006
    Posts
    74
    I have installed kubuntu on my laptop, it is HP (Compaq nc8230).

    I plugged the headphone in the laptop

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Guru D-cat's Avatar
    Join Date
    Jan 2009
    Location
    Bounce between Dover, NH - Shapleigh, ME
    Posts
    1,638
    Usually, inserting headphones (or anything the right size) into the headphone jack would physically disconnect the electrical path to the speakers and redirect them to the headphones. Evidently, this laptop doesn't do that, but I'd still be surprised to find that the headphone/speaker switch was software driven.
    ---
    Actually, that is the case. According to this thread, You have to manually check the headphone sense box...
    pimpaulogy
    July 7th, 2006, 03:03 PM
    Well, not sure if this will be helpful because I am guessing most of you have done this already and I am new to this whole Linux thing, but I was also having the same problem with my HP Compaq nc8230. Turns out, Ubuntu didn't have the "switch" enabled by default to recognize the headphones when I plug them in to mute the main speakers. To fix it, opened up the Volume Control for the Intel ICH6 driver, click the switches tab, and put a check mark next to Headphone Jack Sense, and that did the trick. Like I said, not sure how helpful this would be but here you go.

    davebgimp
    July 8th, 2006, 01:45 PM
    Yeah, I've also found out that manually disabling the laptop speakers does the trick. In my case, turning off "external amplifiers" from Kmix (I use Kubuntu) does the job.
    If that doesn't work or you can't find this option, there's the manual edit of a config file method; open a terminal and do the following:

    sudo nano /etc/modprobe.d/alsa-base

    Add/edit the following line:
    options snd-hda-intel model=lenovo

    Save the file (Ctrl+x , y)

    Restart the laptop. See what happens!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •