Find the answer to your Linux question:
Results 1 to 4 of 4
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1

    Ubuntu 8.10 on a Dell Inspiron 2600 Notebook


    Ubuntu 8.10 on a Dell Inspiron 2600

    --------------------------------------------------------------------------------

    SIGH

    OK. This is beyond frustrating now. Fellow Ubuntu-on-a-dell users, please assist!! I will detail my installation issues below :

    I own a very old Inspiron 2600 Dell Laptop :

    * Celeron 1.0 GHz processor
    * 256 MB RAM
    * 20 GB HD
    * Intel 830 Graphics Chipset

    It has a few 'defects'. First off, the cd-rom won't boot anymore. I have tried everything from updating the BIOS to chatting with DELL support, and the only conclusion I have is that there is something wrong with the internal cd-rom. It still works regularly though, just won't boot. I also have a wifi PCMCIA card installed (Belkin 802.11G wireless notebook card) and that seems to be an issue ...

    Let me explain the torture I went through trying to get this to install properly. First time, I downloaded the regular version of ubuntu 8.10 and tried the install, when starting the GUI portion of the installer my screen started to display horizontal lines and a garbled what looked to be a wallpaper, but really distorted. So that didn't work. Searched the internet for answers and found that the problem has to do with my chipset (intel 830) does not play nicely with Ubuntu/Debian etc. A lot of people described editing the xorg.conf file in /etc/X11/ with certain values.

    At time of install, I still also had windows xp home edition installed. Since my cd-rom won't boot, I started the installer from within Windows and got it to a point where there was a dual boot option (ubuntu/windows). I had no idea how to edit the xorg.conf file. Then I read about an alternate installation disc for ubuntu so I tried it (using the Smart Boot Manager floppy to get it to boot from the CD-ROM). This installed finally. Yet, booting into Ubuntu still showed lines and garble.

    Tried booting into recovery mode. This gave me the option to exit to a command line. After a few attempts I finally was able to edit xorg.conf successfully to the values I found could help. This did not help at all. Now the regular boot option gives me a command prompt in a huge font. Tried starting gnome, by entering 'gnome-session', but that errored out with a 'device not found' error.

    I want to try going back to an older version of the laptop's BIOS but none of my other machines have floppy drives for the BIOS image, except for the now defunct laptop. I guess I could get the executable zip file from DELL and burn the contents onto a cd-rom and boot that cd-rom using the SMB boot manager, do you think?

    I'm at a loss here, don't know what else to do to get Ubuntu to install properly, booting into the GNOME GUI. During install and boot up, it also gave me an error having to do with my wireless card, but I just removed the card and plugged the laptop directly into my router using an ethernet cable.

    Help. Is there anybody out there that can help me, give me some tips to get this to working. I'm a Linux newbie so you have to be gentle. I most definitely appreciate any help you can give me.

    Thanks!!

  2. #2
    Linux Guru D-cat's Avatar
    Join Date
    Jan 2009
    Location
    Bounce between Dover, NH - Shapleigh, ME
    Posts
    1,638
    Do NOT flash the BIOS unless there is no other way. I have killed more computers than I have saved that way.

    In command recovery mode (which makes you root, should have the "#" prompt):

    nano /boot/grub/menu.lst

    Find your default Ubuntu section, on the kernel line, add vga=771 (this is 800x600 mode, which is good for low RAM graphics cards. The splash will be oversized (or you can remove that here too if desired), but the lines should at least disappear from boot)

    kernel /boot/vmlinuz-(version)-generic root=UUID=(distro partition's UUID) ro vga=771
    In mine, I have removed both the "splash" and the "quiet" keys so I can see exactly what's going on when. This is preference. That should sove the lines on boot problem, but there may still be an Xserver issue.

    [ctrl + x , y] to save.

    If you post in code the contents of your xorg.conf, I might be able to help you.

    ---

    I note that his laptop uses shared memory for video.
    How much memory did you assign to the video card? If you're trying to run too high a graphics mode on not enough allocated video ram, you could be bombing out the card. For 1024x768x24bit (which is likely what you're defaulting), you should have at least 16 MB to the video.

    Also, with such a low RAM system, you should have a decent swap partition defined, I'd say about 400 MB.

    In all honesty, I'd suggest a different distro for this computer. DSL and Puppy (probably an older version, like 2.01) are the favs for low spec systems. These are not minimalist distros, more like cut the fat full featured distros designed for older hardware. They are also designed for live boot (off CD), but can be installed on the hard drive as well.

    Good luck, I hope you find something that works.
    Last edited by D-cat; 03-23-2009 at 04:19 PM. Reason: I didn't see you typed you had 256 MB RAM, removed references.

  3. #3
    Linux User saivin's Avatar
    Join Date
    Dec 2008
    Location
    Bengaluru, India
    Posts
    305
    Hi,
    Post the out put of your /etc/X11/xorg.conf. (But wrap it with CODE tags). Others may guide you better.

    In the meantime, whenever you have problem with your native graphics card driver, you can almost always take refuge in the VESA driver. In your xorg.conf file change whatever you have mentioned under driver to Vesa. Save and reboot and check.
    A candle looses nothing by lighting other candles. - Khalil Zibran.
    Registered Linux User #490076

  4. $spacer_open
    $spacer_close
  5. #4

    This Is a Tough One

    I've installed Ubuntu and other variants of Linux on close to 10 different machines by now, and this was definitely the toughest install I've ever seen.

    It turns out that you need to downgrade from BIOS A11 to A08 to resolve the flickering/bands issue. As far as I can tell the vga=711 trick only errors out. Alternate CD appears to be the only way to install. This guy seems to have had pretty good success:

    hxxp://vvv.apfrod.cqm/works/2008/03/15/ubuntu_8_04_hardy_heron_on_dell_inspiron_2600

    Note that the 9.04 kernel fails to boot; it just hangs on some PCI error, at least with the A08 BIOS.

    I thought Ubuntu was designed for machines like this: open-source Intel GPU and standard Intel chipset and CPU. I upgraded this one's Celeron CPU to the fastest PIII-M Tualatin CPU I could find; only cost $6 on eBay.

    I also found that none of these BIOSes could boot from USB. I ended up borrowing the DVD drive from another laptop to do the install, since a network install seemed like a pain to me, and the built-in CD drive wouldn't boot anything I'd burnt.

    Amazing, really. I guess there is such thing as hardware that's too old for Linux. Wow.

    Notes:

    I thought I'd also add--so that you all can pity me--that I upgraded the RAM from 256 MB to 384. Also upgraded the hard drive. USB devices will not boot. USB is only 1.0 anyway. The CD ROM, though never used, was dead. I only had DVDs lying around so I bought CD-Rs just for this machine, and it wouldn't even read them. Can someone say budget?!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •